Network doesn't work after some time on ZyXEL P-2812HNU-F1

About two weeks ago I;ve bought ZyXEL P-2812HNU-F1 router with installed LEDE Reboot 17.01.4. I configured it and everything worked fine, but after some time wifi stopped working. I was connected to wifi network, but couldn't connect to my local devices(even router) or wan servers. I've got computer connected with cable to this router, and sometimes it works when wifi not, and sometimes it also doesn't work. So I have to restart this router every morning. Sometimes after this restart network doesn't work after 10-30 minutes and I have to restart again. After this everything works fine until next morning. I also remember, that once network get down while I was using it at night. Do you have any idea why this is happening? How can I prevent this?

SSH in to the router and run the following...

cat /etc/config/network

cat /etc/config/wireless

Note: Make sure to obscure the "option key" value(s) in the wireless config results before posting.

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7e:7f2c:504f::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'
        option xfer_mode 'ptm'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        option _orig_ifname 'eth0.1'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '00:01:02:03:04:05'

config interface 'wan'
        option _orig_ifname 'ptm0'
        option _orig_bridge 'false'
        option proto 'dhcp'
        option ifname 'eth0'

config device 'wan_dev'
        option name 'ptm0'
        option macaddr '00:01:02:03:04:06'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0 5 6t'

config interface 'wanport'
        option type 'bridge'
        option _orig_ifname 'eth0.2 wlan0'
        option _orig_bridge 'true'
        option proto 'static'
        option ipaddr '192.168.7.10'
        option netmask '255.255.255.0'
        option gateway '192.168.7.1'
        option dns '8.8.8.8'
        option ifname 'eth0.2'

config interface 'cjdns'
        option proto 'none'
        option type 'bridge'
        option _orig_ifname 'tuncjdns'
        option _orig_bridge 'true'
        option ifname 'tuncjdns'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:0e.0'
        option htmode 'HT20'
        option country '00'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'Matesiakowie'
        option network 'lan'

I configured one lan port as wan, because my wan port doesn't work. I think I've done it with this blog post https://onetransistor.blogspot.com/2017/04/wan-port-openwrt-lede-vlan.html

I suffered from a similar issue and wrote about it another thread: [Solved] Wireless interruption on Zyxel P2812HNU-F1. I ended up resolving my issue by installing a separate USB wireless adapter. Cross-check against my findings (especially the kernel logs that I get when the problem occurs) and determine if you are looking at the same problem.