Network device is not present

While setting up a new interface on wlan0, things go well

Protocol: Static address
Uptime: 0h 1m 7s
MAC: 80:3F:5D:C3:4F:D5
RX: 2.44 KB (32 Pkts.)
TX: 732.88 KB (7092 Pkts.)
IPv4: 172.16.2.1/24

but after reboot I get this, "Network device is not present"

Protocol: Static address
MAC: 80:3F:5D:C3:4F:D5
RX: 0 B (0 Pkts.)
TX: 689.42 KB (6667 Pkts.)
Error: Network device is not present    << ========

Why? What am I doing wrong?


Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

I'm not sure which one of the following fixed the problem.
1: i removed the dots in the ssid. ie: wifi1-2.4 to wifi1-2-4
2: i have also noticed that in /etc/config/wireless, there was a missing option. So I added it manually. note the option ifname 'wlan1'

before 
config interface 'wlanmesh'
        option proto 'static'
        list dns '8.8.8.8'
        option force_link '0'
        option delegate '0'
        option netmask '255.255.255.0'
        option gateway '172.16.1.1'
        option broadcast '172.16.1.255'
        option ipaddr '172.16.1.2'

after
config interface 'wlanmesh'
        option proto 'static'
        list dns '8.8.8.8'
        option force_link '0'
        option delegate '0'
        option netmask '255.255.255.0'
        option gateway '172.16.1.1'
        option broadcast '172.16.1.255'
        option ipaddr '172.16.1.2'
        option ifname 'wlan1'

root@OpenWrt:~# cat /etc/os-release
NAME="OpenWrt"
VERSION="19.07.3"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt 19.07.3"
VERSION_ID="19.07.3"
HOME_URL="https://openwrt.org/"
BUG_URL="https://bugs.openwrt.org/"
SUPPORT_URL="https://forum.openwrt.org/"
BUILD_ID="r11063-85e04e9f46"
OPENWRT_BOARD="ramips/mt76x8"
OPENWRT_ARCH="mipsel_24kc"
OPENWRT_TAINTS=""
OPENWRT_DEVICE_MANUFACTURER="OpenWrt"
OPENWRT_DEVICE_MANUFACTURER_URL="https://openwrt.org/"
OPENWRT_DEVICE_PRODUCT="Generic"
OPENWRT_DEVICE_REVISION="v0"
OPENWRT_RELEASE="OpenWrt 19.07.3 r11063-85e04e9f46"

Wifi device names are dynamically created thus not predictable. So don't put an ifname in /etc/config/network. In /etc/config/wireless connect the device to the network with option network.

It is normal for "device not present" on a STA interface which is not connected to its AP, or an AP that is forced down due to having an unconnected STA on the same radio. This should resolve once connection is made.

(Pre-defined wifi device names can be configured with option ifname in /etc/config/wireless, but this is not conventional).

there is no sta on this device. wlan0 is an AP. wlan1 is a mesh.