Network device in not present

Hiii

I keep getting this error with DS-Lite interface “error: Network device in not Present”.

Attached below is the config/network & config /firewall files

/etc/config/network

config interface 'loopback'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
option device 'lo'

config globals 'globals'
option ula_prefix 'fdab:620f:3d62::/48'

config interface 'lan'
option proto 'static'
option device 'eth1'
option ipaddr '10.0.0.2'
option netmask '255.255.255.0'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'

config interface 'natt'
option proto 'dhcp'
option device 'eth0'

config interface 'wan'
option proto 'static'
option ip6add '2001:db8:0:1::1/64'
option device 'eth2'
list ip6addr '2001:db8:0:1::1'

config interface 'wan6'
option proto 'dslite'
option peeraddr '2001:db8:0:1::2'
option ip6addr '2001:db8:0:1::1'
option tunlink 'wan'
option encaplimit 'ignore'

/etc/config/firewall

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1


config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user

ssh in and logread? Or LuCI-->status-->system log?

Wed Aug  4 16:01:35 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 16:01:35 2021 daemon.notice netifd: natt (19687): udhcpc: received SIGTERM
Wed Aug  4 16:01:35 2021 daemon.notice netifd: natt (19687): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 16:01:35 2021 daemon.notice netifd: natt (19687): udhcpc: sending release
Wed Aug  4 16:01:35 2021 daemon.notice netifd: natt (19687): udhcpc: entering released state
Wed Aug  4 16:01:35 2021 daemon.notice netifd: natt (19687): Command failed: Permission denied
Wed Aug  4 16:01:35 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 16:01:35 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 16:01:35 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 16:01:35 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 16:01:35 2021 kern.info kernel: [59985.697459] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 16:01:40 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:01:40 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:01:41 2021 kern.info kernel: [59991.740616] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 16:01:41 2021 kern.info kernel: [59991.744558] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 16:01:41 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 16:01:41 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 16:01:41 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 16:01:41 2021 daemon.notice netifd: natt (19899): udhcpc: started, v1.33.1
Wed Aug  4 16:01:41 2021 daemon.notice netifd: natt (19899): udhcpc: sending discover
Wed Aug  4 16:01:41 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:01:42 2021 daemon.notice netifd: natt (19899): udhcpc: sending select for 192.168.172.156
Wed Aug  4 16:01:42 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:01:42 2021 daemon.notice netifd: natt (19899): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 16:01:42 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 16:01:42 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 16:16:42 2021 daemon.notice netifd: natt (19899): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 16:16:42 2021 daemon.notice netifd: natt (19899): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 16:34:04 2021 daemon.notice netifd: Network device 'eth0' link is down
Wed Aug  4 16:34:04 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 16:34:04 2021 kern.info kernel: [61365.311868] e1000: eth0 NIC Link is Down
Wed Aug  4 16:34:04 2021 daemon.notice netifd: natt (19899): udhcpc: received SIGTERM
Wed Aug  4 16:34:04 2021 daemon.notice netifd: natt (19899): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 16:34:04 2021 daemon.notice netifd: natt (19899): udhcpc: sending release
Wed Aug  4 16:34:04 2021 daemon.notice netifd: natt (19899): udhcpc: entering released state
Wed Aug  4 16:34:04 2021 daemon.notice netifd: natt (19899): Command failed: Permission denied
Wed Aug  4 16:34:04 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 16:34:04 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 16:34:04 2021 kern.info kernel: [61365.530330] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 16:34:04 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 16:34:04 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 16:34:09 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:34:10 2021 kern.info kernel: [61371.612463] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 16:34:10 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 16:34:10 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 16:34:10 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 16:34:10 2021 kern.info kernel: [61371.614240] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 16:34:10 2021 daemon.notice netifd: natt (20111): udhcpc: started, v1.33.1
Wed Aug  4 16:34:10 2021 daemon.notice netifd: natt (20111): udhcpc: sending discover
Wed Aug  4 16:34:10 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:34:11 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:34:11 2021 daemon.notice netifd: natt (20111): udhcpc: sending select for 192.168.172.156
Wed Aug  4 16:34:11 2021 daemon.notice netifd: natt (20111): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 16:34:11 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 16:34:11 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 16:34:18 2021 daemon.notice netifd: Network device 'eth0' link is down
Wed Aug  4 16:34:18 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 16:34:18 2021 kern.info kernel: [61379.675170] e1000: eth0 NIC Link is Down
Wed Aug  4 16:34:18 2021 daemon.notice netifd: natt (20111): udhcpc: received SIGTERM
Wed Aug  4 16:34:18 2021 daemon.notice netifd: natt (20111): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 16:34:18 2021 daemon.notice netifd: natt (20111): udhcpc: sending release
Wed Aug  4 16:34:18 2021 daemon.notice netifd: natt (20111): udhcpc: entering released state
Wed Aug  4 16:34:18 2021 daemon.notice netifd: natt (20111): Command failed: Permission denied
Wed Aug  4 16:34:18 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 16:34:18 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 16:34:18 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 16:34:18 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 16:34:18 2021 kern.info kernel: [61379.771157] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 16:34:22 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 16:34:22 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 16:34:22 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 16:34:22 2021 kern.info kernel: [61383.804099] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 16:34:22 2021 kern.info kernel: [61383.805707] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 16:34:22 2021 daemon.notice netifd: natt (20283): udhcpc: started, v1.33.1
Wed Aug  4 16:34:22 2021 daemon.notice netifd: natt (20283): udhcpc: sending discover
Wed Aug  4 16:34:22 2021 daemon.notice netifd: natt (20283): udhcpc: sending select for 192.168.172.156
Wed Aug  4 16:34:22 2021 daemon.notice netifd: natt (20283): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 16:34:22 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 16:34:22 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 16:34:23 2021 daemon.warn dnsmasq-dhcp[15787]: no address range available for DHCP request via eth0
Wed Aug  4 16:34:23 2021 daemon.warn dnsmasq-dhcp[15787]: no address range available for DHCP request via eth0
Wed Aug  4 16:34:24 2021 daemon.notice netifd: Network device 'eth0' link is down
Wed Aug  4 16:34:24 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 16:34:24 2021 kern.info kernel: [61385.820141] e1000: eth0 NIC Link is Down
Wed Aug  4 16:34:24 2021 daemon.notice netifd: natt (20283): udhcpc: received SIGTERM
Wed Aug  4 16:34:24 2021 daemon.notice netifd: natt (20283): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 16:34:24 2021 daemon.notice netifd: natt (20283): udhcpc: sending release
Wed Aug  4 16:34:24 2021 daemon.notice netifd: natt (20283): udhcpc: entering released state
Wed Aug  4 16:34:24 2021 daemon.notice netifd: natt (20283): Command failed: Permission denied
Wed Aug  4 16:34:24 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 16:34:24 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 16:34:24 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 16:34:24 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 16:34:24 2021 kern.info kernel: [61385.901916] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 16:34:28 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 16:34:28 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 16:34:28 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 16:34:28 2021 kern.info kernel: [61389.949051] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 16:34:28 2021 kern.info kernel: [61389.951152] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 16:34:28 2021 daemon.notice netifd: natt (20455): udhcpc: started, v1.33.1
Wed Aug  4 16:34:28 2021 daemon.notice netifd: natt (20455): udhcpc: sending discover
Wed Aug  4 16:34:28 2021 daemon.notice netifd: natt (20455): udhcpc: sending select for 192.168.172.156
Wed Aug  4 16:34:28 2021 daemon.notice netifd: natt (20455): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 16:34:28 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 16:34:28 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 16:34:29 2021 daemon.warn dnsmasq-dhcp[15787]: no address range available for DHCP request via eth0
Wed Aug  4 16:34:29 2021 daemon.warn dnsmasq-dhcp[15787]: no address range available for DHCP request via eth0
Wed Aug  4 16:49:28 2021 daemon.notice netifd: natt (20455): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 16:55:04 2021 daemon.notice netifd: Network device 'eth0' link is down
Wed Aug  4 16:55:04 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 16:55:04 2021 kern.info kernel: [62625.614927] e1000: eth0 NIC Link is Down
Wed Aug  4 16:55:04 2021 daemon.notice netifd: natt (20455): udhcpc: received SIGTERM
Wed Aug  4 16:55:04 2021 daemon.notice netifd: natt (20455): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 16:55:04 2021 daemon.notice netifd: natt (20455): udhcpc: sending release
Wed Aug  4 16:55:04 2021 daemon.notice netifd: natt (20455): udhcpc: entering released state
Wed Aug  4 16:55:04 2021 daemon.notice netifd: natt (20455): Command failed: Permission denied
Wed Aug  4 16:55:04 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 16:55:04 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 16:55:04 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 16:55:04 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 16:55:04 2021 kern.info kernel: [62625.765987] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 16:55:09 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:55:10 2021 kern.info kernel: [62631.804430] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 16:55:10 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 16:55:10 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 16:55:10 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 16:55:10 2021 kern.info kernel: [62631.806844] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 16:55:10 2021 daemon.notice netifd: natt (20651): udhcpc: started, v1.33.1
Wed Aug  4 16:55:10 2021 daemon.notice netifd: natt (20651): udhcpc: sending discover
Wed Aug  4 16:55:10 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 16:55:10 2021 daemon.notice netifd: natt (20651): udhcpc: sending select for 192.168.172.156
Wed Aug  4 16:55:10 2021 daemon.notice netifd: natt (20651): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 16:55:10 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 16:55:10 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 16:55:11 2021 daemon.warn dnsmasq-dhcp[15787]: no address range available for DHCP request via eth0
Wed Aug  4 17:10:10 2021 daemon.notice netifd: natt (20651): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 17:10:10 2021 daemon.notice netifd: natt (20651): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 17:34:52 2021 daemon.notice netifd: natt (20651): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 17:34:52 2021 daemon.notice netifd: natt (20651): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 17:49:52 2021 daemon.notice netifd: natt (20651): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 17:49:52 2021 daemon.notice netifd: natt (20651): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 18:04:52 2021 daemon.notice netifd: natt (20651): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 18:04:52 2021 daemon.notice netifd: natt (20651): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 18:19:52 2021 daemon.notice netifd: natt (20651): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 18:19:52 2021 daemon.notice netifd: natt (20651): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 18:34:53 2021 daemon.notice netifd: natt (20651): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 18:34:53 2021 daemon.notice netifd: natt (20651): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 18:49:53 2021 daemon.notice netifd: natt (20651): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 18:49:53 2021 daemon.notice netifd: natt (20651): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 19:04:09 2021 kern.info kernel: [69789.349816] e1000: eth0 NIC Link is Down
Wed Aug  4 19:04:09 2021 daemon.notice netifd: Network device 'eth0' link is down
Wed Aug  4 19:04:09 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 19:04:09 2021 daemon.notice netifd: natt (20651): udhcpc: received SIGTERM
Wed Aug  4 19:04:09 2021 daemon.notice netifd: natt (20651): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 19:04:09 2021 daemon.notice netifd: natt (20651): udhcpc: sending release
Wed Aug  4 19:04:09 2021 daemon.notice netifd: natt (20651): udhcpc: entering released state
Wed Aug  4 19:04:09 2021 daemon.notice netifd: natt (20651): Command failed: Permission denied
Wed Aug  4 19:04:09 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 19:04:09 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 19:04:09 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 19:04:09 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 19:04:09 2021 kern.info kernel: [69789.511957] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 19:04:14 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 19:04:14 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 19:04:16 2021 kern.info kernel: [69795.555935] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 19:04:16 2021 kern.info kernel: [69795.557827] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 19:04:16 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 19:04:16 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 19:04:16 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 19:04:16 2021 daemon.notice netifd: natt (20999): udhcpc: started, v1.33.1
Wed Aug  4 19:04:16 2021 daemon.notice netifd: natt (20999): udhcpc: sending discover
Wed Aug  4 19:04:16 2021 daemon.notice netifd: natt (20999): udhcpc: sending select for 192.168.172.156
Wed Aug  4 19:04:17 2021 daemon.notice netifd: natt (20999): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 19:04:17 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 19:04:17 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 19:04:18 2021 daemon.notice netifd: Network device 'eth0' link is down
Wed Aug  4 19:04:18 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 19:04:18 2021 kern.info kernel: [69797.570579] e1000: eth0 NIC Link is Down
Wed Aug  4 19:04:18 2021 daemon.notice netifd: natt (20999): udhcpc: received SIGTERM
Wed Aug  4 19:04:18 2021 daemon.notice netifd: natt (20999): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 19:04:18 2021 daemon.notice netifd: natt (20999): udhcpc: sending release
Wed Aug  4 19:04:18 2021 daemon.notice netifd: natt (20999): udhcpc: entering released state
Wed Aug  4 19:04:18 2021 daemon.notice netifd: natt (20999): Command failed: Permission denied
Wed Aug  4 19:04:18 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 19:04:18 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 19:04:18 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 19:04:18 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 19:04:18 2021 kern.info kernel: [69797.652213] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 19:04:22 2021 kern.info kernel: [69801.697809] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 19:04:22 2021 kern.info kernel: [69801.700441] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 19:04:22 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 19:04:22 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 19:04:22 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 19:04:22 2021 daemon.notice netifd: natt (21114): udhcpc: started, v1.33.1
Wed Aug  4 19:04:22 2021 daemon.notice netifd: natt (21114): udhcpc: sending discover
Wed Aug  4 19:04:22 2021 daemon.notice netifd: natt (21114): udhcpc: sending select for 192.168.172.156
Wed Aug  4 19:04:22 2021 daemon.notice netifd: natt (21114): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 19:04:22 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 19:04:22 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 19:04:24 2021 daemon.notice netifd: Network device 'eth0' link is down
Wed Aug  4 19:04:24 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 19:04:24 2021 daemon.notice netifd: natt (21114): udhcpc: received SIGTERM
Wed Aug  4 19:04:24 2021 daemon.notice netifd: natt (21114): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 19:04:24 2021 daemon.notice netifd: natt (21114): udhcpc: sending release
Wed Aug  4 19:04:24 2021 daemon.notice netifd: natt (21114): udhcpc: entering released state
Wed Aug  4 19:04:24 2021 kern.info kernel: [69803.714044] e1000: eth0 NIC Link is Down
Wed Aug  4 19:04:24 2021 daemon.notice netifd: natt (21114): Command failed: Permission denied
Wed Aug  4 19:04:24 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 19:04:24 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 19:04:24 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 19:04:24 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 19:04:24 2021 kern.info kernel: [69803.796868] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 19:04:28 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 19:04:28 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 19:04:28 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 19:04:28 2021 kern.info kernel: [69807.841596] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 19:04:28 2021 kern.info kernel: [69807.843161] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 19:04:28 2021 daemon.notice netifd: natt (21286): udhcpc: started, v1.33.1
Wed Aug  4 19:04:28 2021 daemon.notice netifd: natt (21286): udhcpc: sending discover
Wed Aug  4 19:04:28 2021 daemon.notice netifd: natt (21286): udhcpc: sending select for 192.168.172.156
Wed Aug  4 19:04:28 2021 daemon.notice netifd: natt (21286): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 19:04:28 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 19:04:28 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 19:04:28 2021 daemon.warn dnsmasq-dhcp[15787]: no address range available for DHCP request via eth0
Wed Aug  4 19:04:28 2021 daemon.warn dnsmasq-dhcp[15787]: no address range available for DHCP request via eth0
Wed Aug  4 19:19:28 2021 daemon.notice netifd: natt (21286): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 19:19:28 2021 daemon.notice netifd: natt (21286): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 20:22:34 2021 daemon.notice netifd: natt (21286): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 20:22:34 2021 daemon.notice netifd: natt (21286): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 20:37:34 2021 daemon.notice netifd: natt (21286): udhcpc: sending renew to 192.168.172.254
Wed Aug  4 20:37:34 2021 daemon.notice netifd: natt (21286): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 20:43:07 2021 daemon.notice netifd: Network device 'eth0' link is down
Wed Aug  4 20:43:07 2021 daemon.notice netifd: Interface 'natt' has link connectivity loss
Wed Aug  4 20:43:07 2021 daemon.notice netifd: natt (21286): udhcpc: received SIGTERM
Wed Aug  4 20:43:07 2021 daemon.notice netifd: natt (21286): udhcpc: unicasting a release of 192.168.172.156 to 192.168.172.254
Wed Aug  4 20:43:07 2021 daemon.notice netifd: natt (21286): udhcpc: sending release
Wed Aug  4 20:43:07 2021 daemon.notice netifd: natt (21286): udhcpc: entering released state
Wed Aug  4 20:43:07 2021 daemon.notice netifd: natt (21286): Command failed: Permission denied
Wed Aug  4 20:43:07 2021 daemon.notice netifd: Interface 'natt' is now down
Wed Aug  4 20:43:07 2021 kern.info kernel: [72841.063868] e1000: eth0 NIC Link is Down
Wed Aug  4 20:43:07 2021 daemon.notice netifd: Interface 'natt' is disabled
Wed Aug  4 20:43:07 2021 daemon.notice netifd: Interface 'natt' is enabled
Wed Aug  4 20:43:07 2021 daemon.warn dnsmasq[15787]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Wed Aug  4 20:43:07 2021 kern.info kernel: [72841.190204] 8021q: adding VLAN 0 to HW filter on device eth0
Wed Aug  4 20:43:12 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 20:43:12 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 20:43:26 2021 kern.info kernel: [72859.587327] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Wed Aug  4 20:43:26 2021 kern.info kernel: [72859.591424] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Wed Aug  4 20:43:26 2021 daemon.notice netifd: Network device 'eth0' link is up
Wed Aug  4 20:43:26 2021 daemon.notice netifd: Interface 'natt' has link connectivity
Wed Aug  4 20:43:26 2021 daemon.notice netifd: Interface 'natt' is setting up now
Wed Aug  4 20:43:26 2021 daemon.notice netifd: natt (21538): udhcpc: started, v1.33.1
Wed Aug  4 20:43:26 2021 daemon.notice netifd: natt (21538): udhcpc: sending discover
Wed Aug  4 20:43:26 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 20:43:26 2021 daemon.notice netifd: natt (21538): udhcpc: sending select for 192.168.172.156
Wed Aug  4 20:43:26 2021 daemon.warn dnsmasq-dhcp[15787]: DHCP packet received on eth0 which has no address
Wed Aug  4 20:43:26 2021 daemon.notice netifd: natt (21538): udhcpc: lease of 192.168.172.156 obtained, lease time 1800
Wed Aug  4 20:43:26 2021 daemon.notice netifd: Interface 'natt' is now up
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: reading /tmp/resolv.conf.d/resolv.conf.auto
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain test
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain onion
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain localhost
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain local
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain invalid
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain bind
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: using only locally-known addresses for domain lan
Wed Aug  4 20:43:26 2021 daemon.info dnsmasq[15787]: using nameserver 192.168.172.2#53
Wed Aug  4 20:46:35 2021 daemon.err uhttpd[2723]: luci: accepted login on /admin/network/network for root from 192.168.172.1

The file is too big, I only copy the the last 50% of it.
FYI, I only changed the interface name yestrday and it looks like this now: -

Do you have internet connectivity? Did your provider give you an AFTR address?

Shouldn't wan6 also have eth2 defined?

OR should it have defined an ifname?

config interface 'wan'
option ifname 'eth1'
option proto 'dhcp' #ignore

config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6' #ignore

Additional reading....

https://bugs.openwrt.org/index.php?do=details&task_id=1501

Which dnsmasq do you have installed?
What version of OpenWRT are you running?
What router are you using?

I must clarify that I am building the whole topology of DS-Lite in a testbed.
So, I am trying to build the below topology: -

I do have IPv4 connectivity through my eth0 (NAT) which sub-natted from my main host (my pc) NIC.
I am also building my own AFTR using OpenWrt, and I have the same issue there:-

There is no need, check the last line here: -

The whole topology is built using vmware VMs, as explained here: -

Below is the system overview: -

What NIC? Swap NICs?

https://kb.vmware.com/s/article/1034782

Swap PCs? Swap CPUs?

https://www.vmware.com/resources/compatibility/search.php?deviceCategory=cpu

All patched up? What rev?

I don't know if we are on the same page.
I am connected to my ISP though my home router, which has the address is 192.168.0.1
I am connecting to it through my PC, I am using VMware workstation hyperviser upon my pc.
So, I am using a different VM network, like connection from the host to the B4 in vmnet 11, connection between b4 and AFTR in vmnet12, etc.
Every topology element has eth0 with as nat interface with 192.168.172.2 gateway.
As for the error I am seeing in Luci interface, Am I supposed to see DS-Lite as a seperate network device when I type "ip add" command in CLI ??

I don't know if your VM hardware is compatible with the recommended hardware list.

"Also note that dslite doesn't support ipaddr or netmask parameters since
RFC6333 specifies fixed IPv4 addresses so these parameters do nothing." Quoted from the link below:

https://openwrt-devel.openwrt.narkive.com/aKljOoKw/ds-lite-interface-is-not-coming-up

I have seen other recommendations like using a known good router that supports Ds-lite to verify the ISP is supporting it - ie. the ISP provided router.

If that works then see if you can get an openWRT based router to connect and then refer to the network settings used as a guide for your VM.

If you are trying to make your own B4 and AFTR try doing it first with a couple of older inexpensive routers (using openWRT) from some of the openWRT guides (or search the forums) so you know they will work. Then use those configs as guidelines.

HTH

??? It doesn't look like it auto configured correctly. Manually add it?

Wan6-ds-lite interface is being tunneled using 'wan'.
In 'wan' interface there is eth2 device configured.
So that should do the trick.
I tried to add 'eth2' device in 'wan6', it didn't change anything either.

Thanks for your support anyway man.

Make sure that IPv6 gateway is set on inteface wan.

Here are some useful notes I got while I was strugged with this issue.

Error: Network device is not present seems to come from dslite.sh.

See: https://github.com/openwrt/openwrt/blob/1e4469b090a7e3234345c1b7f17c956ec7dc0b81/package/network/ipv6/ds-lite/files/dslite.sh#L27

This file is deployed at /lib/netifd/proto/dslite.sh inside openwrt.

In some cases proto_add_host_dependency will return exit code 4 (UBUS_STATUS_NOT_FOUND).
And shell script seems to be terminated then.

We can observe this behavior by modifying shell script like following:

	( proto_add_host_dependency "$cfg" "::" "$tunlink" && logger ok || logger err $? )

Note that it needs restart of /sbin/netifd process, when we change dslite.sh and needs to reflected correctly.
This will help: service network restart

The log can be seen from either:

  • OpenWrt: StatusSystem Log
  • Shell: logread | grep "user.notice root:"

proto_add_host_dependency seems to be used to propagate ifdown/up events coming from underlying iface (like wan).
e.g. whenever wan is restarted, dslite is also restarted.

See also: https://openwrt.org/docs/guide-developer/network-scripting

	( proto_add_host_dependency "$cfg" "::" "$tunlink" )

The 2nd arg "::" seems to indicate "find the interface having IPv6 default gateway".

Although dslite is usually activated on valid IPv6 enabled network, sometimes we build easy sandbox for testing purpose.

Thus changing from "::" to "" will skip checking of default gateway.