Network configuration Linksys WRT3200ACM-EU + DGS-1008P


my Name is Markus and i am new here and new to OpemWrt. I am located in Austria and my native Language is German so please excuse my eventually bad english.

I habe tried OpenWrt on my WRT3200ACM and the installation worked without any Problems. I was able to setup Wifi and was able to get internet Access when directly connected to the router via LAN.

But i was not able to Ping any other Devices in my network that are connected via a separate switch.

I have a D-Link DGS-1008P Switch connected to Lan Port 1 of the Router. All Devices connected to the Switch do not have access to the Internet.

I don´t know what to do. Can some give me some advice?

Thank you very much!

That sounds strange.
This is just an unmanaged switch.
Everything on the host side should look the same for the client.
Please show the output of "ipconfig" for both connections.

That is an unmanaged switch -- there is no special configuration required to make it work.

As a test, unplug the switch and connect a computer directly to port 1 of the router -- does it get an IP via DHCP and have normal connectivitiy?

If that works, unplug the computer and plug the switch back in. Then plug your computer into the switch and see if it works. If things don't work properly, check your cables.

I have tested the following combinations:

Router with Stock Firmware and the switch after it - > everything works without Problem. Every device is reachable and is connected to the Internet.

Router with openwrt (21.02.1) in default config and nothing else changed - > only Devices directly connected to the Router get an IP and Show up in the Status Page of the Router. Even Devices with fixed IP Adresses are not reachable from one of the Routers LAN ports.
The network clients which are connected to the switch can communicate, but not with anything that is connected to the Router Or the Router itself.

When i activate the wlan on the Router in openwrt connected Devices get an IP and can access the Internet without Problems.

At this Moment the Router i running with the stock Firmware and everything works.

Your lan addresses with the stock firmware may be different than the default config of OpenWrt. By default, OpenWrt uses for the lan, and then router itself will be at

If you have devices with static ip assignments, you need to check the ip, subnet mask, dns, and gateway/router addresses to make sure they are correct for the way the router is configured. Or, change the network definition on the router to match what you were using before. likewise, devices that use dhcp need to be forced to renew their lease. Bouncing the port or rebooting the device will do the trick here.

Thank you @psherman for your help.

You are right, in the default config i get ip adresses in the 192.168.1.x Range. This is so with the stock Firmware and with the Default OpenWrt. The devices in my Lan with fixed IPs all have IP adresses in that Range ( for example).
Subnet Mask is on all devices.

When i am directly connected to the router with openwrt i get the ip, with as Gateway. So the Devices with fixed IP´s should be able to connect to the Router, even the dhcp is not working?

Also i tried some other cables to connect the switch to the router, nothing has changed.

There is an Ubiquiti AP in the Network, could this be a problem?

If everything is using the subnet, there should theoretically be no issues related to changing the firmware.

When running OpenWrt:

  • Can all devices still reach each other as they could previously (not counting the router)?
  • Can you ping the router from the other hosts (ping
  • How are you trying to access the router normally?
  • What is the IP of the Unifi AP?

i have found the Problem. After i disconnectet my Unifi AP everything worked. So i checked the settings on the AP and found out that the DHCP on the AP was enabled. After i disabled it on the AP everything worked.

Thank you!

I assume you are running openwrt or some alternative firmware on the ap (not the unifi firmware), correct? Unifi firmware does not have a dhcp server option (because it is intended to be an ap only with their firmware).