Netgear x4s (R7800) not powering on... any help appreciated!


I recently acquired an R7800 that did not come with antenna or power adapter. It appears to be DOA, but I was hoping to possibly fix it (since it is now free). I am using a 12v 2amp power adapter that seemed to fit fine and had the correct polarity (at least its markings were correct...).

Currently the router does nothing when plugged in (yes I did make sure the power button was "on". I also tried holding the reset etc. and nothing seemed to effect it. So, I opened it up.

I have pulled the board out fully (even taking off the top cover which has the thermal tape connecting the heat-sink). I didn't see any burnt or obviously blown/damaged components. So I tried to confirm that power was getting to the device (already tested the adapter).

Beside power connector are metal contacts that I assumed I could probe and confirm 12v... but I can't... I get a wavering <0.5v.... then I flipped it over, and there are three solder points. So I checked these and still can only get a wavering <0.5v... so now I am starting to wonder if this thing is even getting power correctly... but I am pretty novice at what I am trying to do - so I was hoping someone on here might have some knowledge and be willing to share it.

Here are the solder points under the power connector:

And here are the points I tried on the top of the board:

Can someone with experience possibly tell me if I am being an idiot, and if so where I should be checking voltage? If I am in the correct location, should I be getting the expected 12v or am I again ignorant of how it works?

It could be that the plug I found that "appears" to work, is actually short or something like that and it's actually making full contact?

Thanks for any/all help!

Unplug the power adapter and measure the resistance across the pins of the power connector on the router. The wavering 0.5V suggests that there is a short and the switchmode power supply in the adapter is "chirping", ie trying to start up, detecting an overload and shutting down.

Most routers have a buck regulator to drop the 12V input down to 3.3V and sometimes additional voltages. It's not too uncommon for the switching device and/or freewheel diode in the regulator to fail shorted, especially if someone plugged in an adapter of the wrong polarity or too high voltage. You might also look to see if there's a transient supressor diode across the input, if you're lucky that may have shorted without any other damage.


I damage my voltmeter and don't think it can measure resistance anymore... I'll have to borrow or buy another to check this.

Sorry... Greek to me... I'll try and google it and see if I can figure out what this is...

Judging by the fact this was sold without the power adapter or antenna, you might be right... someone might have used the wrong adapter and broke it... As said above, I'll see if I can understand what that is and then see if I can find one on this board.


not to try and discourage you but this is above your paygrade not a novice project. So your going to have to find the short. You'll need a meter with diode mode to start checking the board power supplies and see if you can isolate, if your lucky a bad cap. Do you have a hot air station? If not you can pretty much stop what your doing your not prepared to do the repair.

oh and btw did you buy this real cheap off ebay or something? If you did someone has already troubleshot the board and realized its unrepairable. If it was too good to be true it probably wasnt

1 Like

I would have to look, but I think the power supply for the R7800 is 12v, 2.4a.

Thanks for the reply. I take no offense, I'm sure I am over my head at this point. But since it's already broken, I might be able to at least learn a little. And there is a very small chance I get lucky and its an easy fix that I can do, lol. None of the caps look blown - but can't be positive. I'll probably dig until I know its not an easy fix - learn what I can, and then either trash it or give it to someone who knows more and might have a shot at fixing it.

No it wasn't off Ebay - but was some other site. Upon opening it I didn't see any noticeable signs of it being opened before (stripped screws, scratches around plastic etc.). Deal was pretty good though... so they probably knew it wouldn't power on... lucky for me I got a full refund and still have the hardware.. so no loss there.


stock adapter is 12v 3.5a.
I found reference of a guy who accidentally switch it with another 1amp and it powered on and would restart every so often... so I figure this 2amp I found should be enough to at least power on and flash some lights... with no USB, wireless off, no load 2amp should be enough to test it... at least I think it should :man_shrugging:

Be aware that there are multiple sizes of the inner prong for barrel plugs, if your PSU expects a thicker prong than your router provides, you won't get a good (enough) contact.

Sometimes electronics can be pretty temperamental with power supplies.

Yeah I was wondering that... but I wasn't sure how many different sizes there were... seems like most are standard - I found a replacement power adapter on Amazon for ~$20... was thinking of buying it and if it doesn't boot I can just return it... always an option.

I compared the pin hole in the plug to my laptop plug it does look bigger... but I tried my laptop adapter (without power applied) and it was too small... so unless there is another pin size between the two, I think this adapter is probably a close fit.


excellent. I would start watching youtube vids on troubleshooting electronic circuits but you will need a hot air station along with a fine soldering pencil and a decent multimeter

A 2A adapter should be enough to make it do something, the fact that the voltage is not going above 0.5V strongly suggests a short. 12V is pretty common, do you have anything else with a similar adapter you can try? I don't think I'd bother investing more money if I were in your position, I agree with others who say you're likely in over your head if what I said previously is Greek. Better to either find someone who has experience fixing things and get them to take a look at it (nearby hackerspace maybe?) or cut your losses and buy another router and hope that's in better shape. Even if you narrow down exactly what the fault is, you'll still have to buy parts and do the actual repair job. A hot air station is not strictly necessary but sure does make this sort of thing a lot easier. On the most basic level a fully working multimeter with diode check is a must, and a bench power supply with adjustable current limiting makes it a lot easier to avoid letting out the magic smoke.


I am mainly digging now because I was refunded, so I have $0 into it... nothing to lose.
I did try a few other adapters just to see what fits (OD is good, just checking pin size) and the 12v adapter seems to be a good fit - so I think that might not be the problem.

It sounds like the consensus is that it likely is a short (if the adapter is in fact making good contact). I'll try and see if I can find anyone locally who does repairs to take a look at it... if not o-well... no loss.

if you decide not to repair it I'll be the first to request it, if you don't mind shipping it I'll gladly use it for spare parts or a repair seeing that my main router is a r7800

I'm betting the connector fits fine if you're getting any voltage at all. The two common sizes I encounter are 2.1mm and 2.5mm and a 2.5mm plug usually won't connect at all to the center pin. If you put your ear up to the adapter when it's plugged in you might even hear an audible ticking or chirping sound.

I found a picture of the PCB in a 7800 and I can see it's quite a complex unit. I see at least four separate regulators, one near the input which is where I'd focus, the others I suspect are cascaded from that and provide core voltages for the CPU and other parts. If you can read a part number off the regulator IC you should be able to find a datasheet, in many cases the actual circuit will be nearly a direct copy of the reference design in the datasheet.

It's extremely difficult to troubleshoot remotely though, there's no substitute for having a rough understanding of how the circuit works and how to test components like diodes and transistors.

1 Like

In case anyone wants to look... here is the board:
Google Photos

L23 looks strange, the casing looks warped, might have gotten cooked a little. I would remove R807 and R821 and probe to ground to see if you could isolate which part of the board has the short. Those R### with the"0" on them are jumpers and you could remove them one by one to isolate portions of the board to see if your board comes alive.

I just compared L23 to the one beside it (L48) and also to the pictures on the FCC filing.
I didn't notice it at first but I think you are correct! L23 does look like it is mis-shaped... Now, my ignorant self just needs to research what that thing is lol...

But thank you for taking such a close look... worth a shot to fix it (again, can't make it worse than broken). I also contacted a local MarkerSpace in hopes that someone is willing to help.

Cheers and thanks to everyone!

"L" is the standard reference designation for an inductor. In this case these are almost certainly buck converters, if you look that up you'll see examples of the topology and how the inductor is used.

I don't think this is your problem though, these inductors have ferrite cores, it doesn't melt and change shape, if it got hot enough to damage the core it would have obvious charring. Also if the inductor won't just heat up on its own, if it got hot enough to be damaged then it happened because another component is damaged. Typically the freewheel diode and switching transistor (in this case integrated into the regulator IC) fail shorted. Testing the diodes is the first thing I'd do because it's relatively easy and provides clues on the state of things.

I have same issue. I measure around 10ohms between the power terminals. Somewhere on the board must be shorted but have no clue where could it be.