Netgear X10 (R9000)

Maybe a copy of your /etc/config/wireless minus any keys might help too

Looks like i have a faulty hardware.
The short story is, i tried to install OpenWrt because my 2.4ghz and 5ghz wifi is missing (not detected from other device) before and after upgrading the original Netgear firmware to the latest version.

I even tried DD-WRT and the wifi still missing (unknown state).
The only detected chip is WIL6210 802.11ad (60ghz).

Where are you located? If you're open to it, I'd be happy to buy the faulty X10 from you.

I've been successfully using this branch in my R9000 for a year to provide Wi-Fi vdevs for multiple vlans trunked over the WAN port. Everything has been working great; however, now, im adding some new equipment and running into latency issues while trying to add a 2nd trunk port to service a unify AP.

Is there any benefit to using the WAN port as a trunk? I don't need any firewall functionality as this is behind a PFsense box. Also, checking my switch configuration, I noticed that I an also using the VID statement for each vlan. Is this needed?

The WAN port is not part of a trunk , only a VLAN.
In my switch setup, 2 trunks are used to connect master and slave switches.
Therefore, trunks are internal and no external switch port is connected to a trunk.

I managed to get this device for 75$ in good shape, I hope someone can give me some answers.

  1. Would the rj45 wan interface be able to deal with 1gb up/download due the quad core cpu using NAT? (tested and wan is able to deal with 1gbs)
  2. Would it be possible to use the SFP+ interface as WAN if I would like to connect a fiber cable to it?
  3. If so can I somehow see the commits that added support for this unit and perhaps rebase it myself now and then? (edit: got this sorted)

Please note: i'm not planning to use the wifi.

Best Regards,

After a recent git pull, I'm unable to build successfully with the alpine-fan-control included.
I'm building from the netgear-r9000 branch.
make package/alpine-fan-control/compile ends up with the following error:

make[2]: Entering directory '/home/X10/package/libs/ncurses'
. /home/X10/include/; /home/X10/staging_dir/host/bin/libdeflate-gzip -dc /home/X10/dl/ncurses-6.4.tar.gz | tar -C /home/X10/build_dir/hostpkg/ncurses-6.4/.. -xf -
bash: line 1: /home/X10/staging_dir/host/bin/libdeflate-gzip: No such file or directory
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
make[2]: *** [Makefile:191: /home/X10/build_dir/hostpkg/ncurses-6.4/.prepared2dfe777e6fae67a68461e5d90a64a76d_6664517399ebbbc92a37c5bb081b5c53] Error 2
make[2]: Leaving directory '/home/X10/package/libs/ncurses'
time: package/libs/ncurses/host-compile#0.19#0.03#0.19
    ERROR: package/libs/ncurses [host] failed to build.
make[1]: *** [package/Makefile:114: package/libs/ncurses/host/compile] Error 1
make[1]: Leaving directory '/home/X10/
make: *** [/home/X10/include/ package/alpine-fan-control/compile] Error 2

Has anyone else seen this error? Is there a workaround?


Build including alpine-fan-control seems to be possible after a recent git pull

When I do make defconfig

  • kmod-crypto-hw-alpine
  • alpine-fan-control
  • kmod-switch-ar8xxx
    isn't selected.
    Is this intentional?

for those wondering, the SFP+ port is working fine and able of doing 10gbs no problem.
i have it configured as WAN for my tests.
The module i used is from fairOptics.

The 10G led on the front does not come on and the only indication it made a link was the other router.
Here is an iperf3 test i ran to confirm everything was working


Sorry for the (really) late reply.

I haven't rebuilt openwrt in a while, but IIRC, the 1st install -a installs everything and sets up all the symlinks and all that, and the 2nd install -a will trigger re-scanning what packages are available and updating some database of what packages are available and dependencies and things like that.

If you dont do the 2nd install -a now itll happen later (id guess as part of the make menuconfig call), so dropping the 2nd call is probably OK but doesnt save any time - it just gets that part done and out of the way sooner.

That said, its possible that the 1st install -a call will not install some packages that specify "dont install if any dependencies are unavailable when install -a is called" and that have some dependencies installed during the first install -a. I dont know that any packages do this (though I do seem to recall that a handful do), but if they do then youd need the 2nd install -a call to pull those in.

I know for sure that a couple eBPF programs wont (or at least didnt several months ago) get pulled in until after the cross-compile toolchain and all the build tools are finished building. To pull these in you have to run the 1st part of the compile (make prepare_kernel_conf IIRC) then re-run the install -a to pull them in,

Massive hugs to @egorenar for working on this project. Although I've been building kernels since linux 1.2, this is the first time I've used OpenWrt and I'm impressed by everything. As a newbie, I didn't know I had to include the LuCI packages so when the snapshot image booted and all I could see was a dhcp lease grant I was a bit confused, but a bit of RTFM, rebuild and sysupgrade later I have a beautiful fully functioning router the way god intended. Thanks so much.