Netgear WNR2000v3 not saving settings after reboot with RC2

I have a Netgear WNR2000v3 that I use as an AP (firewall off, WLAN connected to WAN).
It had OpenWRT 15.05 (IIRC) on it and everything was working as expected. It has been stable for a year or so.
I upgraded to LEDE RC2 with the lede-17.01.0-rc2-r3131-42f3c1f-ar71xx-generic-wnr2000v3-squashfs-sysupgrade.bin image via the command line (not saving settings), and now it loses the settings on reboot.
I tried upgrading again (via LUCI) with the "save settings" box unchecked and have had the same issue.
What should I try next to troubleshoot it?


Aaron Z

check the system log that it switches to jffs2 & overlay.
If you have quite full firmware image, there is maybe not enough free space to create the needed work structures for jffs2.

What does "df" command say?

I will have to check again tonight. I know that it has enough free space to install nano without any errors, it just blows any changes (including installing packages) away when it restarts.

Aaron Z

But does is install nano to flash or to ramdisk ???
It sounds like you operate in ramdisk and thus a reboot clears it all.

When it fails to use flash, you should see something like this in the kernel log and system log:

 [    8.870000] mount_root: switching to jffs2 overlay
 [    9.120000] overlayfs: failed to create work directory (EROFS), mounting read-only

the first line is the normal one (switch to either jffs2 or ubifs), the second one is then error.

I am not sure where it was installing it. After I switched from OpenWRT, I just ran "opkg update" then "opkg install nano" and edited the config files. I then rebooted it and was surprised when it lost its configuration.

Aaron Z

And now it looks like I at least soft-bricked it (did an update to the LEDE Release without saving settings and it failed somewhere in the update process)...
When it starts up, it gives me 4 pings, then it stops responding and the network interface flaps on and off.

Aaron Z

The WNR2000 v3 only has 4 MB flash, it's rather unlikely that you have enough space (roundabout 180 KB) to install nano on the jffs2 partition. One symptom of "no space left on the device" (ENOSPC) is that the overlay is mounted on tmpfs (in RAM) only, to allow the router to succeed booting (as a kind of emergency mode), so that would be the first thing I'd check (df -h), besides trying to avoid installing any additional packages (busybox vi might not be convenient, but it's always installed and a quite usable editor, once you've looked into its basic operations).

True, vi works well, I prefer Nano given the choice. One of these days, I need to set things up to compile my own images so I can get rid of packages that I dont need (PPOE for example).
At this point, I might play with this wnr2000 again if I get bored, but I have other projects that are more pressing (and my TPLink 1043 with the LEDE 17 release is chugging along happily), so its going to sit on the shelf until I have time to mess with it.
In the meantime, I just ordered a TP Link TL-WA855RE to go in the window I was going to put this box into and add wireless in the garage (metal siding is not conducive to good wifi reception for some strange reason :smiley:).

Aaron Z

Are you sure that the TP-Link TL-WA855RE really has more flash than 4 MB? I'd strongly suggest against spending money on devices with just 4 MB flash (or less than 64 MB RAM) today.

Good point, I hadn't thought about flashing it so I hadn't looked at the memory.
I see a Asus RT-N56U (8MB/128MB) going fairly cheap near me, I will see if I can pick that up.

Aaron Z

Hello all! Thanks for this wonderful piece of software.

I have WNR2000v1 and I successfully compiled my own images:

$ ls *_new.bin -l
-rw-r--r-- 1 root root 2228224 Mar 5 15:29 sqfs_new.bin
-rw-r--r-- 1 root root 1218787 Mar 5 15:30 uImage_new.bin

and flashed them however in bootup log I see:
[ 8.174614] mount_root: no usable overlay filesystem found, using tmpfs overlay
and thus I'm unable to save any settings.
I flashed earlier this images from
(there is a link to his Google drive )
which are:
$ ls *_works.bin -l
-rw-r--r-- 1 root root 2490368 Mar  3 14:50 sqfs_works.bin
-rw-r--r-- 1 root root 1256534 Mar  3 14:50 uImage_works.bin

so they are bigger then my images, but they works - I can save settings.

So what I did wrong with my images? Do I need to select something while in menuconfig?

I solved it. It turned out I just had to issue jffs2reset command while in serial console and reboot the device. Afterwards it mounted overlay correctly and now the router remember settings through a reboot.
I managed to fit lede+luci on 4MB flash and I still have 100KB left.

I can confirm this issue. Its there since OpenWrt 15.05.1.
aczlan wrote he had 15.05 (not 15.05.1) on his device. The issue came with 15.05.1 and it never go away again.

I have installed LEDE stable final release ( ) on a WNR2000v3 and the issue was still there.
The most simple way to make a example of this issue: Install 15.05.1 stable or 17.01 stable and open It tells you that there is no password set. Go to settings, set a password. Open browser again. It asks you now for the password. Power off the device. Wait 2-3 seconds. Power it on. Password is now lost and device have again factory settings.

This makes lede on this device somehow useless. Would be great if someone could fix this problem.

EDIT: I made a bugreport about that here:

I may have had 15.05.01 on that device, it had been on there for a while and I didn't look to see what version was on there before I upgraded.

Aaron Z

This appears to be fixed in the 6 April snapshot (r3922-9613d97). I installed that and it is saving my changes.
@lmtiaxkb, I will attach the bootlog from the 17.01 upgrade/firstboot to your ticket.

Aaron Z

I am no longer seeing the settings not saving issue, what I am seeing now is that it goes into a bootloop after installing 17.01.0
I had time tonight to plug a serial console into it and record what it does when you install 17.01.0
Attached are two bootlogs:

  • Bootlog of the upgrade to 17.01.0 from recovery mode using the lede-17.01.0-r3205-59508e3-ar71xx-generic-wnr2000v3-squashfs-factory-NA.img image (goes into a bootloop after the install): WNR2000V3To17.01UpgradeBootlog.txt
  • Bootlog of the upgrade to the 6 April 2017 nightly (r3922-9613d97) using the lede-ar71xx-generic-wnr2000v3-squashfs-factory-NA.img image (works as expected): WNR2000V3To6April17SnapshotUpgradeBootlog.txt

I saw the same thing installing lede-17.01.0-r3205-59508e3-ar71xx-generic-wnr2000v3-squashfs-factory-NA.img from the factory web interface (Netgear wnr2000v3-V1.1.2.14 which runs on OpenWrt Kamikaze 7.09 IIRC)
I opened a ticket for this
I also remembered to run df, this was with the 6 Apr snapshot installed:
root@LEDE:/# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 2048 2048 0 100% /rom
tmpfs 13900 76 13824 1% /tmp
tmpfs 13900 32 13868 0% /tmp/root
tmpfs 512 0 512 0% /dev
/dev/mtdblock5 512 208 304 41% /overlay
overlayfs:/overlay 512 208 304 41% /

Aaron Z

I cant confirm bootloop on the device. Have updated from 14.07 to 17.01.4. I had the "not saving setting" issue. Then i installed latest snapshot (that does not contain luci) and that worked with saving the settings.
Did you still have the bootloop on latest images?

I had a similar problem on an Ubiquiti RouterStation Pro with 17.01.4 - it wouldn't save settings during reboot, but would save files in /root. I did not confirm which locations it would and not save files before jffs2reset fixed it.

root@LEDE:~# jffs2reset
This will erase all settings and remove any installed packages. Are you sure? [N/y]
/dev/mtdblock3 is mounted as /overlay, only erasing files

I've built an image for the WNR2000v3 that should run 18.06.4 with no bootloops, no lost settings after reboot. You can upgrade directly from a previous version of OpenWrt using the sysupgrade .bin file.

This image includes LuCi (GUI), IPV6, SQM - no PPP. A build manifest is available in the download folder.

If you end up installing, please let me know how it works for you. I don't have a WNR2000v3 to test it on directly - but it runs great on my almost identical hardware, the WNR1000V2.

More information on these builds.