Netgear WNDR4700 Firmware Re-Flash [SOLVED]

I run a Netgear router, model WNDR4700

I followed the factory install instructions here, all the way to the last step in the install guide, after all was said and done, it let me connect to the wifi (labeled OpenWRT1), and I could connect to the internet just fine, but whatever I messed up, I can't connect to the openwrt control panel using the address, keeps saying "no connection with this address"

since I only installed it to see if I could get it running, is there a way for me to either get back in the openwrt control panel and re-flash the default netgear firmware, or re-flash using cmder or smartty?

try connect to the router by hostname and maybe connect thru ipv6?

1 Like

If you didn't disable IPv6, there should be a link-local address (begins with with fe80:: ) to the router.

You might try browsing or SSHing to it. That would be the easiest.

Also, try using the physical reset button, it if has one.

Worse case:

  • use serial port inside the router to access OpenWrt prompt; or
  • use serial to reset to factory via TFTP, sysupgrade, etc.

i like the idea, to push things forward :smile:
hope you realise though this inside the router
, gives the creeps to many of us, especially when it is a shiny new one, as much as it is truly the last resort of hope, to get back in control again.

Unfortunately, I do realize the serial port is inside the router. :pray: :prayer_beads: If the OP is a praying person...hopefully they won't have to open the case.

Good luck first to the OP with the:

  • reset button; and
  • the IPv6 Link-Local/ULA addresses
  • I thought of something else! Perhaps you simply turned off DHCP and just need to statically address your computer to access the router! The default LAN subnet for OpenWrt is and the router is (as you know).

now what sort of people put a port in the guts of a router?

the reset button worked, thought I would have to do it like replied above, and yet the few questions I have had simple answers I didn't even see. ill take the dunce cap for this one

Glad you got it working...consider marking the solution and editing the title to append [SOLVED].

Those who believe consumers are too scared to open the case.


well the part of getting into the router control panel works, now all that is left is to re-flash the default netgear firmware. I tried doing that through the openwrt control panel's firmware section, says its the wrong format

I can the tftp server method using tftpd32/tftpd64, but first few times I did kept giving me an error, and I had all my computer firewalls turned off; anything I can change that I am forgetting?

worry not @MonfGeiger, the cap stays where it is.
you had a great lesson with such a small price. i reckon to take a step back, sleep over it and plan forward.
What is it you want out of your router?
once you know, make informed decisions and act accordingly.

OpenWrt is quite powerful and i'm sure you can get almost anything out of it.
and if you are in need of a little help here and there along the process, OpenWrt has a neat and knowledgeable community to discuss it with.

1 Like

If I decided to keep OpenWRT as my main firmware, I planned on configuring it to be a little more secure than what options the Netgear firmware provided, seeing which packages I would need to install to do so; also, maybe figure out how to get printing working with OpenWRT and my families windows computers

but again, until I can get my father to accept this as a possibility, ill need to figure out how to re-flash the netgear firmware back to the router (tried the tftp deal with windows, keeps failing, will try on the linux side)

I know I appended the title as solved, but I want to "soundboard" this idea here before I really commit to it

I looked through the sub-forum here on someone wanting to re-flash their linksys firmware, and he was told to follow these steps

cd /tmp
wget link-to-stock-firmware
sysupgrade -F -n /tmp/stock-firmware-file

from what I read, this person succeeded, but it also created a second partition, giving the router 2 firmwares (default firmware, and openwrt firmware). I seek to use the syspgrade command, but I want the netgear firmware to be the only one; is there a set of commands I can use to ensure that the netgear firmware is the only one on the router when I go to flash, or if not and I have 2 firmware partitions, can I erase the openwrt firmware afterwards using the wipefs command?

Can you provide that thread?

I think the person(s) you refer to had a device that includes 2 OSes (active and backup) from the OEM.

from what I researched with netgear, it says I need to use the tftp client for windows and/or the tftpd32/64 program from what the netgear knowledge-base says

but if I can use the sysupgrade package to do the same, if maybe with a few extra steps before hand, then al the better, unless I should stick with tftp instead?

Yes, the model in the post has two partitions from the OEM. The OP's subsquent problems were that the device rebooted into the other partition after an issue.

I suggest you use TFTP. It's not that hard. You might brick your router trying to sysupgrade. There's no need to take the risk when a known solution works.

The OP in the other thread also noted that they had flashed both partitions. If you only flash your router once, the stock firmware should still be there, though. Use the procedures to switch to the other partition ( luci-app-advanced-reboot or the 3-failed-boots method).

I installed the luci-app-advanced-reboot, and this is what it told me when I selected it in the openwrt control panel
You want me to risk it anyway, or try and make tftp work? I tried the tftpd32/64 app before, but as before, when I followed the netgear instructions to the letter, it kept changing the server instance box to, and when I switched back to my configured ethernet, it says "something something 10025 error something", I forget

maybe I was missing some router packages that would've made it easier; I can try again, but I can't guarantee a success if it keeps messing with me

luci-app-advanced-reboot supports these;a=blob;f=applications/luci-app-advanced-reboot/;hb=HEAD routers at the moment, if yours isn't on the list, it isn't supported and would need device specific additions. However, giving the device page in the wiki and the flash layout a casual look, I don't see that your device actually has dual-boot support - meaning that luci-app-advanced-reboot won't be useful here (I think lleachii mixed up the wndr4700 with the wrt3200acm).


Thanks, I didn't mix them up...I took the OP's words implying 2 partitions are somehow there...

I think the OP should better explain this concern regarding:

  • Are you concerned about the OEM settings partition?
  • Since you already have OpenWrt flashed (you stated you followed the steps), I'm not certain what you mean by "ensure that the Netgear firmware is the only one on the router when I go to flash, or if not and I have 2 firmware partitions"

At this time, is the router flashed with OpenWrt or OEM firmware?

luci-app-advanced-reboot only touches devices for which it knows exactly how their dual-boot settings need to be configured (device white list, with their corresponding mappings), it doesn't try to detect anything automatically (which would be pretty dangerous).

1 Like

When I did this topic (sorry if I didn't say it good enough), I flashed the OpenWRT firmware onto my netgear router (which before I did so, was running default OEM firmware)

So yes, the router WAS running OEM firmware, but is now running openwrt firmware; if I need to provide anymore details I should've, say so and it shall be done