[netgear wndr3700] bridge between pppoe and wifi

I’ve recently change flat and I need to reconfigure my network.

The new flat has a fiber coming in and a switcher with an Ethernet port. A router can be attached to it.

The mode of connection is an pppoe with username and password.

In LUCI I’m struggling to configure the netgear in a way that the connection is shared over the two wireless interfaces (ideally also over the 4 Ethernet ports)

Every time I try to configure the Ethernet port as pppoe I loose access to the router (and wireless connection cannot be assigned an IP)

Any idea of how I should go about configure it ? (I’m a bit ignorant of the differences between interfaces and virtual bridges that you can configure in luci). I remember a similar configuration was quite straightforward on the net gear firmware, but would love to keep openWRT

Thanks in advance

The cable should go to the WAN port (typically the blue one), and it is the WAN inteface that you need to configure as PPPoE.

The 4 LAN ports and the radios are all bridged in the default config, so you don't have to worry about that, export of course turning the WiFi on and setting up the security options.

Edit: it seems that your device has the WAN port as yellow while LAN ports as black. But anyway, it's the WAN port that you should connect the cable to.


Thank you @Hegabo!

Yes, indeed, the model has the WAN coloured yellow. The cable is attached there.

I'm worried that, since the router before was having a repeater configuration between the two wireless station, with some ad hoc bridging on the LANs, I have a bit of previous configuration that is conflicting.

Do you mind confirming that In LUCI I should configure in the INTERFACE panel and the WAV will come up as WAN (and not something different like eth0.1) ?

Check that WAN and LAN ports are not bridged together.


You could probably just reset config using firstboot

The interface will come up with whatever name is given to it, and the default for WAN is typically WAN (and WAN6). eth0.1 is typically the LAN for most routers (while eth0.2 would be the WAN. The number after the period should match the VLAN ID in the Switch page in LuCI. So it appears to me that you are putting the PPPoE settings in the LAN inteface.

You probably should check the Wiki for how interfaces are named, if you wish, and then you can just reset the config to make sure you don't have leftover settings from the previous config.

1 Like

For posterity, Hegabo was correct, and his explanation of Interfaces is probably one of the best out there. Thank you!

1 Like


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.