Netgear WAX220 support (almost complete)

Which OEM version are you trying to flash? And which OpenWrt version did you flash previously?

Sometimes the UBI volume runs out of space, which prevents nmrpflash to flash back the original firmware. You can delete the OpenWrt specific UBI volumes to fix this, see

I also tried to delete those partitions as described in the link. That did not solve the problem.
I have openwrt 23.05-SNAPSHOT installed and tried to revert to WAX220-V1.0.2.1.img or WAX220-V1.0.3.0.img.
Prior to flashing Openwrt the firmware was WAX220-V1.0.3.0.img if i remember well.

I followed this:

and could use nmrpflash to flash oem firmware :slight_smile:

The commands above should essentially achieve the same. Did you run those commands and then run nmrpflash on the very next boot? Otherwise OpenWrt will recreate those UBI volumes.

Yes on the very next boot. And i tried several times.

Ok. Yeah, without serial port logs it's kinda hard to tell why this fails then :cry:

First of all thanks for all the work you guys put into making openwrt available on newer hardware! I cannot imagine to switch back to some OEM stock software again...

I am going to try to flash WAX220 next week. What is the recommended image to use - is the rc3 snapshot mentioned in the wiki a good choice that should work out of the box? Or this one:

I am going to try to flash WAX220 next week. What is the recommended image to use - is the rc3 snapshot mentioned in the wiki a good choice that should work out of the box?

There are no netgear_wax220-squashfs-factory.img for rc3 right now, there should be with rc4. Best is to use netgear_wax220-squashfs-factory.img from the snapshot directory (, then sysupgrade to the latest rc3 using the sysupgrade file from

Or this one:

Do not use this one, it is outdated.

1 Like

i started a couple of weeks ago with the snapshot factory.img from the WAX220 wiki page and then loading a custom build of 23.05.0-rc3 from the firmware selector. that worked ok but i had some stability issues with a week of uptime.

i switched back to the OEM firmware to see if it gave better stability but just found i ended up with different problems. :smirk:

so, i switched back again to openwrt and this time went with the r24002-e3559fb445 snapshot from yesterday and it has been good so far - will see in a week or so if the stability continues.

i've only been able to get the 5G radio to work with auto channel selection so if you need specific channels this may be problematic right now.

1 Like

I tested the last snapshot (r24024-6585498372) with kernel 6.1
Everything works fine.
I only have an Intel AX200 card (max link 2401 Mb/s (5.2 GHz))

[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 1.22 GBytes 1.05 Gbits/sec 0 sender
[ 5] 0.00-10.01 sec 1.22 GBytes 1.05 Gbits/sec receiver

Hi folks :raised_hand:

I used snapshot version for:

  1. firmware update to openwrt-mediatek-filogic-netgear_wax220-squashfs-factory.img
  2. sysupgrade -n /tmp/openwrt-mediatek-filogic-netgear_wax220-squashfs-sysupgrade.bin

After that, the reset button bricked my device to the state where the power LED is lightning only :frowning_face:

I failed to do TFTP or NMRP recovery from that state (more likely doing something wrong here).

Please help me to de-brick WAX220

Thank you!

What is the color of the led ?

If green, set the local address e.g. and check

If it doesn't work, try using nmrpflash to revert to the original firmware.

Thank you @rybirek
after power up, power LED is:

  • 15 sec - orange still
  • 15 sec - blue flashing
  • green still

During first 15 sec (orange) I see that interface was up for a moment but failed to ping from (host) to (wax220) with mask

What are valid steps and IP adresses to recover wax220 using nmrpflash?

Download and unpack
Download and unpack firmware
Set IP local e. g.

List interfaces

nmrpflash -L


nmrpflash -i net4 -f WAX220-V1.0.3.0.img

@rybirek Unfortunately, it is not so trivial.
When the power led is green still, I am getting:

Error: Ethernet cable is unplugged.

So I tried to use the short window ( previous post ) when wax220 network interface was up for a moment, but it failed with

Advertising NMRP server on en7 ... -
No response after 60 seconds. Bailing out.

What are other methods to stop bootup at the moment when the interface is up or anything else that allows us to recover from that state, please?

Just open that thing and check the serial output. This device is super easy to open, it's simply not worth the trouble working blind.


@Flole thank you. I do not know how to get connected to the serial interface and which hardware is required for WAX220 case.
Can you please guide me (as a noob) with hardware and software (MacOs) steps please? :pray:

@aicjofs , @falstaff, it seems you had an issue with nmrpflash in the past. Please help me to recover this unit based on your past experience - such instruction will be beneficial to put at wax220 page that will help anyone in a situation like I ended after flashing :pray:

@glazeus There isn't really much you can do at this point, you are working blind. You need a serial(console output) connection.

If you don't know much about this it's best to read some and watch some videos but basically
Need a USB to TTL adapter(set to 3.3V)
Pins, solder, and cables to connect the WAX and adapter
As I recall for this unit:
-don't connect the WAX VCC to the adapter
-adapter GND to a ground pad on WAX
Serial software if using Windows(putty, etc)
-115200, 8N1, 3.3V

I did find some pics on this model that I took.

As for nmrpflash... I can't remember what the error said but it would start the download and then give the error. No way around that until I erased UBI partition. Even then the first reboot the console gave the same error. I rebooted an immediately started nmrpflash and it loaded fine.

1 Like

Thank you a lot @aicjofs
I will start with FT232 device - seems it is compatible with windows/linux/macos
product / wiki
Hope that I will be able to see more via TTL UART

If I understood correctly you recommend erasing UBI partition over TTL (which command?) and after the first reboot "immediately started nmrpflash" stock firmware?