Netgear WAX220 makes ticking noise

Hello dear OpenWrt community,

I have a problem with a newly installed device (Netgear WAX220). I installed the access point a few days ago, and I am very happy with the device, except for one small thing. The device starts making ticking noises after about 5 minutes after power on.
I'm not sure if it did this with the stock image and I can't imagine why an access point would make any noise (no moving parts).
My question is, does anyone have any experience with the Netgear WAX220 device or any other similar access point, making noises?


  • I use an original Netgear powersupply
  • I have installed the latest snapshot netgear_wax220-squashfs-sysupgrade.bin | Fri Aug 18 08:34:00 2023
  • The only package installed is luci-ssl (no big processor load on the device)

And if you go back to stock ?

Are you sure it's the router and not the psu? Anyway looks like a case for RMA and yes you should go back to stock and return it for repair/replacement

1 Like

Thank you both for the quick reply.
It's definitely not the psu, I tried different ones.
I will try to reload the stock firmware in the next few days and report my result.
Thanks a lot and have a nice weekend

The ticking noise is from the buck converter in the router
It may happen because of high current draw or just defective inductor

1 Like

Thank you very much, the tips have helped me. I restored the AP to its original state and had the same problem with the manufacturer firmware. I have returned the device and have no problems with the replacement device.


let's mark the topic as solved to help others :wink:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.