Netgear Wax206, unable to reset or restore

I've been trying to reset my wax206 after unsuccessfully installing a snapshot of openwrt a few months back. I want to try the release version now out.

The reset button didn't work, and while trying nmrpflash it just hangs at the uploading phase. I left it running over an hour without success. Firewall is off and direct connection to my computer.

what's the current state of the device ?

I can't connect to it at all. Right now it is hung while trying to nmrpflash. Power light slow flashing orange.

I'm starting to think it may be bricked, even though I can connect to it with nmrpflash.

Any suggestions what to try next?

serial would be the next step.

Have you tried several timing between powering on the device, and launching nmrpflash? On some devices, I have to power on the device first, on others I have to launch the command first. Also try several intervals (2s, 5s, 10s delay) between them.
A serial link might help to see the nmrp message while booting. You may also have to wait more time after the successfull message.

I let it run for hours when I was away once.

I haven't tried the timing you mentioned, will give it a shot this weekend, thanks.

If I need a serial connection, it looks like I need to solder rx, tx, and ground via a TTL-USB dongle, correct?

I've got several Arduino Uno's around, if I don't have a dongle; do you think the method mentioned in the wiki is ok even with the 3.3 vs 5 voltage difference?

It's meaningless. When the router starts, you have timespan of a few seconds to catch the nmrp server. Once the nmrp client failed, the router doesn't care anymore of a nmrp server. You can clearly see this by watching the bootlog with a serial.

That is why I suggest you the timing test: the moment the router waits for the nmrp server is different for each router.

1 Like

Yes, and it's a PITA.
They used some high temp solder tin, I ended up drilling the holes, then soldering, because my soldering iron couldn't get the tin to stay melted long enough, to be removed.

1 Like

That sucks. Hopefully mine will get hot enough, I've got a hakko that claims it will hit 899 F.

Ok, I have a serial connection. It connects to a openwrt snapshot I installed several months ago. How do I either install the latest release of openwrt or the stock firmware via serial? If I get back to stock I can easily install openwrt.

As I mentioned before, the reset button didn't do anything, and I followed the correct procedure for it.

I think I may be in this state because I had tried configuring the router with the snapshot months back for my static IP and I was having difficulty with that and lost communication with it. I can't remember now exactly what happened, and now that there is a release vs the previous snapshot, I just want to start over. Thank you.

As you seem to have a working serial and a normal OpenWrt snapshot there, the simplest way is to use the serial just for resetting the OpenWrt settings, causing the snapshot to revert to OpenWrt defaults, , root without password, no WiFi etc.

From the serial console, you can use the command "firstboot" to clear overlay from settings and add-packages. Then reboot. And you should have a "freshly installed" old snapshot.
Then you can use the normal sysupgrade from SSH.

1 Like

Looks like I am running with the current release, thank you everyone.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.