Netgear WAX206 Support

If you get snapshot images from the firmware builder page, the link for both factory and sysupgrade will start as the default snapshot with no Luci, but if you add packages, the links will be for an image with the relevant packages added. Only stable builds have Luci by default.

If you used attended sysupgrade, it will have the packages installed on your router and any you added or removed during the build process.

Hope that helps! :wink:


Just installed SNAPSHOT - r22878 this morning (15/5/23) via attended sysupgrade. Works great!

I've had no problems with snapshots for 2 weeks and I keep reading that 23.x is just around the corner, so stable images for WAX206 should be here within weeks or at worst a month if I'm reading things correctly.

I am not 100% sure if OpenWrt 23.xx branch will come soon. Linux kernel 5.15 support looks complete:

But there is a major performance loss with kernel 5.15 on ipq806x:

It seems to be related with frequency scaling. Could be solved during release candidate phase but without a solution I don't think 23.xx branch will get much acceptance from ipq806x users.

I think 23.xx could be branched when these commits are merged:

I don't know. Looks like some pretty knowledgeable people are looking into that bug. I was just going off that quote from Ansuel saying there were only a few things holding back branching and hasn't even heard of that bug. Hope they sort it out soon!

In any case the good news for wax 206 is that snapshots are quite stable, so we are OK until the stable release.

1 Like

Mine arrives tomorrow so as I build from the current Openwrt Master with full 802.11s support please let me know if you have any questions.

1 Like

Looks like in the latest SNAPSHOT (r22899-466be0612a) adblock not supported

root@OpenWrt:/# opkg install adblock
Unknown package 'adblock'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency coreutils for adblock
 * pkg_hash_check_unresolved: cannot find dependency coreutils-sort for adblock
 * pkg_hash_fetch_best_installation_candidate: Packages for adblock found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package adblock.

Looks like a package issue, which snapshot are you using?

This kind of issue happens from time to time with snapshot. Nothing to worry about. It will be solved in a few days. In the mean time, just be patient.

1 Like

SNAPSHOT (r22899-466be0612a)
2023-05-16 19:32:54

Yeah, no problem. I don't worry at all but decided to notify about it, maybe this information could be helpful for someone else.


r22900 is already available

Packages with snapshot builds can be a bit hit or miss as the code is always changing, but the packages may be asking for a different version of another package as a dependency.

You could try adding the packages into the build, which can sometimes help. See my posts above about adding packages either through the firmware builder page or attended sysupgrade. You might have more luck that way rather than using opkg after the fact.

1 Like

Nice! That works - thank you for this info!!!
BTW custom build still not support " coreutils"
Unsupported package(s): coreutils

1 Like

Thanks for all the help guys, I still havent got round to installing the snapshot as I have been busy with other stuff, so I just need to be aware snapshots may occasionally have issues with dependencies been sync'd up so I assume a good idea to get all my packages installed quickly before things shift again, or as said to add them to the custom image.

I wasnt expecting the next release until next autumn, based on previous releases, so also good news that it might be earlier then that.

Packages that are less mainstream is where you are more likely to have issues. I remember having that with either ZeroTier or Tailscale (can't remember which). It tends to be where a package has a hard coded dependency on a particular version of another package or kernel, for instance it might be looking for kernel 5.10 as in stable but snapshot uses 5.15. I'm also not sure if every package is built for snapshot and certainly packages you install from an external repository are more likely to have problems.

Edit: Just found this when I wasn't even looking for it.

1 Like

Hello, I am running snapshot r22945 on my WAX206. Really good work, pretty much everything seems to work fine for my needs. The only (negligible) issue on my device are the non-working wifi LEDs. Is that expected with the snapshot, or do I have to add a custom LED action for the wifi for now? The leds did work with the OEM firmware, so it's not a hw issue.

EDIT: Setting to "Always on" works, but using "netdev" as trigger does not bring up the LED.

1 Like

Try to add the package kmod-ledtrig-netdev. I can see it is not included by default.

1 Like

For info, first file of 23.05. One may want to try.


Thanks, I will try that. Netdev trigger works for the WAN led, though (the snapshot has a pre-defined custom action for that). Also, the LAN leds work and blink based on network activity out-of-the-box.

1 Like

As kind of mentioned above, the 23.05 branch has just been branched off from the main/development branch that the snapshots are made from.

This will now start a release process that will involve making release candidates like 23.05.01rc1, rc2, rc3 etc, before a proper 23.05.01 release. This will be a bug fixing process and new features will not usually be added.

Package authors will now have a more static target for dependencies and packages that haven't been able to run on snapshots should start to run against 23.05. Once the release candidates come out, people will be able to lodge bugs regarding packages not installing or running.

This is exciting but we need to make sure we are being encouraging and not demanding as the devs will already have their hands pretty full.

1 Like