Netgear Wax206 issue Wan last snapshot r22459

HI everyone, i am having a problem, with last snapshot, with version r22400 work's fine.
The wan RX: 0 B (0 Pkts.).

My network configuration is:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	
config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	list ipaddr '192.168.2.254/24'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config interface 'wan'
	option device 'wan'
	option proto 'static'
	option gateway '192.168.1.254'
	list ipaddr '192.168.1.253/24'
	list dns '8.8.8.8'
	list dns '8.8.4.4'


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	
config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	list ipaddr '192.168.2.254/24'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config interface 'wan'
	option device 'wan'
	option proto 'static'
	option gateway '192.168.1.254'
	list ipaddr '192.168.1.253/24'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

Can you help me?

1 Like

Same issue, WAN is not working, at least on last two snapshots. Also, WAN is working with latest immortalwrt snapshot (build date is 2023-03-28 06:56:10, r25687-502c08f95b).

1 Like

There have been a couple of commits for mediatek device on 2023-03-27. On of them is actually breaking the wax206 wan phy. I was not able to figure out which one is exactly breaking the wax, but I contacted the developer, who commited the changes. For now any build, based on a snapshot before 2023-03-27 should be working.

I have ordered a device which also has the RTL8221BV 2.5G PHY connected to MT7531 which seems to be at the root of the problem. It's only going to arrive in about 2 weeks from now (according to AliExpress).

Most likely the problem is that the PHY has SGMII auto-negotiation enabled and the PCS driver on the side of the MT7531 now behaves according to spec and disabled that unless it is explicitly enabled in device tree. Hence we will need to find out how to disable SGMII AN for this PHY.

If anyone can give me good remote access which would allow me to experiment with this PHY and figure out what the problem is, that would make it a bit faster.

1 Like

Ok, I can give you remote access, how we can contact?

Great. If you can run tmate on a machine connected to the serial port and Ethernet that would be amazing. In that way I can fully access the device. If there is a way to remotely power-cycle the device that would be a plus, but I don't think I will hard-crash it too much, and if it happens, I will tell you and let you reset it manually :wink:
Send me a PM here in forums with credentials or use email.

Or, if you like, first of all try this patch

Ok, I probably can set up all this, give me some time to do this

1 Like

Thanks, for taking over this issue. The link you provided, ends in an Error 404 page.

The fix became a pull request:

4 Likes

The patches are working. Do you need any logs? Unfortunately, I can't give you remote acces to my wax.

Thank you for testing, I've already had access yesterday and was tinkering with the WAX206 of @Sad-Soul-Eater which helped me to investigate and figure out a solution. I will merge the PR to OpenWrt later today if nobody complains.

Edit: done.

2 Likes

@daniel I think this issue may have returned. I updated a wax206 to a build with kernel 6.6 (from 6.1.77) and the wan port stopped working.

I was able to work around it by splitting out one of the lan ports to use as wan.

I'll go swap it with another device tomorrow and bring it back to test and gather more information.

I couldn't see any obvious issues in the logs. There was no indication of a link in luci.

1 Like

Same here, I tried to force 1Gb speed with ethtool but it didn’t work. I rolled back to 23.05.3 and it works.

Please test the device with https://github.com/openwrt/openwrt/pull/15634 which sync's RealTek PHY drivers with what is now in upstream Linux. If we still see this problem (again) then at least we can now send a patch upstream to fix it...