Iv started seeing an odd issue with my WAX206 being used as an AP.
Download speeds are fine however upload speeds are always seemingly capped at 10mbps ( see screenshot )
Test - Client Intel Corporation Wi-Fi 6E(802.11ax) AX210
The same issue is seen on my Google Pixel 9 and Lenovo Laptop (MT7921 WiFi card)
Device Info
{
"kernel": "5.15.167",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "Netgear WAX206",
"board_name": "netgear,wax206",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.5",
"revision": "r24106-10cc5fcd00",
"target": "mediatek/mt7622",
"description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
}
}
Network Config
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdb3:f952:d609::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'wan'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
list dns '192.168.1.1'
WiFi Config
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/18000000.wmac'
option channel '10'
option band '2g'
option htmode 'HT40'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'beehive2'
option encryption 'sae-mixed'
option key '****'
config wifi-device 'radio1'
option type 'mac80211'
option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option channel '104'
option band '5g'
option htmode 'HE80'
option cell_density '0'
option country 'GB'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'beehive'
option encryption 'sae-mixed'
option key '****'
Wed Enabled
root@OpenWrt:~# cat /etc/modules.conf
# examples:
# options mod1 option=val
# blacklist mod2
options mt7915e wed_enable=Y
As this is a dumb AP and not using all ports bridged i installed bridger and have hardware flow offloading enabled and am getting the (seemingly) correct outputs from /sys/kernel/debug/ppe0/bind
:
root@OpenWrt:~# cat /sys/kernel/debug/ppe0/bind
0034a BND IPv4 5T orig=195.8.126.250:8080->192.168.1.139:32858 new=195.8.126.250:8080->192.168.1.139:32858 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=364 bytes=552552
00356 BND IPv4 5T orig=195.8.126.250:8080->192.168.1.139:32852 new=195.8.126.250:8080->192.168.1.139:32852 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=190 bytes=288420
00392 BND IPv4 5T orig=195.8.126.250:8080->192.168.1.139:32822 new=195.8.126.250:8080->192.168.1.139:32822 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=8382 bytes=12720980
0039a BND IPv4 5T orig=195.8.126.250:8080->192.168.1.139:32818 new=195.8.126.250:8080->192.168.1.139:32818 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=351 bytes=531370
00ba2 BND IPv4 5T orig=185.151.31.4:8080->192.168.1.139:55892 new=185.151.31.4:8080->192.168.1.139:55892 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=790 bytes=1197772
00bc2 BND IPv4 5T orig=185.151.31.4:8080->192.168.1.139:55908 new=185.151.31.4:8080->192.168.1.139:55908 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=621 bytes=941230
00dd0 BND IPv4 5T orig=129.67.206.50:8080->192.168.1.139:42722 new=129.67.206.50:8080->192.168.1.139:42722 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=24687 bytes=37400054
00dd8 BND IPv4 5T orig=129.67.206.50:8080->192.168.1.139:42726 new=129.67.206.50:8080->192.168.1.139:42726 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=1701 bytes=2577774
00e16 BND IPv4 5T orig=129.67.206.50:8080->192.168.1.139:42752 new=129.67.206.50:8080->192.168.1.139:42752 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=676 bytes=1024720
0137a BND IPv4 5T orig=185.151.31.4:8080->192.168.1.139:55864 new=185.151.31.4:8080->192.168.1.139:55864 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=202 bytes=306636
0139a BND IPv4 5T orig=185.151.31.4:8080->192.168.1.139:55880 new=185.151.31.4:8080->192.168.1.139:55880 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=644 bytes=977592
01702 BND IPv4 5T orig=81.16.176.244:8080->192.168.1.139:42630 new=81.16.176.244:8080->192.168.1.139:42630 eth=22:69:ac:9c:43:51->e8:f4:08:d8:a2:7f etype=0008 vlan=0,256 ib1=21405282 ib2=007e0460 packets=496 bytes=752928
Things I have tried :
- Remove bridger and disable hw flow offloading
- Disable WED on wifi module
- Reboots (many)
- Different channels and 40/80/160 widths
Edit, this also affects my 2G network as well
Any other suggestions would be appreciated, thanks