Netgear WAX202 - PPPoE Issues

Hello,

I have previously searched for "PPPoE" in the forum and still nothing seems to fix the issues I have with my Netgear WAX202 on 23.5.2.

I have a DrayTek Vigor 166 modem which is in bridge mode (internet works fine when in modem mode and my ISP details are entered) but I can't seem to get my OpenWRT router working via PPPoE.

My Vigor is on subnet 192.168.45.1 and my router is 192.168.45.122.

My modem does detect a DSL connection when in bridge mode and the ISP VLAN is set to 101 in the settings of the modem.

I just need some help getting my router to get a PPPoE connection as it keeps saying " Error: Unknown error (USER_REQUEST)" then " Error: Connection attempt failed".

Below are my config details:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4b:bb4e:7cd1::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config device
        option name 'lan1'
        option macaddr 'MAC_ADDRESS'

config device
        option name 'lan2'
        option macaddr 'MAC_ADDRESS'

config device
        option name 'lan3'
        option macaddr 'MAC_ADDRESS'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.45.122'
        option netmask '255.255.255.0'
        option gateway '192.168.45.1'
        option delegate '0'

config device
        option name 'wan'
        option macaddr 'MAC_ADDRESS'

config device
        option name 'eth0.101'
        option type '8021q'
        option ifname 'eth0'
        option vid '101'
        option ipv6 '0'

config interface 'WAN'
        option proto 'static'
        option device 'wan'
        option ipaddr '192.168.45.1'
        option netmask '255.255.255.0'
        option delegate '0'
        list dns 'ISP_DNS'
        list dns 'ISP_DNS2'

config interface 'Modem'
        option proto 'pppoe'
        option device 'wan.101'
        option username 'ISP_ID'
        option password 'ISP_PASS'
        option ipv6 '0'
        option delegate '0'

config device
        option name 'wan.101'
        option type '8021q'
        option ifname 'wan'
        option vid '101'
        option ipv6 '0'

Could someone please help as I need my wifi working.

My guess is it may be a VLAN, DNS or that I've not set my static ISP IP Address somewhere?