Netgear WAX 202 snapshot builds are broken, no WIFI


Come on what?

I made the image twice, given your 2 different lists (I even quoted both). Anyways, we've established I'm using the same image now and that my hardware works.

We're now trying to determine if you have a different submodel - and perhaps that's the cause of your WiFi issue.

You've just said luci is missing from my list when it's right there.

You are not making a lot of sense now.

A submodel? This isn't a prototype or some kind of "enterprise"/ business-oriented variant, it's a standard WAX202 with a label at the bottom confirming as much.

  • You posted a list twice
  • I make an image from both lists
  • I made 2 sets of screenshots of those lists and the builder's success (just review them)
  • As I noted - they create the same image anyways - per the hash from the site

So I'm not sure what the debate is about. Again, we're trying to determine the difference with the hardware now; but you seem to wanna debate if I actually made the same image or not?

Quote it, because the one you referenced above is the same one I quoted and it does contradict you.

luci is not listed. You've been repeating over and over, the OP has the list - so I used it - and it's missing luci.

Is this some joke?

Do you want assistance?

There's no need to debate - I made the same image, my wireless still works.

Also, I can take a picture of my box and router if you think I have something else...

You are frustrating and not helpful at all. That other user noticed as well, your questions are redundant and pointless. How does this line of questioning differ from that of yesterday? You keep asking me questions that have already been answered.

I'm sorry, but that's bullshit. The first list you quoted was in response to your request for my list of installed packages. Luci isn't in the OP because as you kindly explained:

And so now I will ask you one last time to drop your nonsense.

So you don't have a Latin or European model of the WAX202 - or an updated one.

OK, my apologies - I didn't see that answer. Thanks for clarifying.

Then in that case, I would advise you to return your device for RMA or refund. I understand you insist it's a software issue, but given an identical firmware was used here on multiple devices, I've yet to have a Wireless failure.

Perhaps you'll get one that doesn't experience said issue.

My other advice was to reset to default and show the wireless configuration after you setup again - but since you claim you made clear you did so already and how you setup wireless again (given wireless is disabled by default, I assume one setup the device over again), I didn't want you to repeat yourself.

Reason: perhaps theres a syntax error from stock or previous versions.

Don't know why I bother entertaining this crap anymore. Childish.

There isn't a spec difference. It's only 1, and is sold in the US and EU. Biggest difference is in country code and reseller. Stop moving goalposts; own your crap and leave this thread,

Screw your bs and your ninja edits.

Edits can be seen and note changes.

Well, last time i flash mutiple devices 4 times to assist someone who doesn't appreciate and doesn't wanna troubleshoot their wifi.

I wish you well.

If you wanna show fresh configs after a clean flash one day to troubleshoot as noted, feel free (I for one will not play image games just for an OP to decide not to troubleshoot anymore).

1 Like

In the contrary, do actually want to help others as opposed to leading other users in a very frustrating, wasteful goose chase. Help for the sake of doing good, not to feel good. So much condescension and gaslighting coming from someone who's spent half a thread calling my judgement into question without right or reason.

@Borromini helped. No fuss or debate, just a good ol' helping hand. Actually learned something new since I had no idea what that error meant. Be more like @Borromini.

OEM's have revisions, not spec bumps mid release cycle. If you didn't already know that then you have no business asking me if it matches what's on the box, if it's some kind of "submodel", even misquoting me. Maybe if you actually cared to empathize this thread wouldn't be 40 shades of Reddit.

Feel free to provide the requested information to further assist. Configs speak, your discussion seems to be more so about opinion on the hardware you say isn't broken. It's established we're using the same software, and you insist we're using the same hardware.

Reasoning: I will use the wireless config and test. Or maybe someone else can.

I wasn't aware you didn't know what the error meant given your wireless wasn't recognized, well good for @Borromini. I'm glad that solved one concern.

I do apologize, I wasn't aware he solved the issue you're having (for what it's worth, let me just believe that). I now understand why you got upset when I continued my line of discussion about firmware and the hardware model today,

I digress and stop following the thread. Good day.

1 Like

But not before gracing my thread with your unhelpfulness and condescension one last time. Lovely.

Well to anyone who cares to know, the default package selection for WAX202 snapshots is broken. It begins with -uboot-envtools, when it should be uboot-envtools without the "-". Due to this, uboot-envtools isn't being included in the builds.

That's [obviously] known and as expected. There's no need to alter UBoot on a WAX202 before or after converting to OpenWrt. It also saves on image space - it can be downloaded/installed if [somehow theoretically] needed. Lastly, it's suggested here to manipulate/verify that serial is working, so you don't corrupt the UBoot env using a software tool after boot.

(FYI - You should make a new topic for different issues.)

(Also, if you don't reply to me, I don't get notifications from a person - regarding a topic I unfollowed.)

(Edited to add why the tool's use is generally discouraged.)

Even if you mean well I'd appreciate it if you do unfollow this thread and permit others, if anyone, to contribute.

If their intention was to exclude it there wouldn't be any mention of it in the package selection. Simply not being there would have sufficed, so why keep it? I'm sure there are hundreds of other packages that don't apply to WAX202.

Do I really have to get a mod involved for you to actually, finally let my thread be?

Everyone can see the thread.

If anyone wanted to jump in nothing has stopped them other than your vitriolic replies.

1 Like

If you bothered to read the thread you'd know to bring your tough internet guy volume down to a healthy 5. A lilreddog barking like a bigreddog, fitting. Go advocate for the wrong side on a different site if you aren't here to contribute anything of value.

Apparently I'm a magnet for people who love to hear the sound of their keystrokes.

1 Like

For the naysayer who believes their understanding of this router, or any router for that matter to be absolute. Yes, the WAX202 much like the WAX206 stores more than 1 bootable session. I flashed 23.05.2 onto it and was greeted with what you see in this picture. I then cut the power, waited exactly 2 minutes, then restarted it in order to demonstrate persistence. Meaning what's shown in the picture was still there. I then pressed the reset button on the back and *drum roll* it booted into Netgear's WAX202

Don't believe me? Don't care. Anyone's welcomed to prove otherwise.

Check again.

(So you replied to me again. :wave: - remember that when threatening a mod.)

Since you insisted that I answer a question (and I don't wanna hear the sound of my own keyboard to do so):

So long as you continue to adhere to the forum rules (i.e. not going off topic by insulting posters, tolling about images, etc.) - no need.

You seem to not care - that your device has some hardware issue - or is different somehow.

I'm curious to know the actual steps you used to boot into this. And no - "I flashed 23.05.2" isn't a list of steps. I flash 23.05.2 here on multiple devices - and it boots into 23.05.2.

I'm guessing that you haven't realized yet - that somehow your 23.05.2 flashes are failing and you're going between stock and some phantom image - likely the SDK provided to Netgear from the MediaTek chip manufacturer.

I surmise your flash got corrupted somehow - many flash attempts ago.

Just FYI, one of those partitions may have the nprflash recovery - I would again advise an RMA of your device.

It seems to be occurring to you - you should simply give us the steps and information, not be insulting and tell us to check our [working] devices again. I for one don't want to soft brick a device just because you're upset at your broken WAX202 and you want company.

(EDIT - to intentionally expound/be verbose on explaining the quotes - so the "nija edit" marks appear over my post. :ninja: )

1 Like

That shouldn't matter. This commit moved uboot-envtools to the default package set for mt7621, and since the WAX202 never had it onboard to begin with, it's 'subtracted' from the device recipe. So that is correct.

See the relevant commit:

1 Like