Netgear WAX 202 snapshot builds are broken, no WIFI

The presence of those packages isn't problematic. Luci packages are self explanatory with the exception of bcp38, more on that here. Stubby for end-user benefit, also helps a bit with ads depending on resolver without too much overhead. Basically not terrible and it works. The other two are to put root in a short leash starting with this guide here.

Looks like it, yes. Now that I see your build working I'm going to build it again reading from your screenshot for sanity's sake. If it doesn't work I'll nuke this thread and smash this WAX202 until I can't tell what it was.

My list doesn't include:

1 Like

You didn't answer my inquiry. From your statement, it seems "no" you didn't alter the list.

It's been a rough Friday for reading posts. :people_hugging:

:ok_hand: Feel free to try again:

Wait, but I did exclude several. Mentioned it in the OP.

I'm in shambles. When will it end.

Since:

  • I read that already; and
  • I already asked you why - but you failed to mention those packages when explaining (I can't guess why you leave out certain packages and desire others)

Yea...for brevity - no need to answer why, I'll just suggest the following - since this just worked for me here:

  • Don't omit any packages
  • Just add your desired packages to the Firmware Selector

luci-ssl sudo luci-app-advanced-reboot luci-app-bcp38 shadow-useradd stubby

EDIT:

Or just download (if you request a build with an identical package list, it should generate the same link):

Doesn't it bother you that the absence of optional dependencies breaks network functionality altogether? I'm doing a build now with everyone and their grandkid baked-in since Openwrt took it upon themselves to turn what are without doubt unessential packages into hard dependencies. Feels like I'm trying to downsize KDE; remove a pebble from your shoe and now you have 5GB's of extra / space with half the kernel gone.

Look, I've done the build according to your steps. Every. Single. Package.

It does not work. Meaning, the same build that worked for you (linked in your comment) did not work for me. This can only mean 1 of 2 things: It's a hardware problem that coincidentally begane the second I decided to flash SNAPSHOT r25207-be9023ed43 or there's a configuration somewhere not getting scrubbed even with Keep Settings deselected in Luci. Beyond that I am out of ideas. My gut tells me it's something being left behind across flashes.

Will try again in an hour, I'm beat for now.

@lleachii Let's focus on what's really the issue here: the WiFi not working. With that in mind, this speaks volumes in the boot log:

mt7915e: probe of 0000:02:00.0 failed with error -22

The radio is not being found. That's what needs to be fixed. His version string suggests a clean OpenWrt image, there's no need to fixate on all those other things.

@Nettle Are you compiling yourself? Could you try building with kernel 6.1? I have tested 6.1 on a few of my own mt7621 devices already and some break (6.1 is the testing kernel).

1 Like

@lleachii The culprit lies somewhere outside my control. It's not the hardware, and I took extreme measures to make sure the steps I took were by the book. Used only the files linked in your comment.

I did learn that nmrpflash is put together by shit and snot, it isn't a reliable tool worth keeping around. The wiki instructions are incorrect also; it's not port 1, it's WAN in WAX202's case, meaning port 0. Don't remember seeing a modern Netgear router in recent years use the color blue to label a goddamn thing. Not WAX202's wiki or any git issue explains why the hell does a hard reset leave behind settings from both prior flashes across rom's. What does this mean? Stock settings survive Openwrt installations. I know this because I'm not the only one who's had to deal with Openwrt's bullshit, or maybe it's Netgear's. Point is this stuff should be documented somewhere accessible to the public but isn't.

To restore stock I had to copy the goddamn firmware into the router manually and do a seamless flash a-la Android A/B with mtd via ssh. After that I was greeted with my old stock config.

Guess what? The WIFI then did NOT work until AFTER I did a factory reset from within stock. Not Openwrt, since apparently their resets mean jackshit. Only then, and only then did radio come back to life.

Arch Linux's forums might not be the most user-friendly but goddamn it can they put together a proper wiki. Meanwhile in Openwrt land the word "reset" is used loosely, merely a suggestion.

f*ck my life.

1 Like

Thank you. Felt I was going insane, my OP has been proper from the start.

Btw that error string yields 0 results in Google. Anyone else who encounters it won't know where to look for help.

No, I am using the official automated builder found here. As of this moment snapshots are built against 5.15.148-1.

I did make some progress, though short lived. I discovered WAX202 does in fact store other firmwares like WAX206. Whether or not this is documented is beyond me. Used mtd as explained in my cutesy little rant above, this time I used it to flash an Openwrt .img (as opposed to sysupgrade's .bin) and it booted into yesteryear:

Powered by LuCI mtk7622_mtk7915_wax206 branch (git-21.363.21759-36bc3bb) / LEDE Netgear WAX202 17.01-SNAPSHOT r0-36bc3bb64

That does not match the snapshot I flashed. The login interface looked dated hence why I made a note of it.

  • It asked for an unknown password.
  • It gave me an option to "reset" right next to "login" which did nothing.
  • The snapshot I should have been greeted with is >23.05.2.

More interesting still, I went ahead and pressed the reset button right above the WAN port and after it reset this cursed WAX202 booted into stock firmware. Not what you see above or one of the many snapshots mentioned here today, plain stock. Confused, I reflashed Openwrt through the stock Netgear interface.

You'll be glad to know that while in stock and after a reset WIFI functionality is restored, working as intended. Reflashing Openwrt with or without my package selection in the OP results in no WIFI. Now I've narrowed it down to software, and it looks to be in Openwrt's court.

Maybe I'm not being clear. Wireless works here when I flash the image - on mutiple WAX202's.

Perhaps he has a hardware-based issue - despite the Op's disagreement?

Very - @frollic are you aware of a dual partition on the WAX202?

Also, the description of the reset seems faulty.

Sorry.

Mixing 202 and 206, no idea about the 202.
206 uses dual fw.

1 Like

Also I just noticed this, I think the OP is describing the same thing twice. This is Netgear firmware, the WAX202 didn't exist during the life of 17.01-SNAPSHOT.

Where did you see this message?

  • Are you connected via serial?
  • If so, did you mtd write from OpenWrt or stock?

Nevermind, it says you flashed via SSH - assuming from the running non-WiFi OpenWrt image - but it's not clear where the message is seen.

It has to be hardware-related if only your WAX202 has issues when flashing. I'm successfully flashing multiple WAX202's, and they maintain working WiFi.

I wonder... :thinking:

  • Do you still have your box?
  • If so - as per the label, do you have a WAX202B-100NAS?
  • What's your WiFi config?
  • Are you saving settings across flashes (I ask because CLI flashing has been done, web flashing, recovery flash, etc. on OpenWrt and stock)?
  • Just to be clear, you are aware that WiFi is disabled in default OpenWrt images, correct?

cat /etc/config/wireless

Well, what I've described is accurate and is as confusing to me as it is for everyone else. I'm not using tools or instructions not already documented either here in the forums or in the wiki.

If you have any tips or guides you'd like to suggest I'm all eyes and ears.

That is what booted. Imagine flashing Openwrt 23.05.2 and instead of that you get:

And after pressing the reset button in the back (right above WAN) you are presented with: WAX202 1.0.5.1.

This happened in that order. Both two completely different login prompts. I am telling the truth.

If I can restore WIFI by simply restoring stock and subsequently reseting the router then there's more to it. You may have doubts, doesn't make it any less true.

Your sysupgrade images linked above don't match my package selection. Build without odhcp6c, odhcpd-ipv6only, ppp, and ppp-mod-pppoe. I've added nano to the list of included packages. Do that, update via Luci and keep your settings. For reference I went from 23.05.0 to yesterday's snapshot (first one mentioned in the OP).

I'm going to kindly ask you to stop disrespecting other people's intelligence.

Are you aware that there's an error log in the OP. Same log that would tell us if it was a hardware problem or not. Logs are plenty verbose as they are.

And I'm the selective reader.

1 Like

I was trying to see if they're different hardware versions (i.e. one thing that might explain how you flash stock and have working WiFi, but OpenWrt doesn't).

Not sure how that insults someone's intelligence - but I'll stop assisting at this time.

Yes I am - hence all the inquires in my post. Again, you seem not desite to respond.

I also made an image with your exact package selection - it also works. Unfortunately, the webpage has upgraded the available snapshot, I will do it again and screenshot that:

screen716

Please review the list to verify that it is identical to yours - again, I have no wireless issues here.

-uboot-envtools base-files busybox ca-bundle dnsmasq dropbear firewall4 fstools kmod-crypto-hw-eip93 kmod-gpio-button-hotplug kmod-leds-gpio kmod-mt7915-firmware kmod-nft-offload libc libgcc libustream-mbedtls logd luci mtd netifd nftables opkg procd procd-seccomp procd-ujail uboot-envtools uci uclient-fetch urandom-seed urngd wpad-basic-mbedtls luci-ssl sudo luci-app-advanced-reboot luci-app-bcp38 shadow-useradd stubby

Most of your questions were already answered in the OP. You asked me to double-check to see if this WAX202, same one linked and referenced throughout this entire thread, is in fact a WAX202 by looking at the box. Your efforts are appreciated, really they are; just not that line of questioning, my eyes aren't lying to me. Aren't you going to ask me if anyone besides myself can feel and see the router?

All relevant information was readily available as appreciated by another user. I've addressed your inquiries; haven't I been transparent enough? What other relevant detail haven't I already shared? Have done everything I can to help the good people of this forum help me in return.

Your list is missing luci - but it's added in the build as a prerequisite anyways.

FYI, The Firmware Selector sees it as the same file (same hash, filename, URL, etc).

Now [all of my screenshots show] they do - I still have WiFi as previously noted.

Since it's been refreshed I will have to regenerate it and report back.

Add nano to the list and you're done. Sanity checked as well (others made sure both lists were identical). Include nano, generate, and sysupgrade in a minute. Will let you know how that goes.

Huh!?!?

Maybe if I show you a reference - you'll understand what I'm asking - and why I'm asking.

I'm specifically asking if your device is submodel B-100NAS (that were commonly sold in the US around the time of the linked thread). I see trying to solve your Wireless issue is frustrating, so perhaps you should return when you don't think someone is accusing you of paranoia or something.

Reasoning for my inquiry - if your device is another submodel - maybe it has different hardware - hence your issues.

A direct quote from my list, unedited

I can see it in the list you just quoted. Come on.