Netgear R8000 on LEDE 17.01.4 Boot program checksum is invalid


Trying to move from OpenWRT to latest LEDE version on R8000 but for some reason, the firmware is corrupted on boot. Here is what I've tried.

  1. upload the lede firmware.
  2. device reboots.
  3. Everything is up and ready to be configured.
  4. login to Luci and reboot the device or do this manually.
  5. device does not come back.

IT has network at, but I cannot ssh to it and no Luci. Tried this many times and always the same results. In fact, very similar results on the latest nightly build of OpenWRT for the same router. The only firmware I can run is ChaosCalmer 15.05 which does not have the Wifi fix.

finally connected a serial console and I see that on boot, I get the following:

Device eth0: hwaddr XXXXXX, ipaddr, mask
gateway not set, nameserver not set
Checking crc…Boot program checksum is invalid
Device eth0 has been deactivated.
Device eth0: hwaddr XXXXXX, ipaddr, mask
gateway not set, nameserver not set
Start TFTP server
Reading ::

I have checked the checksum of the firmware I downloaded and it matches, the size of the file on disk and upload through tftp also match. I also noticed a bunch of errors during the initial firmware install:

[ 0.636426] Scanning device for bad blocks
[ 0.660662] Bad eraseblock 33 at 0x000000420000
[ 0.719532] Bad eraseblock 124 at 0x000000f80000
[ 0.904796] Bad eraseblock 424 at 0x000003500000
[ 0.950941] Bad eraseblock 490 at 0x000003d40000
[ 1.083974] Bad eraseblock 693 at 0x0000056a0000
[ 1.230327] Bad eraseblock 917 at 0x0000072a0000
[ 1.285354] Bad eraseblock 997 at 0x000007ca0000
[ 1.313702] random: nonblocking pool is initialized
[ 1.355490] mtd_read error while parsing (offset: 0xF80000): -74
[ 1.533110] mtd_read error while parsing (offset: 0x30A0000): -74
[ 1.545878] mtd_read error while parsing (offset: 0x3200000): -74
[ 1.552363] mtd_read error while parsing (offset: 0x3220000): -74
[ 1.558838] mtd_read error while parsing (offset: 0x3240000): -74
[ 1.565323] mtd_read error while parsing (offset: 0x3260000): -74
[ 1.571805] mtd_read error while parsing (offset: 0x3280000): -74
[ 6.303653] pci 0001:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[ 6.312154] PCI: bus1: Fast back to back transfers disabled
[ 6.317743] pci 0001:01:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[ 6.325954] pci 0001:02:00.0: unknown header type 12, ignoring device
[ 6.333107] pci 0001:02:03.0: [Firmware Bug]: reg 0x10: invalid BAR (can’t size)
[ 6.340555] pci 0001:02:03.0: [Firmware Bug]: reg 0x14: invalid BAR (can’t size)
[ 6.347979] pci 0001:02:03.0: [Firmware Bug]: reg 0x18: invalid BAR (can’t size)
[ 6.355415] pci 0001:02:03.0: [Firmware Bug]: reg 0x1c: invalid BAR (can’t size)
[ 6.362845] pci 0001:02:03.0: [Firmware Bug]: reg 0x20: invalid BAR (can’t size)

tried the 30-30-30 rest about a dozen times to no avail. is this really a firmware issue or do I have to somehow reset my router in another way to get past this?


Which firmware file did you use to flash LEDE?

Supported firmware...[Brand*~]=netgear&dataflt[Model*~]=r8000

I would not do a 30-30-30's no longer needed on current ARM devices.

Use the reset button.

You might try flashing back to Netgear factory from Chaos Calmer, and then flashing LEDE from Netgear factory.

Thanks. That is the same firmware I tried, and I tried both of your suggestions.

It almost seems to be something in OpenWRT based firmware past the 15.01 that causes this.

I tried all these things with CC 15.01 as well and that works every time. But anything past that CC or LEDE causes this issue for me. Works after firmware upload until I reboot. And I can do this all day.with the same result.

I recently tried v17.x and got the same issue as you above and eventually got a USB to serial adapter and got
my r8000 back to stock.

I just noticed there is a new release now, have you tried the new v18 release? I am a bit wary of trying out and having to open the R8000 back up again lol

I went through the same pain, but never got it working. I have since moved on to another router altogether.

Good luck.

Hi! I'm considering going into using OpenWRT as well on an r8000. Have you had any luck with the device?

I did end up trying it out and it flashed and booted fine for me, I also tried rooter on it and it worked as well, however you might need to fiddle with the WiFi a little bit though.