Netgear R8000 install OpenWrt

I have a new Netgear R8000, Firmware Version: V1.0.4.46_10.1.63.

When I upload openwrt-19.07.4-bcm53xx-netgear-r8000-squashfs.chk via web interface, I receive the error: "This firmware file is incorrect! Please get the firmware file again and make sure it is the correct firmware for this product."

I am also connected to my device via serial port and can run commands in BusyBox environment.

I tried to change board_id with nvram command from U12H315T00_NETGEAR to U12H315T00_NETGEARHDR0. Then tried to upload again and received the same error above. nvram commit then rebooting the device didn't help.

I tried to run tftpd, error: /bin/sh: tftpd: not found

I tried to run /mnt/, error:
/mnt/ line 2: /mnt/shares/usr/bin/scripts/ not found
/mnt/ line 3: /mnt/shares/usr/bin/scripts/ not found

I am able to copy firmware file to device via USB flash, but I don't know how to apply it.

I copied whole /www folder of device to my computer and tried to read web interface and see how it would install firmware, but couldn't find any useful information since I don't know how to trace events when a button in a web page is pressed.

Is there anyway to install OpenWrt in this device?

fwiw, are you sure you wish to install OpenWrt on R8000 ?

The R8000 is a Broadcom device and there is little or no support for Broadcom wifi. If you search the forums, you will discover reports of wifi issues from users who did install OpenWrt.
Note the warning at top of wiki page.

For Broadcom devices, you should consider DDwrt and Tomato.

Disclaimer: I've never owned the device in question (nor similar wifi chipsets).

The r8000 is kind of unique for broadcom based routers, as it ships with fullmac supported wireless cards, which are supported by FOSS mainline drivers (brcmfmac). Contrary to their more common softmac based relatives, these drivers should be fully supported (but driver+firmware don't allow every interface combination, especially in terms of combining STA and AP interfaces). While I wouldn't exactly recommend buying this device with OpenWrt in mind (as it's relatively rare, meaning there are only few users who can help you with potential issues), it should be fully supported and working to a pretty reasonable extent (only Broadcom's proprietary (accelerated) firewall helpers missing).

Changing board_ids always sounds wrong, given that r8000 has only been added rather recently I would expect it to work, provided you follow the installtion instruction in your device's wiki page, if not you may need serial console access to see what happens and to eventually use tftboot for the installation; maybe also mail (and CC Rafał) for additional help.

1 Like

I was able to build OpenWrt master branch and install using official web interface. Whatever was problem in 19.07.4, seems to be solved.
Thanks every one.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.