Netgear R8000 2.4GHz fails to scan. Did my hardware break?

My 2.4GHz channel is failing to scan and has seemingly stopped working entirely. I have had OpenWRT running for over a year with no issues and then all of a sudden my 2.4GHz devices stopped connecting. I haven't updated anything recently, so there isn't any obvious reason why it would start failing all of a sudden. 5GHz continues to work just fine.

Is there a way that I can check if my 2.4GHz hardware started failing? I have already tried restarting that radio (radio1) and also tried rebooting the router but the problem persists.

Here's what radio1's scan looks like:

Set country code?

The country code is already set to US - United States (where I'm located).

Maybe nobody near has wifi? Can you run channel analysis in status?
Also iwinfo from command line.

There are tons of 5GHz channels near me, so I believe there should be 2.4GHz as well. Channel analysis shows the same thing:

root@rootkit:~# iwinfo
phy0-ap0  ESSID: "rootkit"
          Access Point: {redacted}
          Mode: Master  Channel: 161 (5.805 GHz)  HT Mode: VHT80
          Center Channel 1: 155 2: unknown
          Tx-Power: 31 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: 401.1 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/n
          Hardware: 14E4:AA52 14E4:AA52 [Broadcom BCM43602]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

phy1-ap0  ESSID: "rootkit"
          Access Point: {redacted}
          Mode: Master  Channel: 11 (2.462 GHz)  HT Mode: NOHT
          Center Channel 1: unknown 2: unknown
          Tx-Power: 0 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11b/g/n
          Hardware: 14E4:AA52 14E4:AA52 [Broadcom BCM43602]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

wlan2     ESSID: unknown
          Access Point: {redacted}
          Mode: Client  Channel: 36 (5.180 GHz)  HT Mode: HT20
          Center Channel 1: 36 2: unknown
          Tx-Power: 31 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11ac/n
          Hardware: 14E4:AA52 14E4:AA52 [Broadcom BCM43602]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy2

The radio is plainly down.

It should be in logread -e hostapd some long command line starting radio then saying it failed.
Can you show /etc/config/wireless sections around 2.4 radio and access points? obviously clear out MAC addreses and passwords

Unfortunately there isn't any output from either of these commands

root@rootkit:~# logread -e hostapd
root@rootkit:~# logread | grep hostapd

Here are the wireless sections:

root@rootkit:~# cat /etc/config/wireless

...

config wifi-device 'radio1'
        option type 'mac80211'
        option path '18000000.axi/bcma0:8/pci0001:00/0001:00:00.0/0001:01:00.0/0001:02:01.0/0001:03:00.0'
        option channel '11'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option country 'US'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'rootkit'
        option encryption 'psk2'
        option key '{redacted}'

...

Config is completely generic - go to luci, restart 2.4 interface and check logread -e hostapd additions during interface restart. In general check logread - there should be some intense messages rewriting it, as it is 1-2 lines when client connects or disconnects under normal operation.

1 Like

I believe this is what we want (looks like my date/time are off on the router):

root@rootkit:~# logread -e hostapd
Mon Apr  8 10:30:17 2024 daemon.notice hostapd: Set new config for phy phy1:
Mon Apr  8 10:30:18 2024 daemon.notice hostapd: Set new config for phy phy1:
Mon Apr  8 10:30:18 2024 daemon.notice hostapd: Set new config for phy phy1: /var/run/hostapd-phy1.conf
Mon Apr  8 10:30:18 2024 daemon.notice hostapd: Restart interface for phy phy1
Mon Apr  8 10:30:18 2024 daemon.notice hostapd: Configuration file: data: driver=nl80211 logger_syslog=127 logger_syslog_level=2 logger_stdout=127 logger_stdout_level=2 country_code=US ieee80211d=1 hw_mode=g supported_rates=60 90 120 180 240 360 480 540 basic_rates=60 120 240 beacon_int=100 chanlist=11 #num_global_macaddr=1 ieee80211n=1 ht_coex=0 ht_capab=[SHORT-GI-20][DSSS_CCK-40] channel=11  interface=phy1-ap0 bssid={redacted} ctrl_interface=/var/run/hostapd ap_isolate=1 bss_load_update_period=60 chan_util_avg_period=600 disassoc_low_ack=1 skip_inactivity_poll=0 preamble=1 wmm_enabled=1 ignore_broadcast_ssid=0 uapsd_advertisement_enabled=1 utf8_ssid=1 multi_ap=0 wpa_passphrase={redacted} wpa_psk_file=/var/run/hostapd-phy1-ap0.psk auth_algs=1 wpa=2 wpa_pairwise=CCMP ssid=rootkit bridge=br-lan wds_bridge= snoop_iface=br-lan wpa_disable_eapol_key_retries=0 wpa_key_mgmt=WPA-PSK okc=0 disable_pmksa_caching=1 dynamic_vlan=0 vlan_naming=1 vlan_no_bridge=1 vlan_file=/var/run/hostapd-phy1-ap0.vlan qos_map_set=0,0,2,16,1,1,2
Mon Apr  8 10:30:18 2024 daemon.notice hostapd: nl80211: deinit ifname=phy1-ap0 disabled_11b_rates=0
Mon Apr  8 10:30:18 2024 daemon.err hostapd: nl80211 driver initialization failed.
Mon Apr  8 10:30:18 2024 daemon.notice hostapd: phy1-ap0: CTRL-EVENT-TERMINATING
Mon Apr  8 10:30:18 2024 daemon.err hostapd: hostapd_free_hapd_data: Interface phy1-ap0 wasn't started
Mon Apr  8 10:30:18 2024 daemon.notice hostapd: hostapd.add_iface failed for phy phy1 ifname=phy1-ap0

ht_capab=[SHORT-GI-20][DSSS_CCK-40]

this list seems very short, can you checl agaist iw list, kind of it deserves at least some multi-antenna cap bit.

root@rootkit:~# iw list

...

Wiphy phy1
        wiphy index: 1
        max # scan SSIDs: 10
        max scan IEs length: 2048 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports roaming.
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * P2P-client
                 * P2P-GO
                 * P2P-device
        Band 1:
                Capabilities: 0x1022
                        HT20/HT40
                        Static SM Power Save
                        RX HT20 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 16 usec (0x07)
                HT TX/RX MCS rate indexes supported: 0-23
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed } <= 1, #{ P2P-device } <= 1, #{ P2P-client, P2P-GO } <= 1,
                   total <= 3, #channels <= 1
                 * #{ managed } <= 1, #{ AP } <= 1, #{ P2P-client } <= 1, #{ P2P-device } <= 1,
                   total <= 4, #channels <= 1
                 * #{ AP } <= 4,
                   total <= 4, #channels <= 1, STA/AP BI must match
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Supported extended features:
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records

I just restarted the router for a second time and it started working... Not sure what went wrong, but it seems to be resolved now.

1 Like

Glad to hear.
save "good" dmesg today to compare if it fails later.

1 Like

Good idea, thanks for your help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.