Netgear R7800 upgrade to 23.05-rc2 fails

Today I tried to upgrade my R7800 from 22.03 to 23.05-rc2 using the factory image downloaded from official openwrt here:

I have not tried the sysupgrade image as I do not want to risk bricking the router without asking first.

I upgraded from Luci. After uploading the above image I get the usual red warnings. I unticked save current configuration and ticked force upgrade. This procedure to upgrade from 22 to 23 worked with my other Linksys routers (MR8300 EA8300).

The R7800 takes the upgrade, but then it reboots to 22.03 with its configuration unchanged. Clearly the upgrade fails, it is good that the router is not bricked or the configuration isn't even reset, but I cannot see any error using this method, therefore I have no clue why it fails to complete. Is it correct to use the factory image upgrading from 22 to 23?

Any suggestions?

if you already are running openwrt, upgrading to another release is done using the sysupgrade image.

1 Like

like frollic says, sysupgrade from a running OpenWrt is done with the sysupgrade image.

Factory image is only needed for

  • flashing from the OEM firmware, or
  • flashing using the u-boot bootloader recovery mode, TFTP

Not quite true since for my linksys routers I had to use the factory image due to major changes upgrading from 22 to 23. I need confirmation over which image to use for R7800.

If there are that kind of rare changes (like kernel size change in WRT1900ACv1 and WRT32x), the sysupgrade image metadata usually contains a flag preventing sysupgrade image usage, and you are seprately notified about that.

But that is a rare exception.

Normally it is the sysupgrade image that you need.

1 Like

OK thank you!