Netgear R7800 upgrade broke? (from 17.01.x)

It’s been over an hour and I’m still stuck on system flashing. Power light is still blinking. What should I do now?

I followed the sysupgrade instructions, unchecked keep settings box, checksum was good, going from 17.01.xx to 19.07.03. Haven’t had issues the last two updates I’ve done.

I don't think you can sysupgrade to 19.07 as from memory there was a partition size change, I think you will need to use a factory image via tftp to get it on 19.07 then sysupgrade will work from then onwards.

Taken from hnymans community build instructions.

1 Like

Thanks. So how can I back out of this failed flash update now? Sorry working from phone right now.

I think you can just power it off, then connect up via Ethernet, set a static IP and use the tftp procedure to boot a factory image...

1 Like

Ok thank. I’ll give that a try.

TFTP worked, back up and running the latest openwrt now, thanks.

I kept getting this terminal message/error in ubuntu: usage:tftp host-name [port]

I think it was related to timing the reboot/reset button with the tftp commands. I held the reset button for about 15 white led flashes, and added the commands below, which worked:

tftp> binary
tftp> rexmt 1
tftp> timeout 60
tftp> put openwrt-19.07.3-ipq806x-generic-netgear_r7800-squashfs-factory.img

This page walks thru the specifics:

1 Like

Yeah tftp with Linux is tricky at times, I always used...

tftp 69
put xxxxxxxxxxxx.img

I currently use in Windows the TFTP GUI tool "tftpd64" from jounin, as the earlier tftp2 from dd-wrt stopped to work with R7800 about two years ago.

The OEM flash routine apparently has some timeout, which plays badly with some clients (with default settings).

It should make no difference. The u-boot sequence just reacts to the reset button press (or actually a release) during the "white flashes".

Ps. Somebody has apparently recently added the incorrect/unnecessary "at least 10 times" advice to the R7800 wiki page. I have written the original version some years ago (originally to the forum in 2016 and to the new wiki in 2018), and there is no requirement of "at least 10 times". The key is to keep the reset button pressed, wait until the orange flashing (OEM Factory reset mode) is over and the white flashing (TFTP mode) begins. Then release the reset button. And the router will be in the recovery TFTP mode waiting for you. There is no rush after that.

As seen from serial:

U-Boot 2012.07 [local,local] (Sep 03 2015 - 17:33:28)

U-boot 2012.07 dni1 V0.4 for DNI HW ID: 29764958 NOR flash 0MB; NAND flash 128MB; RAM 512MB; 1st Radio 4x4; 2nd Radio 4x4; Cascade
S17c init  done
MAC2 addr:xxxxx
eth0, eth1
Factory Reset Mode
The Router is in TFTP Server Firmware Recovery mode NOW!
Listening on Port : 69, IP Address: ...
Upgrade Mode   Upgrade Mode

Ps. I edited the wiki a bit to clarify things again.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.