Netgear R7800 only getting about 140Mbps down - why so slow?

I have a ThinkPad laptop with Intel 6300 (3x3) wireless card. The ThinkPad has 3x3 antennas. I am using Wireless N over 5Ghz with 40Mhz channels that are not in use by others. Running LEDE 17.01.1.

I expected to get more than about 140Mbps down. My testing was in the same room as the router. I was hoping to be in the 200Mbps range at least. Was I expecting too much?

I am getting 500Mbps down from my ISP over wired connection.

You could have interference from nearby APs or USB 3.0 devices connected to the router (it bleeds into the 2.4Ghz spectrum).

Also 2.4 Ghz has longer range but much lower speeds, in my case at around 15ft I get no more than 140-160 Mbps with an Intel 6300 3x3 N at 20 MHz width. 40Mhz is unthinkable because it's unethical; causes interference and reduces stability since there are so many APs in my neighborhoodhood. I'm sure speeds would be higher at 40Mhz width but you'd be hogging too much spectrum if your in a suburban area.

Use 5Ghz if you want high speeds, this is true of most routers. I got about 240-250 Mbps at ~12-15ft away and a floor below the router with an Intel 6300 (3x3 N) adapter. This was about the same as stock firmware for me.

Another thing to look out is if you are too close like 3 or so feet then it can cause a drop in speeds. For example in the same laptop after a Intel 7260ac 2x2 adapter upgrade I got about 480 Mbps (~15ft) downlink speeds to my NAS via the router, at 5ft it was around 551 Mbps and at like 3-4 ft it actually went down to like 360-380 Mbps. So make sure you aren't too close.

As my OP states, I am using Wireless N at 5Ghz with 40Mhz channels and I am the only one (based on scanning) using the channels I'm on. My speed tests never get much higher than around 140Mbps maximum whether in the same room as the router or one room away (about 15 feet maybe).

So why are you getting so much more speed?

Sorry my mistake for misreading, have you tried updating to the latest drivers available on Intel's website? Also what are your WiFi settings in the device properties in windows. Lastly do you have an old 5Ghz cordless or a T-Mobile signal booster (uses 5Ghz bachaul which can interfere and won't show on WiFi analyzers). One more thing what are the router's settings i.e. tx power, encryption type. Try forcing AES CCMP for encryption type.

I am using Debian (linux). I have no signal booster but the signal strength according to the OS is very strong. The router power is set to AUTO. I am using WPA2 CCMP AES. (forcing AES).

how did you test the speed/bandwith?

mostly at But also at and

Testing at just now gave me 130Mbps.

Try testing with Windows, in Linux for example I never get more than 6-10 MB/s transfers to my NAS while in Windows the 6300 N gives me close to 28-30MB/s while that could very well be a Samba issue in Ubuntu/Debian/Mint it could also be a driver issue.

I don't believe speedtest websites. there are so many things that can influence the result.

@avx: this thread is not about smb transfers.

I used Samba transfers for WiFi testing so I could test max speeds as my internet connection is ~40Mbps thats why I mentioned it, as we are testing 5Ghz WiFi.

you should install iperf3 on your pc and router.

1 Like

Good point, thanks for the tip.

you should install iperf3 on your pc and router.

Was that for me or avx?

I went ahead an tried it on Windows. It took like an hour for Windows to update itself with just 50 items. It took me about 20 minutes to figure out where the wireless config is. It is a wonder how people live with that OS. But I digress.

I got different results: gave me just 90Mbps with Windows (every time I ran it--about 5 times total). But DSLreports and PCMag both gave me 180Mbps (an improvement over the 140Mbps with linux). but still I am not getting as much as I was expecting. I thought I'd be over 200 range at least

with iperf3 you can test your wifi speed.
on your debian/Linux PC start iperf3 as a server

 iperf3 -s 

and login to your router with ssh and start iperf3 as a client

 iperf3 -c <ip of the pc> 
1 Like
[ ID]    Interval         Transfer      Bandwidth       Retr   Cwnd
[  4]   0.00-1.00   sec   19.7 MBytes   165 Mbits/sec    0   1.02 MBytes       
[  4]   1.00-2.00   sec   19.6 MBytes   165 Mbits/sec    0   1.07 MBytes       
[  4]   2.00-3.00   sec   18.1 MBytes   152 Mbits/sec    0   1.07 MBytes       
[  4]   3.00-4.00   sec   20.3 MBytes   170 Mbits/sec    0   1.13 MBytes       
[  4]   4.00-5.00   sec   19.1 MBytes   160 Mbits/sec    0   1.25 MBytes       
[  4]   5.00-6.00   sec   19.3 MBytes   161 Mbits/sec    0   1.25 MBytes       
[  4]   6.00-7.00   sec   18.7 MBytes   157 Mbits/sec    0   1.25 MBytes       
[  4]   7.00-8.00   sec   17.9 MBytes   150 Mbits/sec    0   1.25 MBytes       
[  4]   8.00-9.00   sec   19.1 MBytes   161 Mbits/sec    0   1.25 MBytes       
[  4]   9.00-10.00  sec   17.4 MBytes   146 Mbits/sec    0   1.25 MBytes       

[ ID]   Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec    189 MBytes   159 Mbits/sec    0     sender
[  4]   0.00-10.00  sec    186 MBytes   156 Mbits/sec          receiver

have you tried wavemon under debian?
so you can see the rx nad tx rate of your wifi adapter

link quality: 93%
signal strength: -45 dBm
tx-power: 15 dBm (31.62 mW)

RX: 13,760,090 (16.10 GiB), invalid: 0 nwid, 0 crypt, 0 frag, 198 misc
TX: 5,902,497 (4.29 GiB), mac retries: 1, missed beacons: 0

iw dev $wlan station dump
for more information

Please check also your antenna orientation.
All vertical like in the ads is wrong

I wouldn't say they are necessarily wrong, if using on one floor it actually works better all vertical. I use it all vertical and still have excellent coverage and performance 2 floors below. It also depends where your router is located when changing antenna placement. Try and see what works best for you I suppose, depending on your home layout and device location.

I played with the antenna angle but doing anything but straight up only reduced the speed from what I'm getting now. If there is a specific pattern that works best, I'll try it.

inactive time:	456 ms
rx bytes:	1084115199
rx packets:	1027226
tx bytes:	15555063
tx packets:	99531
tx retries:	12965
tx failed:	42
signal:  	-43 dBm
signal avg:	-44 dBm
tx bitrate:	135.0 MBit/s MCS 7 40MHz
rx bitrate:	364.5 MBit/s MCS 22 40MHz
authorized:	yes
authenticated:	yes
preamble:	long
WMM/WME:	yes
MFP:		no
TDLS peer:	no