Netgear R7800 LACP Config Verification

Hi, I am just getting started with OpenWRT and am fairly new to networking in general so I wanted to double check my LACP configuration. From my testing redundancy is working, I can unplug each cable and my Netgear GS724TP LAG monitoring shows the LAG stays up as long as one cable is connected. I haven't verified the bandwidth yet.

Note: Since the official Netgear R7800 OpenWRT firmware has swconfig as the default initial config I stuck with that, instead of trying to switch to DSA, so I can learn 1 thing at a time.

Let me know if you see any glaring issues and if you have any tips for verifying the LAG bandwidth.

Here is my config (all generated using LUCI GUI) -

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '192.168.1.1/24'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '6t 4'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '6t 3'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '4'
        option ports '6t 2'

config switch_vlan
        option device 'switch0'
        option vlan '5'
        option ports '6t 1'
        option vid '5'

config device
        option name 'bond0'

config device
        option name 'bonding_masters'

config device
        option name 'eth1'

config device
        option name 'eth1.1'
        option type '8021q'
        option ifname 'eth1'
        option vid '1'

config device
        option name 'eth1.3'
        option type '8021q'
        option ifname 'eth1'
        option vid '3'

config device
        option name 'eth1.4'
        option type '8021q'
        option ifname 'eth1'
        option vid '4'

config device
        option name 'eth1.5'
        option type '8021q'
        option ifname 'eth1'
        option vid '5'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'bonding-LAGTest'
        list ports 'eth1'

config interface 'LAGTest'
        option proto 'bonding'
        option netmask '255.255.255.0'
        option bonding_policy '802.3ad'
        option min_links '0'
        option ad_actor_sys_prio '1'
        option ad_select 'stable'
        option lacp_rate 'fast'
        option xmit_hash_policy 'layer2'
        option all_slaves_active '0'
        option link_monitoring 'mii'
        option miimon '100'
        option downdelay '0'
        option updelay '0'
        option use_carrier '1'
        option auto '0'
        option ipaddr '192.168.2.10'
        list slaves 'eth1.1'
        list slaves 'eth1.3'
        list slaves 'eth1.4'
        list slaves 'eth1.5'

config interface 'LANPORT3'
        option proto 'static'
        option device 'eth1.3'
        list ipaddr '192.168.2.7/24'

config interface 'LANPORT4'
        option proto 'static'
        option device 'eth1.4'
        list ipaddr '192.168.2.8/24'

config interface 'LANPORT1'
        option proto 'static'
        option device 'eth1.1'
        list ipaddr '192.168.2.6/24'

config interface 'LANPORT5'
        option proto 'static'
        option device 'eth1.5'
        option ipaddr '192.168.2.9/24'
        option netmask '255.255.255.0'

I can't say if it is 100% correct or not, as I can see some parts of swconfig and some of DSA. However since you made the configuration only from Luci, it should be fine.
Regarding testing, I suppose you could enable bonding on another device connected on that switch. Otherwise use 4 devices and run iperf to both of them at the same time with multiple connections to make sure that all 4 links are utilized.

Which parts are DSA?

I exposed the switch_vlan ports as interfaces named LANPORT*, but that doesn't mean they are using the DSA config right?
That was the only way I could see to expose the switch_vlan ports to the bonding interface with swconfig.

The config device parts. E.g

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'bonding-LAGTest'
        list ports 'eth1'

And I can see here what seems to be redundant:

This seems like a mix of both but not exactly right.
Anyway, don't mind me, I am not that experienced with DSA, still learning, and I might be missing something.