Netgear R7800 / JTAG

Hello, please help in the topic of instructions for uploading the factory software via the JTAG port to the Netgear R7800 router.

Why would you need jtag serial?

The uboot bootloader contain a recovery tftp tool, which is not overwritten by OpenWrt. You can use it to return to Netgear OEM image. Explained in wiki.


Thanks for the help. It worked with tftp :slight_smile: But I still have a question. The theme of restoring the original software appeared after I uploaded the openwrt software. Then I lose connection with the router. The router reboots over and over again. I downloaded the openwrt software from the link - and uploaded to the router using the tftp client. Please help. I care about installing alternative software. For example, after downloading the dd-wrt software is the same symptom. Am i doing something wrong?

Have you used sysupgrade or factory image?
Assuming you followed the same steps as for return to stock firmware and you've uploaded factory image everything should be fine.
You can try image by @hnyman:
Also loading factory image from Netgear web interface should work.

Thank you again for your help :slight_smile: The situation has not changed, however. This is a new router bought a week ago and maybe the manufacturer has stuck some kind of blockade in the installation of alternative software. I have no more ideas. Maybe you have some way to remove such blockade, if it exists?

I recall someone on the forum described similar issue and that was caused by failed fragment of flash memory. Stock firmware was able to skip failed region but not the OpenWrt. Although there was workaround identified but not the simple one.
If you still have the chance might be good to replace the kit.
Actually I remember having flash related errors myself and I replaced the router without even trying OpenWrt so might be quite common.
Start from checking system log.

I found even two posts that might be interesting:

This is the referenced discussion about it:

You might have a bad flash block on the kernel area, which the OEM flash routine can handle, but OIpenWrt and DD-wrt do not have the proper logic to tackle. In practice, the kernel part of the combined kernel+rootfs image takes one erase block too much space, so that the rootfs gets written to one block too far, which then causes all file system access to fail.

The solution in the discussion referenced above was to use initramfs image to boot OpenWrt and then use OpenWrt sysupgrade to flash an OpenWrt sysupgrade image. (Like I say in the referenced discussion, sysupgrade flashes kernel and rootfs separately, so the rootfs gets into correct place.)

'A small update: The sysupgrade to hnyman's R7800-owrt1907-r10833-91dde4291c-20191229-1243-sysupgrade.bin worked flawlessly. It seems I only had to flash the initramfs image once and can now upgrade via the sysupgrades.'

I think there is a solution. But I can't find the package on the network - R7800-owrt1907-r10833-91dde4291c-20191229-1243-sysupgrade.bin. Do you have something like that somewhere?

Where can i find initramfs image and how to use it to boot OpenWrt ?

Where can i find initramfs image and how to use it to boot OpenWrt ?

Link in thread I referenced above: R7800 -> Flashing openwrt causes bootloop (bad block in kernel area)

leading to advice:

I have never tried that myself...


Thank you very much for your help :slight_smile: I connected the serial cable to the router with the latest original software loaded and on the console (putty) after turning on the router various characters appear, such matrix;). However, I cannot enter the command line mode :frowning: and enter anything, namely the command: tftpboot 50000000 Am I doing something else wrong?

Matrix style of garbled output?

Sounds like you have wrong serial line speed.
115200 N 8 1