Netgear R7800 HW ID (tftp no recovery)

HI Together,
i like openwrt since a few months...
now i will update my network a little bit...
so become an second R7800 but i can not flash by TFTP

i become this massage

The Router is in TFTP Server Firmware Recovery mode NOW!
Listening on Port : 69, IP Address: 192.168.1.1 ...
Upgrade Mode
Rcv:
	.................................................................
	......
	.................................................................
	................
Done!
Bytes transferred = 21043329 (1411881 hex)
MODEL ID on image: R7800
Firmware Image MODEL ID do not match open source firmware ID
Attempt to read outside the flash area
 0 bytes read: ERROR
HW ID on board: ~и_ь~и_–ц_»мы_ь~и_K
HW ID on image: 29764958+0+128+512+4x4+4x4+cascade
Firmware Image HW ID do not match Board HW ID
Board HW ID mismatch,it is forbidden to be written to flash!!

The Router is in TFTP Server Firmware Recovery mode NOW!
Listening on Port : 69, IP Address: 192.168.1.1 ...
Upgrade Mode

i´m not shure what i can do...
can anybody help me?!?

thanks in advance
stixi

Is that a brand new device?
Or a second-hand device that somebody has modified?

HW ID on board: ~и_ь~и_–ц_»мы_ь~и_K
HW ID on image: 29764958+0+128+512+4x4+4x4+cascade

The above snippet makes me to think that somebody has overwritten the art partition (with serials, HW ID and calibration data). The HW ID looks like something in cyrilic letters, but that might just be coincidence.

The first bytes of mtd3 should look like this. First there are MACs, then the serial, and then the HW ID:

00000000  xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx 32 30 33 32 33 37  xxxxxxxxxxxxxxxxx 203237
00000018  33 32 35 48 35 31 35 43 35 54 30 30 34 38 32 00 02 32 39 37 36 34 39 35  325H515C5T00482  2976495
00000030  38 2b 30 2b 31 32 38 2b 35 31 32 2b 34 78 34 2b 34 78 34 2b 63 61 73 63  8+0+128+512+4x4+4x4+casc
00000048  61 64 65 52 37 38 30 30 00 00 00 00 00 00 00 00 00 00 00 4e 45 54 47 45  adeR7800           NETGE
1 Like

Hi hnyman,
is a second-hand device...
but i don´t know what they have done with this device...

do you know a solution to Flash this?!?

thanks a lot

Based on what you've seen already, I'd run for the hills. The previous seems to have messed it up quite seriously, if they also damaged the wireless calibration data, the situation would be fatal.

I would suggest to do a factory reset, then install the newest Netgear OEM firmware (yes, even if that is already installed) and then do a very thorough functionality check of the device (in particular wireless, checking if the MAC addresses for WAN, LAN and both wireless cards are fine and ciorrespond to what's written on the label) - if any of that fails, run, fast, …

2 Likes

Ok...
the router boots every time in rescue mode!
i can install nothing... and become every time the same massage!
so nobody have an solution for my Problem?!?

Has it ever worked for you? Or has it been similar all the time?
What was installed (and running) when you got it?
What have you then done to it?

Like slh already said (and what I suspected based on your first message), it seems that the flash area where crucial devices-specific data ( wifi calibration etc. along the router MACs, serial number, and device type (HW ID)) are stored, has been damaged somehow. Either a bad flash chip, or somebody has tried modifying it and has failed. (Normally OpenWrt or the OEM firmware never write anything to that area, as it should be read-only.)

There are no easy solutions. Pretty much all solutions would include flashing the correct contents from u-boot (once you somehow get the wifi calibration tailored for your device), or removing that flash chip and reprogramming it.

What rescue mode? (I have never seen it)
Does it not allow you to install Netgear OEM firmware?

i become it in this status...

with rescue mode i mean the TFTP mode...
it boots every time in this mode!

how can i flash the u-boot?!?
can i copy the u-boot from an second device?!? <- and how is it going??

i become the same massage if i will install OpenWRT or the Netgear OEM...

so i never was connected to an GUI on this router...

If you can, recover your losses and return the device. It's very likely that the wireless is permanently shot (corrupted calibration data, which is crucial, especially for such a highend device as this).

Is the calibration data unique per a device or can be copied over from another r7800?

It's unique to each and every device (offsetting production variances in the used components, determined at multiple frequencies and temperatures), calibrated in the test run during production.

1 Like

Ok...
thanks a lot... so it is scrap... ;(