Netgear R7800 exploration (IPQ8065, QCA9984)

Settings: Ingress 286720
Test Site:

  • FQ_CODEL + TBF = 61 Mbps
  • FQ_CODEL + Simplest QOS (HTB) = 191 Mbps
  • Cake + Simplest TBF = 60 Mbps
  • Cake + Simplest QOS (HTB) = 201 Mbps
  • Cake + Piece of Cake = 232 Mbps
  • Setting Off = 234Mbps

Result possibly max out, because it is 7:30 AM Fri here.

I have IRQBalance Installed for the above results

During the test for about 18 times, Core 0 load up to 1.6GHz for 9 times, Core 1 at 1.6GHz for 1 times, mostly between 1Ghz to 1.4Ghz

Hope these figure helps

The build is great @hnyman !~ Thanks a lot. Installed almost everything I need and after I add some packages, still have 14MB free. Feel more responsive on my 5G A/N Wlan on this router, than the mlwifi (wrt1900acs)

Edit: Set on Cake + Piece of Cake and run bufferbloat test on Wifi, score A. Better than the previous wrt1900acs's B. Happy

Result should be better, is it wired or wireless? And what's your connection type poe, l2tp or smth?

It is on wire, cable (comcast)
I redo it just now and the result is better with comcast's own speedtest

Settings: Ingress 306176 ( target 260 Mbps, added 15%)
Test Site:

  • FQ_CODEL + TBF = 51 Mbps
  • FQ_CODEL + Simplest QOS (HTB) = 246 Mbps
  • Cake + Simplest TBF = 51 Mbps
  • Cake + Simplest QOS (HTB) = 247 Mbps
  • Cake + Piece of Cake = 250 Mbps
  • Setting Off = 286 Mbps

Settings: Ingress 317952 ( target 270 Mbps, added 15%)
Test Site:

  • FQ_CODEL + TBF = 55 Mbps
  • FQ_CODEL + Simplest QOS (HTB) = 254 Mbps
  • Cake + Simplest TBF = 55 Mbps
  • Cake + Simplest QOS (HTB) = 263 Mbps
  • Cake + Piece of Cake = 272 Mbps
  • Setting Off = 286 Mbps

The 160MHz is never successfully enabled. I assume it is normal, isn't it?

I got Wifi Explorer now, and seems the 6M and 1M are the Min Rate (right click column and select min rate)

About the program, much better than NetSpot

There's new wifi firmware by the way

How is your exprience with it? better than the previous one?

Haven't noticed any changes in my setup.

By the way, has anyone noticed that when setting 5ghz channel to 36-48 there's always an error in syslog stating that ath10k failed to set some parameter for vdev, each time different parameter. Other channels do not produce this error

Search syslog for "vdev" after setting any channel in 36-48 range.

Hi all,

Just wondering has this issue been solved?
On OpenWRT if I reboot sometimes the hardware will not boot up or gets in a boot loop, or worse loads but is broken. The dmesg always shows some sort of kernel memory bug error that always contains do_DataAbort in the stacktrace.

I've been using OpenWRT version for R7800 but I'd like to jump onto the LEDE version. If you have this solved and it's stable I'll migrate my software straight away.


Yep, I've eventually managed to fix it, move on. Lede is very stable on Netgear R7800 right now even in trunk.

Great out of curiosity what was the issue? Finally should I just go to trunk, or is there a git hash you recommend?


LEDE trunk (master) is very stable for R7800. Just use the current HEAD.

1 Like

There's a 2 Mib size memory block in the end of ram region that kernel should not access or at least should not rely on. Seems to be used by bootloader. Pretty darn hard was to figure it out.

1 Like

well done for figuring that out! I'll give LEDE a go tomorrow. Very excited :smiley:

If you want an easy quick test with R7800, try my community build for R7800. It is tailored for R7800 and contains e.g. the CPU frequency and CPU temperature stats etc.

1 Like

Thanks for the offer but I need to run my own firmware on there.

So it seems LEDE has fixed that bug where it wouldn't boot up sometimes. Seems pretty stable, got a bunch of clients connected with no problems.

However there is still a very strange issue I see occasionally that also existed with OpenWRT. Sometimes files get corrupt, usually if you edit them then reboot.

For example I edited a /etc/init.d/ file then rebooted the router via reboot command.

When it booted my changes to the file had gone and the file had no permissions. If I did "ls -l" the permissions were listed as:
----------- 1 root root 977 Feb 15 11:19 xyz

The update time was correct. Is there something wrong with the overlayfs or perhaps the UBI? Has anyone else experienced this as well?

Sounds strange. I have not noticed similar behaviour. I am frequently testing this and that, and have rebooted right after editing text files.

You might consider issuing "sync" before rebooting.

I have never faced such issue myself, but I have a suspicion (that might be not be related to this issue though) that current nand driver is a bit faulty. And that may be the reason of those block-mount errors in syslog.
The driver that's currently in lede is a pre-upstream version. The upstream version has only made its way in k4.8 or 4.9.
I've tried to port it but failed in doing so because I do not have a serial to check the errors during boot failure.

Transition to 4.9 is probably just behind the corner. Some target platforms have already moved there. Have you tried anything to that direction?

Looks like there is quite much backported stuff in ipq806x to be removed. Lots of work :frowning:

Hello all,
Firstable I want to thank all of you for your great job on this project and specifically with R7800.
I have a question, in the official page of the R7800 says:
5GHz wifi, ADSL, FXS are unsupported features, Is it still true with RC2 version?

Thank you again

Sounds like you are mixing R7800 with D7800 or some other device?.
R7800 has no ADSL. And 5 GHz wifi works ok.

D7800 is discussed in several other threads.