Netgear R7800 exploration (IPQ8065, QCA9984)

Well, WiFi interfaces just went into disabled state now, I had to restart them, the router didn't reboot tho'.

[2069691.801451] device wlan0 left promiscuous mode
[2069691.801588] br-lan: port 3(wlan0) entered disabled state
[2069691.890988] ath10k_pci 0000:01:00.0: could not get mac80211 beacon
[2069692.095787] ath10k_pci 0000:01:00.0: could not get mac80211 beacon
[2069692.300577] ath10k_pci 0000:01:00.0: could not get mac80211 beacon
[2069692.505379] ath10k_pci 0000:01:00.0: could not get mac80211 beacon
[2069692.519704] ath10k_pci 0000:01:00.0: peer-unmap-event: unknown peer id 1
[2069692.519778] ath10k_pci 0000:01:00.0: peer-unmap-event: unknown peer id 1
[2069692.525600] ath10k_pci 0000:01:00.0: peer-unmap-event: unknown peer id 1
[2069692.616753] device wlan1 left promiscuous mode
[2069692.616916] br-lan: port 2(wlan1) entered disabled state
[2069692.770377] ath10k_pci 0001:01:00.0: could not get mac80211 beacon
[2069692.808612] ath10k_pci 0001:01:00.0: peer-unmap-event: unknown peer id 1
[2069692.808724] ath10k_pci 0001:01:00.0: peer-unmap-event: unknown peer id 1

DFS shouldn't cause wifi to be disabled right? It's weird that both interfaces went down.

It will, if I'm not wrong, if you set the interface to a DFS channel and radar was detected for that channel. Was the channel set to a fixed channel or was it auto?

Fixed... But still weird that 2.4Ghz went down.
I'll change 5Ghz back to non-DFS.

1 Like

How do I get 160 mhz working for my 5.0 ghz wifi? I'm running latest stable hnyman's build

For me VHT160 works quite normally, with FI country code, both channel 36 and 100 work for me. DFS detection takes a minute at startup, but completes nicely.

1 Like

New openwrt user here (but experienced software dev) on an XR500 (same hardware as the R7800) and I had this same __krait_mux_set_sel crash twice in the last 24 hours. I'm running the latest snapshot from 2022-03-24.

When it crashed last night, it happened shortly after a decent amount of load followed by a very low amount of load. So if the CPU core frequency ramped downward, perhaps that's what triggered the crash.

I had not set up any min frequency parameters in the local startup script, but it seems like that might be the best workaround at this point from what others have said?

Let me know if there's any way I can help track down the issue.

1 Like

That should be safe and easy to try. Keep an eye on what @ansuel is saying about cpu idle and if your a little more brave, you could try:

1 Like

Didn't know about wifi county code. Thank you

US on channel 36 works great for me!

1 Like

I had the same problem when connecting R6020 (100Mbps) and R7800 (1Gbps) using ethernet. I ended up using the R7800 as dumb AP and an awesome E8450 as the head router. It is time to jump into wifi 6. It works.

1 Like

I add more data about issues with 100Mbps devices.

@Ansuel @quarky
I've tested extensively the latest stock Netgear firmware and latest Voxel firmware for R7800.
I've found that both have almost the same issue as OpenWRT.
There are a few differences. The stock firmware is more resilient and when the LAN traffic is present the full WAN download speed is still achievable even though with higher ping times. But when the WAN speed is at full there are drops in LAN transfer speed.
The upload WAN speed is limited as with OpenWRT firmware.
Original Netgear firmware experiences issues with WAN download speeds too but this happens when there are two different 100Mbps devices connected to the LAN ports and there is a LAN transfer involving one desktop PC (1Gbps) sending files over LAN (or running iperf3 server) to both 100Mbps clients. Using this scenario the R7800 has problems to achieve full WAN down/up speeds.
If the clients are connected at 1Gbps full WAN/LAN speeds at low pings are possible.

1 Like

Interesting. My R7800 is now serving as my main home router. It has a smart TV connected to the R7800 LAN port and it maxed out at 100mbps and switched to 10mbps when on stand-by mode. I do not see the limit to upload/download speed tho., but maybe it's because the TV is not actively using the network. The ar8337 switch should not have this limitation as far as I can tell tho.

Maybe I should stream a YouTube video on the TV and try a speed test.

I have this WAN speeds limitation only during active LAN transfer/s between a PC and another 100Mbps LAN client/s. You need simultaneous WAN and LAN transfers. I use iperf3 to better shape the scenario.
Otherwise this doesn't occur.
For me this is unacceptable because when anyone is watching on a TV set (100Mbps) movie streamed over a LAN (PC at 1Gbps as a server - TV set as a client) the PC (1Gbps) can download/ipload from/to WAN at very low speeds. And all other 100 Mbps devices involved in LAN transfers cannot download either.
A separate Laptop connected at another port at 1Gbps can download at full speed from WAN as long as it doesn't take part in simultaneous LAN traffic with another 100Mbps device.
Obviously a complicated but real life scenario.

Ok, so what you're explaining is that the 100mbps client has to transfer data from a LAN client, instead of from WAN? If that's the case, my test case of watching a YouTube video and speed test probably will not trigger this scenario. Let me see if I can stream from a LAN client to the TV and do a speed test at the same time.

1 Like

Yep, WAN only transfers will not trigger this bug.
I simulate with Laptop, iperf3 and 100Mbps (4 wires) cable.
I think that ~60Mbps LAN traffic is enough to trigger this but the higher the LAN transfer the lower the WAN speed.
And with the Netgear firmware I need two separate LAN (100Mbps) clients transferring at 100Mbps to hinder the WAN speed.
I repeat the same tests using the same scenario and network setup but with cheap 1Gbps router and this doesn't happen.

The issue affects WAN and LAN ports. It is clearly a physical layer driver issue.

Have you tested the throughput? The device will report connecting at 100Mbps, but you will never be able to reach 90 Mbps of the effective transmission rate. In my case, testing with iperf3, I was getting 60-70Mbps.

1 Like

Ok. So I did a quick test. I forced my Dell notebook to 100mbps full duplex and connected it to my R7800, which is serving as my main Internet router. In my Dell notebook I run the iPerf3 server. I run another iPerf3 client that’s connected to another LAN port at 1000mbps. I tried up and down iPerf3 runs, and I get around 95mbps for the iPerf3 runs.

While the iPerf3 session is running (I’ve run it for 5mins) I tried Speedtest with my iPad connected to the R7800. The iPad is able to get 4-500 mbps. Speedtest is done for both up and down iPerf3 runs.

Is this a valid test scenario that you guys are seeing where the thruput is limited to 100mbps?

I guess if you use switch between the router and the client, the problem goes away?


TBH I'm a little bit confused by this.

I do see the "pstore console logging" option in kermel_menuconfig and it is not selected even tho the ramoops commit is enabled and functional (I tested as recommend here).

My understanding from the discussion above is that @shelterx found not all crashes are logged to pstore unless this option is selected in addition to the ramoops config.

For the two crashes I've caused (not intentionally - just "normal" playing around), I've seen both in pstore without having this option selected.

Hmm, I enabled the ramoops crash logging by default for R7800, and that should work (lie your experience indicates), but I am not sure if there is a separate kernel option to turn on some kind of continuous console logging into pstore. Sounds like that. I haven't looked into that.

Looks like there is:

1 Like