Netgear R7800 exploration (IPQ8065, QCA9984)

I understand, but in my case I restarted wifi several times and it was very consistent. It is possible that it is because of the auto channel that I am using. I will try fixed channels next time.

I've been trying channel 'auto' on a map-ac2200/ ipq4019 (qca4019[10.4-3.6-00140] + qca4019[10.4-3.6-00140] + qca9888[10.4-3.10-00076]) for about the same time now (my nbg6817 sticks to hardcoded channels, but the map-ac2200 is used in a semi-mobile fashion, so trying out auto makes sense there), without any issues.

are you sure it's not due to this bug?

Did anyone file this as a bug in flyspray or on GitHub? Can’t seem to find it marked as an issue, and without that it will never be worked on I assume.

It could be. Thx for sharing that link, I missed those posts.

Yesterday I updated my R7800 to master and wifi is now working almost fine. If I change some wifi settings I then see some misbehaviour like device not coming up properly or one wifi device coming up and the other down. In that case I have to use the "wifi" command to reset all wifi devices (5GHz and 2GHz) and then both would come up ok. I also noticed these log messages which I think were not there before:

daemon.err hostapd: nl80211: kernel reports: key addition failed

From where? Many of us are constantly using master, so it hard to understand if you change is against master of last week/last month, or 19.07.x or 18.06.x...

Updated from master from a couple of weeks before.

Then it is about both the hostapd version bump, wifi driver major version bump (to kernel 5.7-rc3) and e.g. the script changes referenced above by facboy.

I'm using the imagebuilder.
Between upgrading to 19.07.3 from .2, switching back to -ct (actually the smallbuffers version, had to use non-ct a while since that at least didnt hardlock), getting rid of some uneeded packages, changing channels, and probably other small trivial settings/things, I now feel that my R7800 is ROCK SOLID, the same way my R7000 was with Xvortex. I don't know what exactly did it, but finally!

I was just recently given a free R7800 since my friend upgraded, so now I have both my R7800 in a 802.11s/BATMAN-adv mesh (backhaul and AP both on 5G),and 802.11r quick handoff. It just works! :smiling_face_with_three_hearts:

(Compared to just wirelessly bridging with relayd, the wireless took a little hit on the speed because of the overhead and the fact that the backhaul is on the same radio as AP. About 50/51MBs compared to about 68MBs with relayd (between hardwired NAS at one end to my wired PC on the other end, through the wireless backhaul). Incidentially the original firmware had speeds up to 75MB/s but they were fluctuating like crazy, so avg speed was probably in the 68-70MBs range, and also the connection was super unstable and actually required a manual reboot all the time, and even then it might not reconnect at first..phew. I was just gonna use the second R7800 as a wireless bridge, but ended up with Openwrt on this too since the Netgear firmware was just too bad.)

I'm writing up a bug report right now. I'm running v19.07.3 on a Linksys WRT1900ACSv2 that I compiled myself and rebooting the WiFi breaks one of the radios.

**UPDATE
Created bug report here > https://bugs.openwrt.org/index.php?do=details&task_id=3138&order=dateopened&sort=desc

1 Like

Is it possible to flash e.g. 19.07.3 straight from the factory image, or TFTP flashing necessary?
The device page mentions needing to use TFTP to switch between these 2 groups:

  1. kernel 4.4 or 4.9: 17.01, old master builds (<r7000), plus the quite earliest 18.06 builds

  2. kernel 4.14: new master builds (>r7000), new 18.06 builds (rc2 and final 18.06.0)

But in effect I'm looking to flash to the 2nd group directly from the factory image. Is that possible?

Possible from factory image

1 Like

And it seems the fix is in master already. Will try a new build tomorrow, and see if it has resolved it.

One of my radios still does not come up even with the latest fix. Tried both auto and fixed channels.

Might be a DFS channel that needs 60 seconds to activate the 5ghz radio?!

I waited long enough. Did you have any success?

I'm running snapshot r13406, the issue with the radios has been fixed for me, both radios are working normally now.

For me the Issues are solved with a new build of the master tree. Both on my R7800 as well as on my WRT1900AC-V2

any one else still experiences crashes on the backported mac stuff?
i'm running a master build of about 3 days old and getting some occasional crashes:

[86244.685177] ------------[ cut here ]------------
[86244.685356] WARNING: CPU: 0 PID: 9 at backports-5.7-rc3-1/net/mac80211/sta_info.c:1929 ieee80211_sta_update_pending_airtime+0x1f8/0x1fc [mac80211]
[86244.688989] STA f4:06:16:de:20:d8 AC 2 txq pending airtime underflow: 4294966916, 380
[86244.688994] Modules linked in: xt_connlimit pppoe ppp_async nf_conncount iptable_nat ath10k_pci ath10k_core ath xt_state xt_nat xt_helper xt_conntrack xt_connmark xt_connbytes xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table_hw nf_flow_table nf_conntrack_rtcache nf_conntrack mac80211 ipt_REJECT ftdi_sio cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_recent xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY usbserial slhc sch_cake nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables crc_ccitt compat sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred ledtrig_usbport ledtrig_heartbeat nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 ifb tun uas usb_storage leds_gpio xhci_plat_hcd
[86244.702217]  xhci_pci xhci_hcd dwc3 dwc3_qcom ohci_platform ohci_hcd phy_qcom_dwc3 ahci fsl_mph_dr_of ehci_platform ehci_fsl sd_mod ahci_platform libahci_platform libahci libata scsi_mod ehci_hcd gpio_button_hotplug ext4 mbcache jbd2 exfat(C) crc32c_generic
[86244.797884] CPU: 0 PID: 9 Comm: ksoftirqd/0 Tainted: G         C        5.4.42 #0
[86244.820030] Hardware name: Generic DT based system
[86244.827515] [<c030f954>] (unwind_backtrace) from [<c030b96c>] (show_stack+0x14/0x20)
[86244.832203] [<c030b96c>] (show_stack) from [<c08acfe0>] (dump_stack+0x94/0xa8)
[86244.840104] [<c08acfe0>] (dump_stack) from [<c031e7c0>] (__warn+0xb4/0xd0)
[86244.847125] [<c031e7c0>] (__warn) from [<c031e85c>] (warn_slowpath_fmt+0x80/0x90)
[86244.854061] [<c031e85c>] (warn_slowpath_fmt) from [<bf3f2af0>] (ieee80211_sta_update_pending_airtime+0x1f8/0x1fc [mac80211])
[86244.861729] [<bf3f2af0>] (ieee80211_sta_update_pending_airtime [mac80211]) from [<bf3ed13c>] (ieee80211_report_low_ack+0x254/0x50c [mac80211])
[86244.872978] [<bf3ed13c>] (ieee80211_report_low_ack [mac80211]) from [<bf3ed408>] (ieee80211_free_txskb+0x14/0x2c [mac80211])
[86244.885562] [<bf3ed408>] (ieee80211_free_txskb [mac80211]) from [<bf52488c>] (ath10k_txrx_tx_unref+0x608/0x738 [ath10k_core])
[86244.896896] [<bf52488c>] (ath10k_txrx_tx_unref [ath10k_core]) from [<bf51e840>] (ath10k_htt_t2h_msg_handler+0xe6c/0x1288 [ath10k_core])
[86244.908036] [<bf51e840>] (ath10k_htt_t2h_msg_handler [ath10k_core]) from [<bf3c8768>] (ath10k_pci_htt_rx_cb+0x178/0x230 [ath10k_pci])
[86244.920036] [<bf3c8768>] (ath10k_pci_htt_rx_cb [ath10k_pci]) from [<bf53e290>] (ath10k_ce_per_engine_service+0x9c/0x10c [ath10k_core])
[86244.932201] [<bf53e290>] (ath10k_ce_per_engine_service [ath10k_core]) from [<bf53e380>] (ath10k_ce_per_engine_service_any+0x80/0xd8 [ath10k_core])
[86244.944142] [<bf53e380>] (ath10k_ce_per_engine_service_any [ath10k_core]) from [<bf3ca104>] (ath10k_pci_napi_poll+0x54/0x15c [ath10k_pci])
[86244.957215] [<bf3ca104>] (ath10k_pci_napi_poll [ath10k_pci]) from [<c0767424>] (net_rx_action+0x118/0x374)
[86244.969613] [<c0767424>] (net_rx_action) from [<c0302298>] (__do_softirq+0x130/0x2d4)
[86244.979242] [<c0302298>] (__do_softirq) from [<c03228ec>] (run_ksoftirqd+0x38/0x4c)
[86244.987142] [<c03228ec>] (run_ksoftirqd) from [<c0341638>] (smpboot_thread_fn+0xfc/0x1c8)
[86244.994610] [<c0341638>] (smpboot_thread_fn) from [<c033e144>] (kthread+0x160/0x164)
[86245.002939] [<c033e144>] (kthread) from [<c03010e8>] (ret_from_fork+0x14/0x2c)
[86245.010744] Exception stack(0xdd461fb0 to 0xdd461ff8)
[86245.017781] 1fa0:                                     00000000 00000000 00000000 00000000
[86245.022917] 1fc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[86245.031069] 1fe0: 00000000 00000000 00000000 00000000 00000013 00000000
[86245.039286] ---[ end trace 41c60d134a0d9c66 ]---