Netgear R7800 cannot upgrade packages (only 0kB available)

solving one problem and a next one appears. Today, I wanted to update the openwrt files and there were lots of updates (21) When clicking one to start, it returned an error "Only have 0kb available on filesystem /overlay"
When I SSH'd into the router and did an root@netgear:/df -h it returned:
Filesystem Size Used Available Use% Mounted on
/dev/root 3.0M 3.0M 0 100% /rom
tmpfs 233.6M 1.3M 232.3M 1% /tmp
/dev/ubi0_1 79.1M 79.1M 0 100% /overlay
overlayfs:/overlay 79.1M 79.1M 0 100% /
tmpfs 512.0K 0 512.0K 0% /dev

Is there something I can do to solve it?

Thank you.

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

One of the problems is that opkg upgrade doesn't delete the old version of a package which belongs to the rom. So you occupy double space.
Apart from that it seems that you have installed too many packages and filled up the overlay, or you have other files which occupy space. You can delete some that you don't need.
du -h / | sort -n can help with that.


Please forgive me but "upgrading software is highly discouraged" for a device which is 24/7 connected to the internet?

This is the first time in all of my ICT years someone said this to me.

I guess I misunderstood you.


Did you read inside the link?

In the vast majority of cases, any security patches of significant importance/risk will be rapidly released in an official stable maintenance release to be upgraded using the sysupgrade system. This is the recommended method for keeping up-to-date.

1 Like

Read carefully:

Nobody is telling you that you shouldn't keep your OpenWrt installation updated. You should just not upgrade packages blindly, especially not via script.

"Upgrading" packages via flashing a new image with the respective packages already included is the way to go. This will not waste your precious flash with unused old packages.


You have filled the overlay, and pretty much the only reliable eway to recover from that is to reset the router with "firstboot" so that your installed packages & settings get cleared.

You may try deleting some large files from /overlay/upper (where all overlay files are), and reboot, but that is risky if you delete wrong files.

Hello all,

As a Linux user I thought I could empty /tmp. So I did. Well, I had to flash the router again. :slight_smile:
Now I begin from scratch again. It doesn't matter, I'm learning from it.

As I understand, it is NOT advisable to update seperate packages but only complete builds?

grtzz tom

It is not advisable too mass-update separate packages.

Compatibility is not guaranteed, and the flash space issues may hit you.

There is limited flash space. The ROM+overlay fs structure enables the reset functionality, but on the other hand nothing in the original firmware actually gets deleted (as it just gets a delete mark).

You can selectively upgrade individual (user-space) packages, if you have a real reason to upgrade and you know that there is enough free flash space.

This is not a usual PC with unlimited disk space, but router with a few MB of flash.


ok, thank you

I resetted the router, factory defaults and installed again AdGuardHome, DDNS. Just following a manual on this forum. No destination is asked.
Now I have :

Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.0M      3.0M         0 100% /rom
tmpfs                   233.6M      1.3M    232.3M   1% /tmp
/dev/ubi0_1              79.1M     34.4M     40.6M  46% /overlay
overlayfs:/overlay       79.1M     34.4M     40.6M  46% /
tmpfs                   512.0K         0    512.0K   0% /dev

Am I doing something wrong while installing?

Nothing wrong.
You have now roughly half of the flash space in overlay available. (46% used)

1 Like

Yes, but I need to install WireGuard too.
The last time I did, the overlayFS was 100% full.

wireguard weighs around 100 KB in total, while you have over 40 MB free space.



My prior installation had also only ADG, DDNS and wireguard but took all of /overlay.

Is it not possible to increase the size of /overlay ?

I see, tmpfs is only using 1% of 233MB so it would be nice to add for example 100MB to /overlay.

grt tom

/tmp is ramdisk, which currently consumes 1% of your RAM.
It is not permanent flash memory.

1 Like
1 Like

Now this looks more like it should be :slight_smile:

Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.0M      3.0M         0 100% /rom
tmpfs                   233.6M    268.0K    233.3M   0% /tmp
/dev/sda1                14.4G     47.9M     13.6G   0% /overlay
overlayfs:/overlay       14.4G     47.9M     13.6G   0% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/ubi0_1              79.1M      4.6M     70.4M   6% /rwm

thx to vgaetera

Grt tom

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.