Netgear R6230 Factory Firmware Restore

Hi. I have a Netgear R6230 that I installed OpenWrt on. I don't like it. I guess it's above my paygrade. I want to restore my router to factory firmware. I've read about TFTP (this router has only one color LED) and I can't get it to work. I've also tried nmrpflash and it tells me it is ignoring additional upload. The router is running OpenWrt so it's not bricked. I just need a comprehensive guide to get it back on the Netgear firmware. Thank you in advance for your help.

If you want to be nit-picky, nmrpflash doesn't say anything about 6230 support.

Did you follow this, when trying to recover using TFTP ?

Another post on here recommended nmprflash. Even the author said it likely worked with other models. It did actually connect unlike TFTP. I tried changing the version number of the firmware as suggested, and even blind mode which claimed it work, but it did not.

As for TFTP I explained that I tried that. My router doesn't have multi-color LEDS, there is no white, no amber, only green. It did flash the internet light and wireless light which may have been TFTP mode, but regardless I was unable to upload the original firmware. It would time out the connection or make no movements on the upload status depending on whether I used the Mac command line or the Windows application. Either way I have no way to tell if this specific model is even getting into TFTP mode.

I'm not a noob, I was Director of IT at a small school. I was able to work a SonicWall (not my favorite), and I know a good deal of stuff. I was hoping for DDWRT, but my router is not supported. None of this seems to specifically apply to an R6230, I know the R6220 similar, but again the instructions are non model specific and I can't seem to make them work.

yes it's the same PCB & firmware use I the R6220
& yes nmrpflash is what you use
tftp didn't work for me ether
set & run nmrpflash then turn unit on
while it's boot it will connect download & tell you when to reboot
i got away with the help in nmrpflash can't remember the command line now tho

It did connect, but it kept saying "Ignoring Additional Upload after it saw the firmware. It never uploaded it. I could only get it to work on Windows, I couldn't get the command to work on my Mac. Either way as I said it would connect to the router, but then spit out errors and never upload the firmware.

I did work for me on windows 10 LTSC 1908
you may have to disable you firewall


Lucky1, you sir are a genius! I didn't even think of that. It's a Netgear again. Thank you!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.