Netgear R6220 - not able to update Software package list // ping adresses from router

Hello,

I am running OpenWRT on my Netgear R6220 with the following firmware version: OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-20.247.75781-0d0ab01.
After installation, I tried to update the software packages to install WPA3 encryption. But when I go to System -> Software -> "update lists", I get the following error:

Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Failed to send request: Operation not permitted
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/kmods/4.14.195-1-2e88863ccdd594fb8e842df3c25842ee/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.4/packages/mipsel_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.4/packages/mipsel_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.4/packages/mipsel_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.4/packages/mipsel_24kc/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.4/packages/mipsel_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

The opkg update command failed with code 7.

Also, maybe that is the same problem: When I go to Network -> Diagnostics and try to ping, i receive:

bad address 'openwrt.org'

Thank you for any assistance.

Cheers,
Lasko

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
2 Likes

Here is the output:

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'xxx'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'pppoe'
	option password 'xxx'
	option ipv6 'auto'
	option username 'xxx'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'xxx'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '6t'
	option vid '60'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '2 6t'
	option vid '10'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option ports '1 6t'
	option vid '20'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option ports '0 6t'
	option vid '30'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '6t'
	option vid '40'

config switch_vlan
	option device 'switch0'
	option vlan '8'
	option ports '6t'
	option vid '50'

config interface 'Lan3'
	option proto 'static'
	option ifname 'eth0.20'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.3.1/24'

config interface 'LAN2'
	option proto 'static'
	option ifname 'eth0.10'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.2.1/24'

config interface 'WIFITrusted2'
	option proto 'static'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.5.1/24'
	option ifname 'eth0.40'

config interface 'WIFIBUSINESS'
	option proto 'static'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.6.1/24'
	option ifname 'eth0.50'

config interface 'WIFIGUESTS'
	option proto 'static'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.7.1/24'
	option ifname 'eth0.60'

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option limit '2'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'WIFI_T1'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'WIFI_T1'
	option ra 'server'
	option dhcpv6 'server'
	option ra_management '1'

config dhcp 'LAN2'
	option start '100'
	option leasetime '12h'
	option interface 'LAN2'
	option ra 'server'
	option dhcpv6 'server'
	option ra_management '1'
	option limit '2'

config dhcp 'Lan3'
	option start '100'
	option leasetime '12h'
	option interface 'Lan3'
	option dhcpv6 'server'
	option ra 'server'
	option limit '2'
	option ra_management '1'

config dhcp 'LAN2'
	option start '100'
	option leasetime '12h'
	option interface 'LAN2'
	option dhcpv6 'server'
	option ra 'server'
	option limit '2'
	option ra_management '1'

config dhcp 'WIFITrusted2'
	option start '100'
	option leasetime '12h'
	option interface 'WIFITrusted2'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option limit '100'

config dhcp 'WIFIBUSINESS'
	option start '100'
	option leasetime '12h'
	option interface 'WIFIBUSINESS'
	option dhcpv6 'server'
	option ra 'server'
	option limit '1'
	option ra_management '1'

config dhcp 'WIFIGUESTS'
	option start '100'
	option leasetime '12h'
	option interface 'WIFIGUESTS'
	option dhcpv6 'server'
	option ra 'server'
	option limit '10'
	option ra_management '1'

package firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option network 'lan'
	option forward 'REJECT'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'xxx'
	option dest_ip 'xxx'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'xx'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone
	option network 'Lan3'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'xbox'
	option output 'ACCEPT'

config zone
	option network 'LAN2'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'amazontv'
	option output 'ACCEPT'

config zone
	option network 'WIFITrusted2'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option name 'WIFIT2'

config forwarding
	option dest 'wan'
	option src 'xbox'

config forwarding
	option dest 'wan'
	option src 'amazontv'

config forwarding
	option dest 'wan'
	option src 'WIFIT2'

config zone
	option network 'WIFIBUSINESS'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'WIFIBUS'
	option output 'ACCEPT'

config zone
	option network 'WIFIGUESTS'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'WIFIGUEST'
	option output 'ACCEPT'

config forwarding
	option dest 'wan'
	option src 'WIFIBUS'

config forwarding
	option dest 'wan'
	option src 'WIFIGUEST'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
5: br-LAN2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-LAN2AmazonTV
       valid_lft forever preferred_lft forever
7: br-Lan3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.3.1/24 brd 192.168.3.255 scope global br-Lan3Xbox
       valid_lft forever preferred_lft forever
9: br-WIFIBUSINESS: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.6.1/24 brd 192.168.6.255 scope global br-WIFIBUSINESS
       valid_lft forever preferred_lft forever
11: br-WIFIGUESTS: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.7.1/24 brd 192.168.7.255 scope global br-WIFIGUESTS
       valid_lft forever preferred_lft forever
13: br-WIFITrusted2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.5.1/24 brd 192.168.5.255 scope global br-WIFITrusted2
       valid_lft forever preferred_lft forever
15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
69: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN qlen 3
    inet xxx peer xxx scope global pppoe-wan
       valid_lft forever preferred_lft forever
default via xx dev pppoe-wan 
xxx dev pppoe-wan scope link  src xxx 
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1 
192.168.2.0/24 dev br-LAN2 scope link  src 192.168.2.1 
192.168.3.0/24 dev br-Lan3 scope link  src 192.168.3.1 
192.168.5.0/24 dev br-WIFITrusted2 scope link  src 192.168.5.1 
192.168.6.0/24 dev br-WIFIBUSINESS scope link  src 192.168.6.1 
192.168.7.0/24 dev br-WIFIGUESTS scope link  src 192.168.7.1 
local xxx dev pppoe-wan table local scope host  src 91.14.248.41 
broadcast 192.168.1.0 dev br-lan table local scope link  src 192.168.1.1 
local 192.168.1.1 dev br-lan table local scope host  src 192.168.1.1 
broadcast 192.168.1.255 dev br-lan table local scope link  src 192.168.1.1 
broadcast 192.168.2.0 dev br-LAN2AmazonTV table local scope link  src 192.168.2.1 
local 192.168.2.1 dev br-LAN2AmazonTV table local scope host  src 192.168.2.1 
broadcast 192.168.2.255 dev br-LAN2AmazonTV table local scope link  src 192.168.2.1 
broadcast 192.168.3.0 dev br-Lan3Xbox table local scope link  src 192.168.3.1 
local 192.168.3.1 dev br-Lan3Xbox table local scope host  src 192.168.3.1 
broadcast 192.168.3.255 dev br-Lan3Xbox table local scope link  src 192.168.3.1 
broadcast 192.168.5.0 dev br-WIFITrusted2 table local scope link  src 192.168.5.1 
local 192.168.5.1 dev br-WIFITrusted2 table local scope host  src 192.168.5.1 
broadcast 192.168.5.255 dev br-WIFITrusted2 table local scope link  src 192.168.5.1 
broadcast 192.168.6.0 dev br-WIFIBUSINESS table local scope link  src 192.168.6.1 
local 192.168.6.1 dev br-WIFIBUSINESS table local scope host  src 192.168.6.1 
broadcast 192.168.6.255 dev br-WIFIBUSINESS table local scope link  src 192.168.6.1 
broadcast 192.168.7.0 dev br-WIFIGUESTS table local scope link  src 192.168.7.1 
local 192.168.7.1 dev br-WIFIGUESTS table local scope host  src 192.168.7.1 
broadcast 192.168.7.255 dev br-WIFIGUESTS table local scope link  src 192.168.7.1 
0:	from all lookup local 
32766:	from all lookup main 
32767:	from all lookup default 
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 xxx scope link 
       valid_lft forever preferred_lft forever
5: br-LAN2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xxx scope global dynamic 
       valid_lft 14016sec preferred_lft 1416sec
    inet6 xxx scope link 
       valid_lft forever preferred_lft forever
7: br-Lan3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xx scope global dynamic 
       valid_lft 14016sec preferred_lft 1416sec
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
9: br-WIFIBUSINESS: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xxx scope global dynamic 
       valid_lft 14016sec preferred_lft 1416sec
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
11: br-WIFIGUESTS: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xxx scope global dynamic 
       valid_lft 14016sec preferred_lft 1416sec
    inet6 xxx scope link 
       valid_lft forever preferred_lft forever
13: br-WIFITrusted2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xxx scope global dynamic 
       valid_lft 14016sec preferred_lft 1416sec
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xx scope global dynamic 
       valid_lft 14016sec preferred_lft 1416sec
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
17: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
35: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
36: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
39: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
40: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
69: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 xx scope global dynamic 
       valid_lft 14190sec preferred_lft 1590sec
    inet6 xx scope link 
       valid_lft forever preferred_lft forever
default from xx via xx dev pppoe-wan  metric 512 
default from xx via xx dev pppoe-wan  metric 512 
xx dev br-LAN2  metric 1024 
xx dev br-Lan3  metric 1024 
xx dev br-WIFIBUSINESS  metric 1024 
xx dev br-WIFIGUESTS  metric 1024 
xx dev br-WIFITrusted2  metric 1024 
xx dev br-lan  metric 1024 
unreachable xx dev lo  metric 2147483647  error -148
xx dev pppoe-wan  metric 256 
xx dev eth0  metric 256 
xx dev br-Lan3  metric 256 
xx dev br-WIFIBUSINESS  metric 256 
xx dev br-WIFIGUESTS  metric 256 
xx dev br-WIFITrusted2  metric 256 
xx dev br-lan  metric 256 
xx dev eth0.2  metric 256 
xx dev br-LAN2  metric 256 
xx dev wlan1  metric 256 
xx dev wlan1-1  metric 256 
xx dev wlan0  metric 256 
xx dev wlan0-1  metric 256 
xx dev pppoe-wan  metric 1 
xx dev pppoe-wan  metric 256 
anycast xx dev br-LAN2 table local  metric 0 
local xx dev br-LAN2 table local  metric 0 
anycast xx dev br-Lan3 table local  metric 0 
local xx dev br-Lan3 table local  metric 0 
anycast xx dev br-WIFIBUSINESS table local  metric 0 
local xx dev br-WIFIBUSINESS table local  metric 0 
anycast xx dev br-WIFIGUESTS table local  metric 0 
local xx dev br-WIFIGUESTS table local  metric 0 
anycast xx dev br-WIFITrusted2 table local  metric 0 
local xx dev br-WIFITrusted2 table local  metric 0 
anycast xx dev br-lan table local  metric 0 
local xx dev br-lan table local  metric 0 
anycast xx dev pppoe-wan table local  metric 0 
local xx dev pppoe-wan table local  metric 0 
anycast xx dev eth0 table local  metric 0 
anycast xx dev br-Lan3 table local  metric 0 
anycast xx dev br-WIFIBUSINESS table local  metric 0 
anycast xx dev eth0.2 table local  metric 0 
anycast xx: dev br-lan table local  metric 0 
anycast xx dev br-WIFITrusted2 table local  metric 0 
anycast xx dev br-WIFIGUESTS table local  metric 0 
anycast xx dev br-LAN2 table local  metric 0 
anycast xx dev wlan1 table local  metric 0 
anycast xx dev wlan1-1 table local  metric 0 
anycast xx dev wlan0 table local  metric 0 
anycast xx dev wlan0-1 table local  metric 0 
anycast xx dev pppoe-wan table local  metric 0 
local xx dev wlan0-1 table local  metric 0 
local xx dev wlan1-1 table local  metric 0 
local xx dev eth0 table local  metric 0 
local xx dev br-Lan3 table local  metric 0 
local xx dev br-WIFIBUSINESS table local  metric 0 
local xx dev br-lan table local  metric 0 
local xx dev br-WIFITrusted2 table local  metric 0 
local xx dev br-WIFIGUESTS table local  metric 0 
local xx dev br-LAN2 table local  metric 0 
local xx dev wlan0 table local  metric 0 
local xx dev eth0.2 table local  metric 0 
local xx dev wlan1 table local  metric 0 
local xx dev pppoe-wan table local  metric 0 
xx dev eth0 table local  metric 256 
xx dev br-Lan3 table local  metric 256 
xx dev br-WIFIBUSINESS table local  metric 256 
xx dev br-WIFIGUESTS table local  metric 256 
xx dev br-WIFITrusted2 table local  metric 256 
xx dev br-lan table local  metric 256 
xx dev eth0.2 table local  metric 256 
xx dev br-LAN2 table local  metric 256 
xx dev wlan1 table local  metric 256 
xx dev wlan1-1 table local  metric 256 
xx dev wlan0 table local  metric 256 
xx dev wlan0-1 table local  metric 256 
xx dev pppoe-wan table local  metric 256 
0:	from all lookup local 
32766:	from all lookup main 
4200000000:	from xx iif br-LAN2 lookup unspec unreachable
4200000000:	from xx iif br-Lan3 lookup unspec unreachable
4200000000:	from xx iif br-WIFIBUSINESS lookup unspec unreachable
4200000000:	from xx iif br-WIFIGUESTS lookup unspec unreachable
4200000000:	from xx iif br-WIFITrusted2 lookup unspec unreachable
4200000000:	from xx iif br-lan lookup unspec unreachable
4200000005:	from all iif br-LAN2 lookup unspec 12
4200000007:	from all iif br-Lan3 lookup unspec 12
4200000009:	from all iif br-WIFIBUSINESS lookup unspec 12
4200000011:	from all iif br-WIFIGUESTS lookup unspec 12
4200000013:	from all iif br-WIFITrusted2 lookup unspec 12
4200000015:	from all iif br-lan lookup unspec 12
4200000069:	from all iif pppoe-wan lookup unspec 12
4200000069:	from all iif pppoe-wan lookup unspec 12
ls: /tmp/resolv.*/*: No such file or directory
lrwxrwxrwx    1 root     root            16 Sep  6 18:19 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 Oct 20 16:14 /tmp/resolv.conf
-rw-r--r--    1 root     root           150 Nov 26 10:14 /tmp/resolv.conf.auto
-rw-r--r--    1 root     root            54 Nov 26 10:14 /tmp/resolv.conf.ppp
==> /etc/resolv.conf <==
search lan
nameserver xx

==> /tmp/resolv.conf <==
search lan
nameserver xx

==> /tmp/resolv.conf.auto <==
# Interface wan
nameserver xx
nameserver xx
# Interface wan_6
nameserver xx
nameserver xx

==> /tmp/resolv.conf.ppp <==
nameserver xx
nameserver xx
head: /tmp/resolv.*/*: No such file or directory

I am pretty sure you exaggerated with the redaction of IP addresses and you redacted private ones too, making it impossible to understand what is wrong there.
Private IPv4: 10.0.0.0/8 (10.x.y.z) 172.16.0.0/12 (172.16.x.y - 172.31.x.y) 192.168.0.0/16 (192.168.x.y)
Private IPv6: Link Local fe80::/10 basically every address starting from fe80
ULA fc00::/6 (basically fc.... and fd....)
The DNS you are using are certainly not to be redacted.
Also the public IPv4 can be obfuscated by redacting a few digits in the middle.

1 Like

What happenes of you try to ping 139.59.209.225 (that's openwrt.org IP) or 1.1.1.1?

1 Like

I'm on the same device as OP - getting same results.

Ping results are all 'network unreachable'

On the interfaces page, TRM_WWAN is showing 'not present' - pretty sure this was active before, not sure how to make it work...

update - adjusted a couple of things (removed some evidently non-working wireless uplinks) - saved, rebooted. Now my connected box is back online. But when I'm in the OpenWrt interface (Network Diagnostics) I still can't ping openwrt.org - pinging 1.1.1.1 works fine.

When I enter the direct IP adress, it works:

PING 139.59.209.225 (139.59.209.225): 56 data bytes
64 bytes from 139.59.209.225: seq=0 ttl=57 time=12.127 ms
64 bytes from 139.59.209.225: seq=1 ttl=57 time=12.331 ms
64 bytes from 139.59.209.225: seq=2 ttl=57 time=12.586 ms
64 bytes from 139.59.209.225: seq=3 ttl=57 time=12.589 ms
64 bytes from 139.59.209.225: seq=4 ttl=57 time=12.533 ms

--- 139.59.209.225 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 12.127/12.433/12.589 ms

When I leave it as "openwrt.org" I get the "bad adress". Can this be a DNS issue?

Yep, this is a typical DNS-related error message for BusyBox ping.
Disable peer DNS and configure a major public DNS provider:
https://openwrt.org/docs/guide-user/base-system/dhcp_configuration#upstream_dns_provider

It looks like a different issue, so you'd best create a separate thread providing the proper diagnostics.

1 Like

Sorry, for that. I was not sure about the private ipv6 adresse. Here is the output:

package network

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'xx'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'pppoe'
	option password 'xx'
	option ipv6 'auto'
	option username 'xx'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'xx'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '6t'
	option vid '60'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '2 6t'
	option vid '10'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option ports '1 6t'
	option vid '20'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option ports '0 6t'
	option vid '30'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '6t'
	option vid '40'

config switch_vlan
	option device 'switch0'
	option vlan '8'
	option ports '6t'
	option vid '50'

config interface 'Lan3Xbox'
	option proto 'static'
	option ifname 'eth0.20'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.3.1/24'

config interface 'LAN2AmazonTV'
	option proto 'static'
	option ifname 'eth0.10'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.2.1/24'

config interface 'WIFITrusted2'
	option proto 'static'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.5.1/24'
	option ifname 'eth0.40'

config interface 'WIFIBUSINESS'
	option proto 'static'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.6.1/24'
	option ifname 'eth0.50'

config interface 'WIFIGUESTS'
	option proto 'static'
	option type 'bridge'
	option ip6assign '60'
	list ipaddr '192.168.7.1/24'
	option ifname 'eth0.60'

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option limit '2'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'WIFI_T1'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'WIFI_T1'
	option ra 'server'
	option dhcpv6 'server'
	option ra_management '1'

config dhcp 'LAN2_AmazonTV'
	option start '100'
	option leasetime '12h'
	option interface 'LAN2_AmazonTV'
	option ra 'server'
	option dhcpv6 'server'
	option ra_management '1'
	option limit '2'

config dhcp 'Lan3Xbox'
	option start '100'
	option leasetime '12h'
	option interface 'Lan3Xbox'
	option dhcpv6 'server'
	option ra 'server'
	option limit '2'
	option ra_management '1'

config dhcp 'LAN2AmazonTV'
	option start '100'
	option leasetime '12h'
	option interface 'LAN2AmazonTV'
	option dhcpv6 'server'
	option ra 'server'
	option limit '2'
	option ra_management '1'

config dhcp 'WIFITrusted2'
	option start '100'
	option leasetime '12h'
	option interface 'WIFITrusted2'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option limit '100'

config dhcp 'WIFIBUSINESS'
	option start '100'
	option leasetime '12h'
	option interface 'WIFIBUSINESS'
	option dhcpv6 'server'
	option ra 'server'
	option limit '1'
	option ra_management '1'

config dhcp 'WIFIGUESTS'
	option start '100'
	option leasetime '12h'
	option interface 'WIFIGUESTS'
	option dhcpv6 'server'
	option ra 'server'
	option limit '10'
	option ra_management '1'

package firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option network 'lan'
	option forward 'REJECT'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone
	option network 'Lan3Xbox'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'xbox'
	option output 'ACCEPT'

config zone
	option network 'LAN2AmazonTV'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'amazontv'
	option output 'ACCEPT'

config zone
	option network 'WIFITrusted2'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option name 'WIFIT2'

config forwarding
	option dest 'wan'
	option src 'xbox'

config forwarding
	option dest 'wan'
	option src 'amazontv'

config forwarding
	option dest 'wan'
	option src 'WIFIT2'

config zone
	option network 'WIFIBUSINESS'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'WIFIBUS'
	option output 'ACCEPT'

config zone
	option network 'WIFIGUESTS'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'WIFIGUEST'
	option output 'ACCEPT'

config forwarding
	option dest 'wan'
	option src 'WIFIBUS'

config forwarding
	option dest 'wan'
	option src 'WIFIGUEST'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
5: br-LAN2AmazonTV: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-LAN2AmazonTV
       valid_lft forever preferred_lft forever
7: br-Lan3Xbox: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.3.1/24 brd 192.168.3.255 scope global br-Lan3Xbox
       valid_lft forever preferred_lft forever
9: br-WIFIBUSINESS: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.6.1/24 brd 192.168.6.255 scope global br-WIFIBUSINESS
       valid_lft forever preferred_lft forever
11: br-WIFIGUESTS: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.7.1/24 brd 192.168.7.255 scope global br-WIFIGUESTS
       valid_lft forever preferred_lft forever
13: br-WIFITrusted2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.5.1/24 brd 192.168.5.255 scope global br-WIFITrusted2
       valid_lft forever preferred_lft forever
15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
69: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN qlen 3
    inet 91.14.xxx.xx peer 62.155.xxx.xx/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
default via 62.155.xxx.xxx dev pppoe-wan 
62.155.xxx.xx dev pppoe-wan scope link  src 91.14.xxx.xx 
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1 
192.168.2.0/24 dev br-LAN2AmazonTV scope link  src 192.168.2.1 
192.168.3.0/24 dev br-Lan3Xbox scope link  src 192.168.3.1 
192.168.5.0/24 dev br-WIFITrusted2 scope link  src 192.168.5.1 
192.168.6.0/24 dev br-WIFIBUSINESS scope link  src 192.168.6.1 
192.168.7.0/24 dev br-WIFIGUESTS scope link  src 192.168.7.1 
local 91.14.xxx.xx dev pppoe-wan table local scope host  src 91.14.xx.xx 
broadcast 192.168.1.0 dev br-lan table local scope link  src 192.168.1.1 
local 192.168.1.1 dev br-lan table local scope host  src 192.168.1.1 
broadcast 192.168.1.255 dev br-lan table local scope link  src 192.168.1.1 
broadcast 192.168.2.0 dev br-LAN2AmazonTV table local scope link  src 192.168.2.1 
local 192.168.2.1 dev br-LAN2AmazonTV table local scope host  src 192.168.2.1 
broadcast 192.168.2.255 dev br-LAN2AmazonTV table local scope link  src 192.168.2.1 
broadcast 192.168.3.0 dev br-Lan3Xbox table local scope link  src 192.168.3.1 
local 192.168.3.1 dev br-Lan3Xbox table local scope host  src 192.168.3.1 
broadcast 192.168.3.255 dev br-Lan3Xbox table local scope link  src 192.168.3.1 
broadcast 192.168.5.0 dev br-WIFITrusted2 table local scope link  src 192.168.5.1 
local 192.168.5.1 dev br-WIFITrusted2 table local scope host  src 192.168.5.1 
broadcast 192.168.5.255 dev br-WIFITrusted2 table local scope link  src 192.168.5.1 
broadcast 192.168.6.0 dev br-WIFIBUSINESS table local scope link  src 192.168.6.1 
local 192.168.6.1 dev br-WIFIBUSINESS table local scope host  src 192.168.6.1 
broadcast 192.168.6.255 dev br-WIFIBUSINESS table local scope link  src 192.168.6.1 
broadcast 192.168.7.0 dev br-WIFIGUESTS table local scope link  src 192.168.7.1 
local 192.168.7.1 dev br-WIFIGUESTS table local scope host  src 192.168.7.1 
broadcast 192.168.7.255 dev br-WIFIGUESTS table local scope link  src 192.168.7.1 
0:	from all lookup local 
32766:	from all lookup main 
32767:	from all lookup default 
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80::3a94:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
5: br-LAN2AmazonTV: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2003:xx:xxx:xxx::1/60 scope global dynamic 
       valid_lft 13593sec preferred_lft 993sec
    inet6 fe80::3a94:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
7: br-Lan3Xbox: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2003:xx:713:xxx::1/60 scope global dynamic 
       valid_lft 13593sec preferred_lft 993sec
    inet6 fe80::3a94:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
9: br-WIFIBUSINESS: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2003:xx:713:xxx::1/60 scope global dynamic 
       valid_lft 13593sec preferred_lft 993sec
    inet6 fe80::3a94:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
11: br-WIFIGUESTS: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2003:xx:713:xxx::1/60 scope global dynamic 
       valid_lft 13593sec preferred_lft 993sec
    inet6 fe80::3a94:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
13: br-WIFITrusted2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2003:xx:713:xxx::1/60 scope global dynamic 
       valid_lft 13593sec preferred_lft 993sec
    inet6 fe80::3a94:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2003:xxx:713:xxx::1/60 scope global dynamic 
       valid_lft 13593sec preferred_lft 993sec
    inet6 fe80::3a94:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
17: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3a94:edff:fef8:d2a9/64 scope link 
       valid_lft forever preferred_lft forever
35: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3a94:edff:fef8:d2ac/64 scope link 
       valid_lft forever preferred_lft forever
36: wlan1-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3894:edff:fef8:d2ac/64 scope link 
       valid_lft forever preferred_lft forever
39: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3a94:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
40: wlan0-1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::3894:edff:fef8:d2a8/64 scope link 
       valid_lft forever preferred_lft forever
69: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 2003:xx:7ff:xxx:xxx:9000:f543:1fb0/64 scope global dynamic 
       valid_lft 13865sec preferred_lft 1265sec
    inet6 fe80::f1ff:9000:f543:1fb0/10 scope link 
       valid_lft forever preferred_lft forever
default from 2003:xx:713:xxx::/56 via fe80::f6b5:2fff:fe7b:34fd dev pppoe-wan  metric 512 
default from 2003:xx:7ff:xxxx::/64 via fe80::f6b5:2fff:fe7b:34fd dev pppoe-wan  metric 512 
2003:xx:713:xxx::/64 dev br-LAN2AmazonTV  metric 1024 
2003:xx:713:xxx::/64 dev br-Lan3Xbox  metric 1024 
2003:xx:713:xxx::/64 dev br-WIFIBUSINESS  metric 1024 
2003:xx:713:xxx::/64 dev br-WIFIGUESTS  metric 1024 
2003:xx:713:xxx::/64 dev br-WIFITrusted2  metric 1024 
2003:xx:713:xxx::/64 dev br-lan  metric 1024 
unreachable 2003:xx:713:xxx::/56 dev lo  metric 2147483647  error -148
2003:xx:7ff:xxx:xx:/64 dev pppoe-wan  metric 256 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev br-Lan3Xbox  metric 256 
fe80::/64 dev br-WIFIBUSINESS  metric 256 
fe80::/64 dev br-WIFIGUESTS  metric 256 
fe80::/64 dev br-WIFITrusted2  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev eth0.2  metric 256 
fe80::/64 dev br-LAN2AmazonTV  metric 256 
fe80::/64 dev wlan1  metric 256 
fe80::/64 dev wlan1-1  metric 256 
fe80::/64 dev wlan0  metric 256 
fe80::/64 dev wlan0-1  metric 256 
fe80::/10 dev pppoe-wan  metric 1 
fe80::/10 dev pppoe-wan  metric 256 
anycast 2003:xxx:713:xxx:: dev br-LAN2AmazonTV table local  metric 0 
local 2003:xxx:713:xxx00::1 dev br-LAN2AmazonTV table local  metric 0 
anycast 2003:xxx:713:xxx:: dev br-Lan3Xbox table local  metric 0 
local 2003:xxx:713:xxx::1 dev br-Lan3Xbox table local  metric 0 
anycast 2003:xxx:713:xxx:: dev br-WIFIBUSINESS table local  metric 0 
local 2003:xxx:713:xxx::1 dev br-WIFIBUSINESS table local  metric 0 
anycast 2003:xxx:713:xxx:: dev br-WIFIGUESTS table local  metric 0 
local 2003:xxx:713:xxx::1 dev br-WIFIGUESTS table local  metric 0 
anycast 2003:xxx:713:xxx:: dev br-WIFITrusted2 table local  metric 0 
local 2003:xxx:713:xxx::1 dev br-WIFITrusted2 table local  metric 0 
anycast 2003:xxx:713:xxx:: dev br-lan table local  metric 0 
local 2003:xxx:713:xxx::1 dev br-lan table local  metric 0 
anycast 2003:xxx:7ff:xxx:: dev pppoe-wan table local  metric 0 
local 2003:xxx:7ff:xxx:f1ff:9000:f543:1fb0 dev pppoe-wan table local  metric 0 
anycast fe80:: dev eth0 table local  metric 0 
anycast fe80:: dev br-Lan3Xbox table local  metric 0 
anycast fe80:: dev br-WIFIBUSINESS table local  metric 0 
anycast fe80:: dev eth0.2 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
anycast fe80:: dev br-WIFITrusted2 table local  metric 0 
anycast fe80:: dev br-WIFIGUESTS table local  metric 0 
anycast fe80:: dev br-LAN2AmazonTV table local  metric 0 
anycast fe80:: dev wlan1 table local  metric 0 
anycast fe80:: dev wlan1-1 table local  metric 0 
anycast fe80:: dev wlan0 table local  metric 0 
anycast fe80:: dev wlan0-1 table local  metric 0 
anycast fe80:: dev pppoe-wan table local  metric 0 
local fe80::3894:edff:fef8:d2a8 dev wlan0-1 table local  metric 0 
local fe80::3894:edff:fef8:d2ac dev wlan1-1 table local  metric 0 
local fe80::3a94:edff:fef8:d2a8 dev eth0 table local  metric 0 
local fe80::3a94:edff:fef8:d2a8 dev br-Lan3Xbox table local  metric 0 
local fe80::3a94:edff:fef8:d2a8 dev br-WIFIBUSINESS table local  metric 0 
local fe80::3a94:edff:fef8:d2a8 dev br-lan table local  metric 0 
local fe80::3a94:edff:fef8:d2a8 dev br-WIFITrusted2 table local  metric 0 
local fe80::3a94:edff:fef8:d2a8 dev br-WIFIGUESTS table local  metric 0 
local fe80::3a94:edff:fef8:d2a8 dev br-LAN2AmazonTV table local  metric 0 
local fe80::3a94:edff:fef8:d2a8 dev wlan0 table local  metric 0 
local fe80::3a94:edff:fef8:d2a9 dev eth0.2 table local  metric 0 
local fe80::3a94:edff:fef8:d2ac dev wlan1 table local  metric 0 
local fe80::f1ff:9000:f543:1fb0 dev pppoe-wan table local  metric 0 
ff00::/8 dev eth0 table local  metric 256 
ff00::/8 dev br-Lan3Xbox table local  metric 256 
ff00::/8 dev br-WIFIBUSINESS table local  metric 256 
ff00::/8 dev br-WIFIGUESTS table local  metric 256 
ff00::/8 dev br-WIFITrusted2 table local  metric 256 
ff00::/8 dev br-lan table local  metric 256 
ff00::/8 dev eth0.2 table local  metric 256 
ff00::/8 dev br-LAN2AmazonTV table local  metric 256 
ff00::/8 dev wlan1 table local  metric 256 
ff00::/8 dev wlan1-1 table local  metric 256 
ff00::/8 dev wlan0 table local  metric 256 
ff00::/8 dev wlan0-1 table local  metric 256 
ff00::/8 dev pppoe-wan table local  metric 256 
0:	from all lookup local 
32766:	from all lookup main 
4200000000:	from 2003:xx:713:xxxx::1/60 iif br-LAN2AmazonTV lookup unspec unreachable
4200000000:	from 2003:xx:713:xxxx::1/60 iif br-Lan3Xbox lookup unspec unreachable
4200000000:	from 2003:xx:713:xxxx::1/60 iif br-WIFIBUSINESS lookup unspec unreachable
4200000000:	from 2003:xx:713:xxxx::1/60 iif br-WIFIGUESTS lookup unspec unreachable
4200000000:	from 2003:xx:713:xxxx::1/60 iif br-WIFITrusted2 lookup unspec unreachable
4200000000:	from 2003:xx:713:xxxx::1/60 iif br-lan lookup unspec unreachable
4200000005:	from all iif br-LAN2AmazonTV lookup unspec 12
4200000007:	from all iif br-Lan3Xbox lookup unspec 12
4200000009:	from all iif br-WIFIBUSINESS lookup unspec 12
4200000011:	from all iif br-WIFIGUESTS lookup unspec 12
4200000013:	from all iif br-WIFITrusted2 lookup unspec 12
4200000015:	from all iif br-lan lookup unspec 12
4200000069:	from all iif pppoe-wan lookup unspec 12
4200000069:	from all iif pppoe-wan lookup unspec 12
ls: /tmp/resolv.*/*: No such file or directory
lrwxrwxrwx    1 root     root            16 Sep  6 18:19 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 Oct 20 16:14 /tmp/resolv.conf
-rw-r--r--    1 root     root           150 Nov 26 10:14 /tmp/resolv.conf.auto
-rw-r--r--    1 root     root            54 Nov 26 10:14 /tmp/resolv.conf.ppp
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.auto <==
# Interface wan
nameserver 217.237.151.142
nameserver 217.237.150.188
# Interface wan_6
nameserver 2003:180:2:a000::53
nameserver 2003:180:2:b000::53

==> /tmp/resolv.conf.ppp <==
nameserver 217.237.151.142
nameserver 217.237.150.188
head: /tmp/resolv.*/*: No such file or directory


Thank you for this. I will test it when I am back home this evening.
As I am new to OpenWRT - are those shell commands or do I have to edit a specific config file for this?

Try pinging 139.59.209.225 (It's the IP of openwrt.org). If it works then it's a DNS issue. If it doesn't then it might be that access to the server is denied (e.g. by ISP).

1 Like

I had my DNS configured elsewhere, but the openwrt box was ignoring it. Moved the configuration elsewhere and it now works, can ping and opkg can download.

(don't remember where these DNS configs were - that was about 50 entry edits ago...

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

Hi trendy,

sorry for the late. Well, this was actually my Topic and I still have those problems.
I tried it with changing the DNS and also deactivate the peer DNS. But still, DNS for the router itself is not working. The changes (DNS server) works for the clients. I have checked this via Browserleaks.

Lasko

Sorry for that, I got confused.

Both router and hosts are using the same DNS.
Check that dnsmasq listens to all interfaces: netstat -anp | grep 53
You have the option nonwildcard enabled but didn't specify the interfaces, so maybe there is an issue there.

Here is the outpur for netstat -anp | grep 53:

tcp        0      0 91.14.xxx.xx:53         0.0.0.0:*               LISTEN      4224/dnsmasq
tcp        0      0 192.168.2.1:53          0.0.0.0:*               LISTEN      4224/dnsmasq
tcp        0      0 192.168.3.1:53          0.0.0.0:*               LISTEN      4224/dnsmasq
tcp        0      0 192.168.6.1:53          0.0.0.0:*               LISTEN      4224/dnsmasq
tcp        0      0 192.168.7.1:53          0.0.0.0:*               LISTEN      4224/dnsmasq
tcp        0      0 192.168.5.1:53          0.0.0.0:*               LISTEN      4224/dnsmasq
tcp        0      0 192.168.1.1:53          0.0.0.0:*               LISTEN      4224/dnsmasq
tcp        0      0 2003:xxx:739:xxxx::1:53  :::*                    LISTEN      4224/dnsmasq
tcp        0      0 2003:xx:739:xxxx::1:53  :::*                    LISTEN      4224/dnsmasq
tcp        0      0 2003:xx:739:xxxx::1:53  :::*                    LISTEN      4224/dnsmasq
tcp        0      0 2003:xx:739:xxxx::1:53  :::*                    LISTEN      4224/dnsmasq
tcp        0      0 2003:xx:739:xxxx::1:53  :::*                    LISTEN      4224/dnsmasq
tcp        0      0 2003:xx:739:xxxx::1:53  :::*                    LISTEN      4224/dnsmasq
tcp        0      0 2003:xx:7ff:xxx:e0ae:xxxx:xxx:7712:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::e0ae:fa36:9246:7712:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a9:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3a94:edff:fef8:d2ac:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3894:edff:fef8:d2a8:53 :::*                    LISTEN      4224/dnsmasq
tcp        0      0 fe80::3894:edff:fef8:d2ac:53 :::*                    LISTEN      4224/dnsmasq
udp        0      0 91.14.xxx.xx:53         0.0.0.0:*                           4224/dnsmasq
udp        0      0 192.168.2.1:53          0.0.0.0:*                           4224/dnsmasq
udp        0      0 192.168.3.1:53          0.0.0.0:*                           4224/dnsmasq
udp        0      0 192.168.6.1:53          0.0.0.0:*                           4224/dnsmasq
udp        0      0 192.168.7.1:53          0.0.0.0:*                           4224/dnsmasq
udp        0      0 192.168.5.1:53          0.0.0.0:*                           4224/dnsmasq
udp        0      0 192.168.1.1:53          0.0.0.0:*                           4224/dnsmasq
udp        0      0 2003:xx:739:xxxx::1:53  :::*                                4224/dnsmasq
udp        0      0 2003:xx:739:xxxx::1:53  :::*                                4224/dnsmasq
udp        0      0 2003:xx:739:xxxx::1:53  :::*                                4224/dnsmasq
udp        0      0 2003:xx:739:xxxx::1:53  :::*                                4224/dnsmasq
udp        0      0 2003:xx:739:xxxx::1:53  :::*                                4224/dnsmasq
udp        0      0 2003:xx:739:xxxx::1:53  :::*                                4224/dnsmasq
udp        0      0 2003:xx:7ff:xxx:e0ae:xxxx:xxxx:7712:53 :::*                                4224/dnsmasq
udp        0      0 fe80::e0ae:fa36:9246:7712:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a9:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3a94:edff:fef8:d2ac:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3894:edff:fef8:d2a8:53 :::*                                4224/dnsmasq
udp        0      0 fe80::3894:edff:fef8:d2ac:53 :::*                                4224/dnsmasq
unix  2      [ ACC ]     STREAM     LISTENING       1172 539/ubusd           /var/run/ubus.sock
unix  3      [ ]         STREAM     CONNECTED       5473 539/ubusd           /var/run/ubus.sock
unix  2      [ ]         DGRAM                       263 539/ubusd           
unix  3      [ ]         STREAM     CONNECTED       1517 539/ubusd           /var/run/ubus.sock
unix  3      [ ]         STREAM     CONNECTED       1531 539/ubusd           /var/run/ubus.sock
unix  3      [ ]         STREAM     CONNECTED       2796 539/ubusd           /var/run/ubus.sock
unix  3      [ ]         STREAM     CONNECTED       3919 539/ubusd           /var/run/ubus.sock
unix  3      [ ]         STREAM     CONNECTED        265 539/ubusd           /var/run/ubus.sock
unix  3      [ ]         STREAM     CONNECTED       1530 904/rpcd            
unix  3      [ ]         STREAM     CONNECTED        803 539/ubusd           /var/run/ubus.sock
unix  3      [ ]         STREAM     CONNECTED       1657 539/ubusd           /var/run/ubus.sock

The router is located in LAN1 192.168.1.xx. Also my Notebook (no problems here).

Just as I suspected the dnsmasq is not listening on the localhost. Try to remove the nonwildcard option, restart dnsmasq and try it again.

1 Like
uci -q delete network.loopback
uci set network.loopback="interface"
uci set network.loopback.ifname="lo"
uci set network.loopback.proto="static"
uci set network.loopback.ipaddr="127.0.0.1"
uci set network.loopback.netmask="255.0.0.0"
uci commit network
/etc/init.d/network restart
2 Likes

Thank you very much for this! Now it is working.
Maybe you can explain what these commands are doing?

Cheers
Lasko

1 Like