Netgear R6220 | Latest OpenWrt Help

Need some update if someone is using latest build on Netgear R6220. Need some inputs if WiFi is stable especially 2.4Ghz ?

I want to try this build but I have never installed in on Netgear Router. I was using Xiaomi Mini earlier

Also, how to know which one is the latest snapshot build ?

Any inputs will be great.

https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/
https://openwrt.org/toh/hwdata/netgear/netgear_r6220

Thanks for your response but am looking for some information regarding the performance. Should I stick to stock firmware or this one is ok as a daily driver ?

Oh

I just found the release, should be worth trying

https://downloads.openwrt.org/releases/18.06.0/targets/ramips/mt7621/

Not sure if its stable as if now, will wait for reviews. Hope someone can answer this.

Do you already have one? Unless you have a very strong attachment to that specific model you should probably look at a MT7621A device or preferably ARM-based.

Unfortunately I recently exchanged it with my Xiaomi mini as I needed a gigabit router. :frowning:

MT7603EN is used for 2.4Ghz so you can probably expect "all" issues people are reporting using the Xiaomi 3G router. That said, it can also work just fine in your case. I'd highly recommend that you try a snapshot build and before you to make sure (in worst case) you know how to recover using tftp or whatever procedure it supports.

I installed 18.06 on my R6220 (bought in March 2016) yesterday. So far it works quite well but I struggled a bit with the installation documentation. The tar mentioned by mbo2o brought my device into a boot loop. But unbricking with nmrpflash worked like a charm.

Instead of using the the tar I had to use these files:
https://downloads.openwrt.org/releases/18.06.0/targets/ramips/mt7621/openwrt-18.06.0-ramips-mt7621-r6220-squashfs-kernel.bin
https://downloads.openwrt.org/releases/18.06.0/targets/ramips/mt7621/openwrt-18.06.0-ramips-mt7621-r6220-squashfs-rootfs.bin

Besides one small issue mentioned below it works everything as expected. I configured it as dumb AP with 2.4G and 5G. Both frequencies work fine and so far I don't see any differences regarding wifi reliability compared to stock firmware. One limitation of the WiFi configuration is that you have to specify the band to use - automatic band selection doesn't work - the WiFi cannot be activated.

Next step for me will be the configuration of a guest VLAN (which is not possible with the stock firmware if using it as AP).

The only small issue that I experienced was the loss of two configuration files after a power failure (yes, it was me, I unplugged the wrong device). The config file for LuCI (uhttpd) and RPC backend server (rpcd) were corrupted - only random characters. I had to copy the files from /rom/etc/config in order to get LuCI back to work. I hope that this was only a one-time failure and won't happen again with the next power cycling.

One more challenge for me will be the WAN port - I would like to use it as uplink port. But it doesn't connect with 1GBit/s - only 100MBit/s. Tools like mii-tool and ethtool were not able to recognize the interface. Maybe I have to read more documentation to understand the bandwidth configuration.

Happy to hear your experiences with 18.06 and thanks to the developers for releasing the first non-snapshot version!

3 Likes

Thanks for this elaborate explanation, happy to know Wifi is stable for both, i can set them manually so not an issue. However i have 125 Mbps connection so i need WAN port to work at 1000Mbps.

Correct me if am wrong it seems you cannot change it to 1Gbps and stuck on 100Mbps ? @rsterz

Thanks man, let me know if you were able to get it sorted :slight_smile: good luck !!

Well, don't ask me why but connected to my switch (Netgear GS724Tv4) I get a 1000Mbps connection using the WAN port of my R6220. I assume the issue I experienced yesterday was related to the direct cable connection between notebook and R6220.

Great, now going ahead, next step is the VLAN configuration.

Awesome, if you could help me with the commands that will be great.

Also, the sequence of Port is it the same or is it reversed ?

Yes, LAN ports are in reverse order. WAN port is assigned correctly.

I succeeded with the VLAN configuration yesterday. It was quite well documented in several blogs how to set up VLANs on OpenWRT. That made it easier to figure out how to realize it.

My goal was to separate guest traffic from my regular home network. That was the reason why I installed OpenWRT on the Netgear R6220 as this feature is not supported by stock firmware.

This is my setup:
Home%20Network

This might look a bit strange. Let me quickly explain what I did:
The Fritzbox is my router to the internet. It doesn't support VLANs but provides a dedicated LAN port for guests. That's why the Fritzbox has two connections to my switch. One connection is used for my regular network traffic and the second for guest traffic. The Fritzbox provides different DHCP ranges on both interfaces and separates the traffic.

My switch (a Netgear GS724Tv4) has all required VLAN options out of the box. By default all ports are in VLAN 1 (untagged). I had to remove the guest LAN port from Fritzbox from VLAN 1 and added it to VLAN 100 (untagged). To support traffic flowing through that port I had to set the port with PVID 100. From that point in time the switch had two separate VLANs - VLAN 1 for my regular network traffic and VLAN 100 for guest traffic.

Towards my R6220s which I use as Access Points on each floor in our house I configured a VLAN trunk - meaning VLAN 1 and 100 tagged to the ports on my switch.

Now I am coming to the R6220 setup. I created a VLAN 100 in the switch configuration and tagged the ports CPU and WAN - all others "off" as I don't want guests to use my Ethernet ports. I configured VLAN 1 to be tagged on CPU and WAN as well. I am still using VLAN 2 for the LAN ports (untagged) and CPU tagged. I could merge it to VLAN 1 but didn't change it so far:

Switch

Next step was the WIFI configuration. This is pretty much straight forward. Just created two SSIDs for each radio interface (I had to assign the radio frequency manually):

WIFI

Next part was the interface configuration. I use two bridges and dropped the pre-defined WAN interfaces. The bridges merge traffic of my home network (LAN ports, WIFI 2.4, WIFI 5G, WAN) and guest traffic (WIFI 2.4 Guest, WIFI 5G Guest, WAN):

Interfaces

If anybody wants more detailed information on the configuration just ask. So far it works stable and I am very happy that I could re-use my R6220s for the guest VLAN.

2 Likes

Ok so only thing left for me is to install it.

If someone can quickly confirm the commands to install or any specific procedure that will be great. Thanks in advance.

This document is fine ?

https://emersion.fr/blog/2017/installing-lede-on-a-netgear-r6220/

mtd_write write openwrt-18.06.0-ramips-mt7621-r6220-squashfs-rootfs.bin Rootfs
mtd_write write openwrt-18.06.0-ramips-mt7621-r6220-squashfs-kernel.bin Kernel
reboot

and Install LUCi 

opkg update
opkg install luci 

That should be it ?

LuCI is part of the 18.06 package - doesn't require any new install. But there have been updates to some packages of LuCI after this release. In case you have trouble with the pre-installed version, you can update the packages with:

opkg update
opkg list-upgradable
opkg upgrade <package-name>

But please be aware that upgrading packages that are part of the firmware image will use additional memory from your user space. This is different compared to a regular Linux environment which works without read-only Squashfs partition. Details can be found here:
https://wiki.openwrt.org/doc/techref/opkg

Yippie, I am no newbee in this forum anymore and can post more replies. I will add the remaining installation steps for my AP scenario later tonight [see updated post above]

But I came across a problem with the Access Point that I didn't expect so far. Almost all devices were able to connect to my Openwrt AP besides one - an IP camera (Instar IN-9008 Wifi). This camera supports 802.11n (144Mbps) on 2.4G. It connects flawlessly with the R6220 stock firmware but doesn't connect to my Openwrt AP using R6220. The SSID scan of the IP camera lists my Openwrt access point.

What did I do so far to analyze the problem (unfortunately the IP camera has no detailed logging):

  • I have set the wireless logging to verbose debugging (log_level '0'), no events of the IP camera get listed by logread
  • I monitored the traffic on the Wifi interface using Aircrack: There is nothing visible - not even a single attempt of the IP camera to connect to the Wifi, no beacons, nothing
  • As I have 3 R6220s, I monitored the traffic of the stock firmware and replicated all settings that I could identify as different: WPS, HT20, turning off 802.11d, country_ie, short_preamble, fragmentation and RTS/CTS thresholds - in my WiFi scanner it looks nearly identical to the stock firmware access point - only vendor and model cannot be transmitted - but still no attempt of the IP camera to connect
  • I turned off encryption of the connection completely - doesn't make any difference

It seems to be related to the Wifi settings and not to encyption or other network settings. So it must be somehow a problem on the "air" connection.

Whenever I switch back to the stock firmware R6220 the connection of the IP camera is up in under 10 seconds - so it seems that the IP camera is always listening for the network.

Any idea how to continue analyzing the IP camera issue? I am a little bit stuck right now with that situation.

Update: Problem seems to be related to [EEPROM data check failed: ffff] MT7603EN/MT7612EN Wifi Troubles on Netgear R6220

Strange thing is that sometimes a connection to the AP on 2.4G works but usually doesn't. 5G is not affected. The other R6220s work fine with OpenWrt - I bought all 3 at the same time but they seem to be different.

Hi @rsterz

Can you share the config from the device ? I am trying to configure - don't really see what could be wrong yet it doesn't work? Have you done all config from Luci?

Br,
Mike

The latest OpenWrt releases doesn't have the NAND offset issue. You can proceed on upgrading and configure as usual.