Netgear R6220 Issue on first loading no internet with Netgear genie CM600 and 192.168.100.0/24 Working!

To start off, I have used OpenWRT in the past and would have put it on my Netgear 6220 when I bought it new. Except there wasn't a distribution for it at the time. After years of waiting and having the (cough) sparetime, I found that it was finally available and downloaded the appropriate firmware (openwrt-19.07.6-ramips-mt7621-r6220-squashfs-factory) and installed it. During the installation the OEM firmware uploader reported it as version V1.0.0.86. That left me scratching my head as the release verion was 19.07.6. I continued anyway.

  1. I installed via the web interface with the current IP address of the local machine of 192.168.100.XXX. The IP address may have meaning later. After procedure was complete there was no internet. FAIL.

NOTE) Not being familiar with the interface, I noticed that the WAN & WAN6 where in RED Icons. It meant either the danger side of the router or a problem with the interface. No IP address info was visible for the WAN interfaces but there was for the LAN. After everything is running they are still red, so red must indicate the danger side.

  1. At this point I am pretty sure I manually unplugged the router and plugged it back in, though I may have done the next step first. NO INTERNET.

  2. Setup my DHCP Server to use address range of 192.168.100.0/24 with address of 192.168.100.2 for server. Assigned a couple of static numbers for my current workstation and my fileserver. Setup the wireless and confirmed I could connect via a laptop. I have a good LAN side at this point though still no WAN access. OK LAN.

  3. Tried unplugging and replugging both the router and the modem. NO INTERNET.

  4. Hooked up my workstation directly to modem and got my assigned info from ISP. OK.

  5. Applied the info to the WAN as a static address and reboot. NO INTERNET.

  6. Testing SSH'ed into the router and unable to ping the gateway of the WAN.

  7. Unpowered router and modem then unplugged cable from ISP side of modem and repowered modem, then repowered router. WAN results with some IP address info of 192.168.100.10/20 or something very close to that, with a gateway address of 192.168.100.1. Unable to ping gateway from workstation obviously. The assigned addresses VERY STRANGE.

  8. Reassigned the DHCP Server addresses on the router to 192.168.101.XXX and rebooted. Can finally ping the gateway. WAN Gateway OK.

  9. Reconnected the cable from the ISP to the modem and after a minute the WAN and WAN6 interfaces are established. INTERNET OK.

Proposed SYNOPIS) Under normal testing and installation all may have gone to plan. ┬┐Although since my original DHCP IP address assignments where at the same starting IP assignment as what the modem was using, though with a different subnet, the installation was somehow getting that as pre info? That is a hugh guess as I am not sure as to the inner workings of modems and routers.

I hope this is detailed enough for someone with far greater knowledge and in the correct place as I am unsure as wether this is solely applicable to the Netgear router.

Granted, the R6220 had a few problems in the beginning, but it received support almost 4 years ago. Regardless, welcome to the OpenWrt community!

That is probably a bogus version to make the OEM firmware think it is upgrading to a Netgear firmware. Don't pay any attention to that.

It means neither. The colors are just to differentiate firewall zones from one another. Yes, red and green are not especially fortunate choices without giving context. WAN is always red, LAN is always green, and you're right, probably to indicate the "dangerous side" and the "safe side" of the router.

Thanks, and I think I have had this router for about 5 years or so. A long time and I replaced and older WR200 or something like that. I am old and can't remember old details. I figured you guys had a handle on things, so when the N6220 installation procedure said to load that firmware, that's the one that went on. Yall have a lot of trust from this guy and that is the highest compliment anyone can get from me.

I think I have the same issue. I found a workaround for this issue:
After both modem and router are up and running, disconnect cable between modem and router for few seconds and then reconnect it. Internet comes up.
This is the only thing I have to do, otherwise, all configurations are standard.