NETGEAR R6220 "disconnected due to excessive missing ACKs"

I keep getting disconnected over wireless when using the router as an AP. Both client and master are on Radio1 (5GHz).

LEDE Reboot SNAPSHOT r4526-a0bb6c9 / LuCI Master (git-17.186.70712-4f127c3)

Thu Jul  6 13:43:23 2017 hostapd: wlan1-1: STA PHONE:MAC IEEE 802.11: disconnected due to excessive missing ACKs
Thu Jul  6 13:43:23 2017 daemon.notice hostapd: wlan1-1: AP-STA-DISCONNECTED PHONE:MAC

Phones will put their wifi radio to sleep when there is no activity. This can lead to the AP being unable to handshake with the phone and making a "missing ACK" disconnect which is normal.

It should not occur if the phone is constantly transferring data and there is a good signal strength on the connection.

It happens all the time, after about 5/10 seconds being connected. If I run a speedtest for example, instant drop. I'm right next to the AP now, so signal is very good.
I've also tried with other wireless devices. Same result.

I think that 3 issues are related, it is not need to create several threads, just explain the situation very detailed, and you will get help anyways, :wink:

1 Like

You are right. Apologies for that. It went from me thinking it was my fault for the problem, config is wrong, to thinking it may be a driver/firmware bug. That's all.

1 Like