Netgear R6100, slow 2.4g, no 5g. New router suggestions?

Hello!

TL:DR I'm unsure as to what router to get and if I can revert back to my stock firmware without bricking my device. Do I just flash it in LuCI or hit the reset button on the router? The reset puts it into some telnet safe mode right? I'm confused.

As the title says, my routers wireless isn't functioning properly. It's almost 7 years old, I think I just need a new one. The 5g radio wont turn on, even on the stock firmware.

I'm new to openWrt. It's exactly what I was looking for. However my current device is either defective or not supported by it all that well. I need to be sub channel 6 on 2.4ghz to get any speed. On the stock firmware I was on channel 9 getting decent/reliable speeds. There are a lot of other routers in the sub channel 6 range in my neighborhood.

When I first switched it to channel 4 (the one that shows no other routers) I got almost 70Mbps down. It's been very strange though. Other tests show only 3.7Mbps and it varies. Sometimes the system has no connection at all.

So I have two questions. Should I buy a new router? If so suggestions are nice. As well as in the meantime, can I flash back my original firmware from Netgear via LuCI or will it brick my device? I'd rather have some internet than no internet. It's just the other person in my home uses wifi on their device and these outages are very frustrating for them and myself.

I'm looking at this Linksys EA8300 on amazon for about $150. It's already 3 years old or so from what I see. Are there newer, better devices? I'm looking for longevity and a good product. So far Netgear has let me down twice with random/weird hardware/firmware failures.

Any help is really appreciated, thanks so much! If you read all this my apologies. I ramble.

I have several of those. Buying them used I found that hardware failure of the 5 GHz radio is common. If you get a good one it actually has quite good radio performance for a desktop router, beating many that have external antennas.

It is very easy to use the TFTP recovery to return to stock. Never tried using OpenWrt to flash back to stock.

1 Like

To get the router up and running again you shuld use nmrpflash


you can use that to flash openwrt or the stock firmware.
btw i have also the r6100 and it works well with r19 for me

1 Like

Ahh, I did read that skimming through the documentation about TFTP. I had forgotten. My bad.

How are the 2.4 radio's when it's a defective model? Mine isn't reliable, at least with openWrt. Maybe it's my configuration.

I was getting around 50Mbps on the stock firmware on channel 9. Flashing openWrt I set it to channel 9 and was only seeing a 3-4Mbps crawl.

I found a forum post saying sub 6 range and 11 are the best channels. I set it to auto and it went to ch 6 with 5 other devices. I noticed ch 4 had none and switched it to that.

Ran a test and got 70Mbps, fastest number I've seen from the router. It consistently fell off though back to the 3-4Mbps crawl. It's the same crawl running a test today too.

I'm at a loss, is it the hardware? On the stock firmware it was mostly fine. Maybe when I flash it back it wont be. It was getting varying speeds but it'd do 40-50Mbps on ch 9 with the stock firmware reliably.

I also have yet to reboot the router since installing openWrt and updating all the packages. Or setup QoS. Could it be either of those two things? My config is still pretty fresh. Also I noticed since flashing the globe and blue wifi led flash. I assume that's normal?

Should I not of updated all the packages? I didn't see an update all button so I'm thinking no.

Thanks for your help! I'm unsure if it's hardware or my configuration. Glad I know how to flash my device back now! I'd like to see if I can fix openWrt before I flash back the OEM firmware tomorrow. If you have the time and can answer any of my questions I'd really appreciate it!

The ones with broken 5 GHz radio will bring up an AP but it only is detectable for a few feet from the router. The 2 GHz works normally.

The 2 GHz channels are based on an old standard where the signal was only 5 MHz wide instead of 20. So adjacent channels will interfere with each other. Best practice (in countries where 11 channels are allowed) is to set your radio to channel 1, 6, or 11 and not any of the other ones.

Overall 2 GHz is not good if you have more than a couple of neighbors.

1 Like

Hmm. I'll try channels 1,6 and 11 tomorrow and see what my results are. However there are many devices on all of those channels. I think ch 8 or 9 was the one with isolation.

I still don't understand though how I was on the OEM firmware on ch 9 absolutely fine. On openWrt I only get a 3-4Mbps crawl. Hopefully it didn't mess up the radio. I'll see tomorrow when I can easily do more testing. Maybe it's operator error, something to do with my config. I don't know. A reboot would also help I'd imagine.

I really like the power user stuff openWrt has to offer. Unfortunate my wifi speeds are suffering with this device. I'll be sure to get a new one that is supported by openWrt. I was looking into making a 'future proof' pfsense or ipfire based box but that'd be way more on power. Overkill for a home network that might run a game server here and there. openWrt was exactly what I was looking for. I wish I found it sooner.

Thanks so much for getting back to me! I wasn't sure what to do at first with flashing back the original firmware. I know more so what to do now. I hope I can get my wifi to reasonable speeds so I don't have to flash back the OEM firmware.

I have no idea what the issue could be. I've edited some of the settings for my 2.4g and I'm getting acceptable numbers. However, running speed tests consecutively will make the machine go into the 2-4Mbps crawl. If I reboot the machine it's fine. I have no idea what is happening and I wasn't having this issue at all on the stock firmware. Anyone have a clue?

I don't have QoS setup and I don't know how to. I was seeing there's something called 'piece of cake'? Maybe it's already configured Idk. I see no QoS option on the menu though.

I have the router set to channel 8 and was seeing almost the full 90Mbps I get down. That was really nice. I'd like to use openWrt. The desktop has a Realtek RTL8192CE card in it.

Also thanks @lumo, I have that all setup for when I want to flash the device back. Pretty sure I understand the instructions. Hit enter on the command and then turn on the router. Seems way simpler than TFTP.

Okay, so the issue is buffer bloat?... I've never heard of this term until now. Learning I suppose but this is quite infuriating.

Does anyone know the QoS disciplines and script I should use? I tried fq_codel and piece_of_cake.qos and it improved it a little bit. It's still going into that mode though of just having 2-4Mbps.

I'm losing my mind trying to figure out what the issue is. Is it buffer bloat? Why? How do I fix it? I enabled QoS, is there a different discipline and script I need to use?

So come to find out it's now an issue with the wifi card in the desktop. If I uninstall the driver and reboot the pc it's fine for a few. Can watch 720p streams fine. 40Mbps down. However it goes into that snail mode.

That computer was made with old hardware. I'm thinking something is just messed up with the computer itself. I found this video with someone having a similar issue. https://youtu.be/laWyX6fmw58

They switched to an older windows 7 driver, 1005.36.0417.2012. I did that and it seems to have fixed the issue so far. However I never had this issue until using openWrt. Very odd, it's been driving me crazy.

Non the less I have a gigabit wan/lan router now, not supported by openWrt but it might be in the future. Hopefully I don't have random hardware failures with this Linksys router.

I enabled TFTP on my PC since it isn't just enabled by default. I'm going to try and flash openWrt back to the r6100 and give it to a friend to replace this usb wifi dongle he's using.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.