Netgear GS308T persistence

New to the OpenWRT so please be kind.

I wanted more out of my Netgear GS308T and decided to flash it to OpenWRT. There are few things that I noted in the results

  • I only have SSH shell, the WebUI never got installed. When I checked the uhttpd in ps, it isn't present.
  • Any change or file copy I do to the switch, it is not persistent. I searched the forum, for similar issues and there was mention of execution of the command: sysupgrade -n /tmp/openwrt-realtek-generic-netgear_gs308t-v1-squashfs-sysupgrade.bin. It runs and reboots the box but then it is back to the same default settings.

Below is os-release in /etc

root@OpenWrt:/etc# cat os-release
ID_LIKE="lede openwrt"
OPENWRT_RELEASE="OpenWrt SNAPSHOT r22153-107f7374c9"

I would really appreciate any help, I am not good with soldering so if I can avoid going serial then I would prefer it. Thanks

The snapshot releases are built without LuCi the WebUI. If you want LuCi you'll either need to install it and/or build your own image or use a release image. The initial install is in RAM only, you need to do the sysupgrade in order to have a persistent installation.

Thanks Raylynn, I wasn't aware of that, I can work to get UI installed.
I did execute the command for sysupgrade (below) but no avail, is there anything I am supposed to do to make it persistent.

sysupgrade -n /tmp/openwrt-realtek-generic-netgear_gs308t-v1-squashfs-sysupgrade.bin

That should be everything needed.

What do you mean by no avail? Did you get any errors on the command line or see anything else happen?

I assume you had already copied/downloaded the file from the downloads site and into the /tmp directory on the router first?

It didn't give any errors. Upon command execution, it goes for a reboot and comes back to its original state without a password and all settings are lost. When I set a new password and reboot, it repeats the exact behavior of not persisting the information.

I will try with the file, you had mentioned and report back.

Attaching the screenshot of the command execution.

Post reboot I set the password, did a reboot and the system came back with default of no password on root.

To be clear, did it - or did it not upgrade successfully?

It said it is doing but looks like it is the same. Below is the cat on openwrt_release

root@OpenWrt:/etc# cat openwrt_release
DISTRIB_DESCRIPTION='OpenWrt SNAPSHOT r22153-107f7374c9'

Ummmm...that's today's yesterday's snapshot!

It is the same.

opkg update
opkg install luci-ssl


:spiral_notepad: Or add luci-ssl to a custom SNAPSHOT image here:

:notebook: This link appears to have a newer SNAPSHOT



Thanks, figured out how to get Luci to work. (Switch wasn't picking up the default gateway and nameserver so had to force it before the installation of luci)

I tried uploading the firmware from it too, and it basically has the same behavior ie., Firmware uploads and flashes fine reverts back to the default settings.

Attaching screenshot of the status page, not sure if this helps

You're currently running an intramfs image, so it's not at all surprising that you're having this issue.

You need to upgrade to the normal squashfs image to have a system that is persistent.

Since you have LuCI running, you might as well use the LuCI firmware update path. Download the sysupgrade image to your computer.... then use the web interface to upgrade:

System > Backup / Flash Firmware > Flash new firmware image

Be sure to not keep settings across the upgrade. Let us know if you encounter any errors, warnings, or any other issues along the way.

1 Like

I think I confused you. I did flash like you said with openwrt-22.03.3-85cce25b7351-realtek-rtl838x-netgear_gs308t-v1-squashfs-sysupgrade file, and it still keeps reverting back to the intramfs

Is that the actual filename of what you're using? If so, it seems a bit odd to me... where did it come from?

When I download it from the link I provided earlier, I get this filename:


Is active partition set to primary? It seems that initramfs image written to secondary is booted.

$ fw_printsys
1 Like

Thank you, this is output I get:

root@OpenWrt:~# fw_printsys

Ok, it's secondary partition...
Next, try the following command to switch to primary:

fw_setsys bootpartition 0

and check:


Finally, reboot your device.


Thanks Musashino, this seemed to be the problem. I made the change you suggested and it solved the issues I was having. Thanks again for being super responsive

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.