Netgear GS308T OpenWrt installation failed?


This is my first time trying to install OpenWRT on my Netgear GS308T. I used the OEM HTTP file transfer update option in the settings and rebooted the switch. The switch light is now orange and I'm unable to access the switch through the web browser. I installed the .bin file and now I'm unsure of what to do.

What can I do?

Thank You!

Did you try connecting to it via ssh already? The initramfs image you installed (master snapshots) don't contain the webinterface. If that fails, you will need to connect to it via (3.3V!) serial console access to debug the issue (if you can connect, don't forget the second step of flashing the regular sysupgrade image).

Would I use something like Putty on my PC? And if so, is it an IP address?

PuTTY is a decent ssh client for windows (and which can also be used for serial console access), but modern windows also offers OpenSSH - whatever you fancy.

Also keep in mind that the default OpenWrt configuration only exposes the management interface (be it webinterface (which you don't have with your currently installed image) or ssh) on the first ethernet port, on a tagged VLAN with VID 100 ( - but that's the same for all devices of the realtek target for now (although there are plans to make this more user friendly in the future; realtek support is still rather fresh, but working nicely).

Since I just tried to SSH into my Switch and nothing is happening, I'm guessing I need to re-image my switch to the factory firmware (assuming I'm able to). I looked it up and it says I can use U-Boot TFTP. But if it is bricked (supposedly) can I even access it?

1 Like

This issue keeps biting newcomers. I wish we could do something to eliminate this VLAN requirement!

1 Like

Totally agreed, but I kind of fear that ship has sailed for 21.02.x ( would also be wanted there) - doesn't mean it can't be fixed for the next one.

I feel like I'm in the same boat as this post at the moment. But I'm not entirely sure.

You really want serial console access (3.3V!) in case anything goes wrong, but chances are that you're just missing the VLAN tagging.

1 Like

What is VLAN tagging?

Sorry but I'm not sure what I can do from here. Does anyone have a guide I can follow?

put your NIC on the correct VLAN, the try to connect again
might need to put a static IP on it as well, on the 192.168.1. subnet, but not .1.

once reconfigured, don't forget to remove it again.

I have given you a link to a step-by-step guide for correctly configuring VID100 on a linux system (hint, linux live systems are around for every major distribution), for windows you'll have to search for yourself. The alternative would be using serial console access, with the details for the connection being explained in the previously linked commit description adding support for this device.

Please take a step back, read what you've been given and try to understand what that means for your situation - ask about the things that might be confusing.

Right now I don't think your switch has any problem to begin with (once you configure the right VLAN settings on your computer), and even if it did, I would expect it to be easily solvable over a serial connection. But if you storm ahead without really understanding what you're doing, there is a quite considerable risk of doing permanent harm to the switch - so take your time and read what you really should have read before even thinking about flashing OpenWrt to your (any) device for the first time.

Disclaimer: While I'm not familiar with this particular device, I have flashed (and am using-) OpenWrt on other rtl838x based switches - and it works rather nicely, once you've settled on your desired configuration and access policy for the management VLAN (lan).


Being one of trhe first ones having "bricked" my gs308t tried everything except for serial. I remember having my vlan set to 100 and still wasn't able to work out. I'm certain that can't be the case, how we're you able to find out about that? I'll try to make time for another attempt this weekend if not I'm willing to donate this to anyone skilled for others to avoid this problem. Is it possible that this firmware flash changed to a higher voltage and just fried the chip? It gets hot pretty quick. Just assuming after watching this unrelated to firmware flashing.

Nvm, being pretty much the same it does mention vlan100. A lot of info I can use from there this weekend.

Okay, so I was able to SSH into my switch using Putty on with my VLAN set to 100. I didn't set a new password yet. I closed the session and now I can't re-open the session. I tried unplugging and replugging and waiting a few minutes and tried again. Still no connection open.

EDIT: NVM, I waited even longer and now I'm able to access the session again.

Make sure your computer Ethernet cable is plugged into the first port then set your VLAN to 100. Try another SSH session and you should be greeted with something that'll ask you to login. There is no set password yet.

Keep in mind that you're still running the initramfs image, which won't save settings - you now need to sysupgrade again using the sysupgrade image, to correctly initialize the overlay. Once that is sorted, you can install luci (the webinterface) and configure the switch as you wish.