Netgear GS308T OpenWrt install problem

Hello, here's another thread that needs help with installing GS308T,

I followed the instructions from GS108T

Downloaded and thru OEM firmware GUI with openwrt-realtek-rtl838x-netgear_gs308t-v1-initramfs-kernel.bin *

After upload and reboot, the device only have orange light up for about 3 seconds, than there's no more lights. Power cycle does the same no matter how many times I tried

Ping to doesn't respond. It's my first time trying to use VLAN tag 100, so I am not sure am I doing it right. I tried both on my Macbook Pro and RaspberryPi 4 with no anvil. **

I searched and I found the git commit , it have slightly different instructions (image0 instead of image1) I didn't double check on the OEM firmware GUI if it's the first image. (oh no moment)

So, what else I could do except for the last resort to solder and use JTAG? Is there any way I could to to get an recovery TFTP access?


Hey, is this patch is already in the snapshot build? What should I do then?

* wiki said to upgrade with a ramdisk, is initramfs and ramdisk the same thing? it's the other one that is not a sysupgrade file

** I followed the linux guide here, of course i substitute to my correct eth0

At least the VLAN 100 should not apply anymore (I removed it from the GS108T v3 wiki entry). The device should configure itself to with untagged VLAN just like any other OpenWrt device.

The LEDs dying on you are normal unfortunately, there is code around somewhere to drive these but it's not upstream or in OpenWrt yet AFAIK.

Set your client to a static, then try pinging or SSH'ing into FWIW, if you get access to the device again (you might need to open it up and tinker some with the serial - I managed to get it going without soldering, but you need a steady hand), you can use 22.03 pre-release images. Those come with a web UI by default and you can easily upgrade to stable releases later on; there's not much surplus value (if any) in running master builds on your specific device at this point.

Yes they're both the same.


Thank you for your tips!

Turns out just trying ssh to worked phew
My heart sank when at first I can't ping to (ICMP not working?)

Thanks again.

1 Like

Great! I'd downgrade to a 22.03 pre-release image, you can scp that over to /tmp, verify the checksum and then use sysupgrade -n $path_to_file. The -n is important, since it would be like you'd flash a new image from OEM cleanly. Without it you'd be preserving settings and master settings are only forward, not backward compatible (in case anything already changed between 22.03 getting branched and master progressing).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.