Netgear EX6120

The original software on Netgear EX6120 got so old that I barely can connect to it (only via Firefox with lowered tls and some other internal flag disabled). To not loose the access to the device I'v installed OpenWrt 22.03.05 and tried to configure same was as it was configured in original firmware. I've used wifi fast lane with 5GHz from router to extender and 2,5Ghz as new wifi network. Additionally I've got NAS connected to router (ethernet) and I want it accessible from the extended network.

Ideally I'd like to replicate that but feel free to provide better solution.

I've tried to follow https://openwrt.org/docs/guide-user/network/wifi/relay_configuration but failed every time. I'm 2nd day on it and I'm loosing hope.

So I finally managed to set it up but its terribly slow and signal strength is lower than the original wifi. Please advise where I have gone wrong:

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

/etc/config/network

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config interface 'wwan'
        option proto 'dhcp'

config interface 'bridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option htmode 'VHT40'
        option channel '40'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/10180000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid '5G-Original'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'Extended'
        option network 'lan'

Router IP: 192.168.0.1

So I went out of my way and did "dumbap" setup. Both 2.4 and 5Ghz speeds are terrible, I can't beat 100kB/s. And it is not the extent of my internet, I've 1,2 Gb fiber.

network

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.2'
        option gateway '192.168.0.1'
        list dns '192.168.0.1'

wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option htmode 'VHT80'
        option channel 'auto'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/10180000.wmac'
        option band '2g'
        option htmode 'HT20'
        option channel 'auto'
        option cell_density '0'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option network 'lan'

Obv I've removed those from above listing:
option ssid
option encryption
option key

Please let me know if you see any mistakes or have ideas regarding the issue.

Try the following:

  • reset your device to defaults.
  • configure only the following (configuring as a dumb ap):
    • lan interface IP address, gateway, and dns
    • turn off DHCP on the lan interface
    • wifi country code (this is not currently in your existing config)
    • wifi ssid name
    • wifi encryption type (recommended wpa2 for these tests)
    • wifi password
    • enable wifi

Then test the wireless connection with that device. If it is really slow, connect a computer to one of the other lan ports via ethernet and then test the throughput.

Report your findings.

Hello, thank you for your involvement.

So I did as you asked, and it seems the issue was that for wifi encryption I was choosing WPA2/WPA3 mixed mode and that crippled the transfer. When changed to WPA2 only I've DL/UL 19.24/36.31 Mb/s (2.4/4.5 MB/s) on 5Ghz, still not ideal and about 1MB slower in DL than I had with old firmware.

Technically I've got 1,2Gb/s / 90 Mb/s, can't really connect with ethernet cable (I don't have one long enough) but when I connected directly to repeater and had it grab internet through wifi from AP I had about 80 - 100Mb/s.

I'll play with it a lil bit more and see if I can squeeze some more transfer.

You won't get anywhere near your 1.2Gbps bandwidth on wifi. But you may be able to get somewhat better performance if you increase the channel width.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.