Netgear DM200 configuration. (Help make a definitive guide for everyone)

Hi all,

I would be grateful if you could take a look at this and tell me what I'm doing wrong.

For context, the DM200 is a single port xDSL modem from netgear, I've already setup an OPNSense router all ready to go this is the last link in the chain. (the router will try to login over pppoe)

I want the single port to act both as a LAN and a WAN so I can access it and configure it later but it needs to provide the bridge over to the dsl as well. So here's what I've done, but as soon as i reboot the DM200 it becomes inaccessible.

I should point out I left the default firewall rules.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7a:aad6:2107::/48'

config atm-bridge 'atm'
        option payload 'bridged'
        option nameprefix 'dsl'
        option vci '38'
        option vpi '0'
        option encaps 'vc'

config dsl 'dsl'
        option annex 'a'
        option ds_snr_offset '0'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'

config device 'lan_dev'
        option name 'eth0'
        option macaddr '...'

config device 'wan_dev'
        option name 'dsl0'
        option macaddr '...'

config device                                  
        option ifname 'eth0'                   
        option vid '106'                       
        option name 'LAN'       
                                
config device                   
        option ifname 'eth0'    
        option vid '204'        
        option name 'WAN'       
                                
config interface 'lan'          
        option type 'bridge'    
        option ifname 'LAN'     
        option proto 'static'      
        option ipaddr '192.168.1.1'   
        option netmask '255.255.255.0'
                                      
config interface 'wan'                    
        option type 'bridge'              
        option ifname 'dsl0 WAN'          
        option proto 'none'