Netgear DM200 Bridge Mode

Hello everyone!

I am struggling to get "bridge mode" set up on my Netgear DM200 which is connected (via the single ethernet port) to my router.

I tried the two setups listed in the DM200 guide: https://openwrt.org/toh/netgear/dm200
They don't seem to work. I must be missing a step.

I have a VDSL connection authenticated over DHCP (transfer mode: PTM)

I was hoping someone could guide me, or show me an example of their similar setup.

network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2e:7e71:989d::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
        option tone 'a'

config interface 'lan'                         
        option type 'bridge'                   
        option ifname 'eth0'                   
        option proto 'static'                  
        option ipaddr '192.168.1.1'            
        option netmask '255.255.255.0'         
        option ip6assign '60'                  
                                          
config device 'lan_dev'                   
        option name 'eth0'                
        option macaddr '3c:37:86:09:f2:b2'
                                          
config interface 'wan'                    
        option ifname 'dsl0.101'          
        option proto 'dhcp'               
                                          
config device 'wan_dev'                   
        option name 'dsl0'                
        option macaddr '3c:37:86:09:f2:b3'

config interface 'wan6'                   
        option ifname '@wan'              
        option proto 'dhcpv6'

I don't have such a setup or device, but it seems to me that you should have the following configuration:

config interface 'wan'
	option type 'bridge'
	option proto 'none'
	option ifname 'dsl0.101 eth0.101'

Then on the router configure the wan port on VLAN 101 with DHCP.
You don't need the wan6 anymore, it will be managed from the router.