Netgear DGND3700v1 help

I have a Netgear DGND3700v1 that I would like to use as an access point with VPN installed, it sounds like the LEDE firmware might do this but I am bewildered by the list of files that come up when I select downloads for this box, BCM6368.
Would anyone be able to advise me on which to try?

See Table of Hardware: Firmware downloads

Thanks, do I want the sysupgrade? I presume the factory is the standard one.

It appears I have installed a version of LEDE without a browser type interface so have been reading about telnet and trying to install LuCI but am not getting anywhere as can't get it the router to respond to telnet, would anyone know of anyway to get some firmware with a user interface on it easily?

What happens if you try ssh instead of telnet?

What did you install ?

I installed DGND3700v1-squashfs-factory.chk
Not sure if it is same as was getting a bit confused about SSH so ended up using 'putty' in SSH mode, I got 'log in as:' and entered admin, it then asked for password, from what I had read I didn't think it had a password but it didn't matter as I could not enter any text in response to that, don't know why, the window stopped responding to the keyboard except for the enter key.

Done a bit more reading and tried logging in using ' root' with putty/SSH and it appears to accept that and window does not lock up, it said to enter a password using passwd command but I seemed to get stuck again on that as it wouldn't accept anything I tried.

There is no password set if this is the first install of lede.
SSH Access for Newcomers

Re link above, I haven't had any warning about RSA fingerprint.
Is there any command I can enter in putty/SSH that will get it to install a different firmware, one with a GUI? I don't really want to get too involved with this version of LEDE, I wouldn't have installed it if I had spotted anything about it not having a GUI, all I got was a link to the files in response to my original enquiry and there wasn't any info on there.
I notice in the page from the link above that it says there may be a GUI but I can't access it.