Netgear DGN3500B Wi-Fi download speed is slow

Hi,

I am using a Netgear DGN3500B with Lede 17.01.4 behind my cable router over LAN. All in all it works quite well but there is an issue with the Wi-Fi download speed. I have a 200/10 Mbit/s connection but only getting max. 25 Mbit/s download speed over Wi-Fi whereas the upload is constant at 10 MBit/s. Sometimes down speed also drops below the 10 Mbit/s of the upload one and recovers again to about 20 Mbit/s. When I connect my PC via LAN with the router, I get the full 200 Mbit/s. And everytime I restart the router, the download speed starts about 40 Mbit/s and then decreases within 30 sec to about 20 Mbit/s.

Additionally the kernel log is full of "eth0: tx ring full".

I didn`t install SQM or changed anything important else. Just deactived DHCP for the LAN interface, so my devices get their IP addresses from my main router.

Another thing I noticed, is that LuCI cannot connect to the internet although I set the gateway address showing to my main router.

My current Wi-Fi configuration:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:0e.0'
        option htmode 'HT40'
        option country '**'
        option channel '13'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid '*************'
        option encryption 'psk2+ccmp'
        option key '*****************'
        option network 'lan'

My current network configuration:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxx:xxxx:xxxx::/xx'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config dsl 'dsl'
        option firmware '/lib/firmware/adsl.bin'
        option annex 'b'
        option xfer_mode 'atm'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.178.3'
        option gateway '192.168.178.1'
        option _orig_ifname 'eth0.1 wlan0'
        option _orig_bridge 'true'
        option ifname 'eth0.1'

config interface 'wan'
        option ifname 'nas0'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 '1'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

What can I do?
I hope anybody can help.

Thanks

I hope you found a solution for the above problem. If not, see if adding your main router's IP address at the Use custom DNS servers field helps your LEDE device connect to the internet. I see no DNS in your LAN network configuration.
I also un-checked the This is the only DHCP in the local network option.
I have a Netgear DGN3500 (not B) as a 2nd router, LEDE couldn't connect to the internet, with the above settings it's OK.
dhcplan-interface

Hi @vasilis74,
Thank you for your answer. You`re right.
I was missing the DNS server, although I already had un-checked the This is the only DHCP in the local network option . Now LuCI is able to connect to the internet.

But the problem with low download speeds are still there. Do you have these, too?

I 'm afraid not, but do you run any torrents on the LEDE device? If yes, stop them and see the result.

I would search for:

and if nothing found, I would open a thread about it. Anyway it seems relative with the download slow-down.

See also here:
r9337: eth0: tx dma ring full
although I didn't understand anything there...

See the LEDE documentation on configuring wireless...

https://lede-project.org/docs/user-guide/start#wifi_configuration

Common issue are not checking WMM (which will result in 802.11n routers falling back to 802.11g speeds), and setting channels to "auto" instead of channels 1, 6, and 11 (no overlapping) for 2.4 Ghz. If you are in the US, start with channel 153 for 5 Ghz.

No, I don´t run any torrents.

Did that already. It might be connected with this commit:

https://github.com/lede-project/source/commit/8f02f7c7f8e3577535ef6dc355438051d5616925

The issue was obviously fixed correctly on xrx200, but not on xway.

Therefore opening a new thread would be the correct way.

Yeah, it could be related, too.

I read that and WMM is enabled by default. But also choosing auto channels hasn`t improved the situation yet.

This device just provides 2.4 GHz WiFi, so there`s no chance to set the channel to 153 :wink:.

But thanks anyway.

I think you misunderstood...

Select channels 1, 6, or 11 for 2.4 Ghz.

Since you have this router bridged, do you have wireless turned off on the cable router?

Oh, you´re right. After reading your previous answer twice I set the channels manually to 1, 6 or 11, but still no improvements. I finally let it at 6.

No, because I´m using the Netgear to expand my Wi-Fi Network. But the cable router is on channel 1 and so there shouldn`t be that much interference between both routers.

That's your problem. A bridged modem can't work as an extender.

You need to either purchase a range extender, or go to a wireless mesh design.

Keep in mind that using extenders halve the wireless speed.

@jwoods @ReverseFlash2

You probably know already, but in any case I want to remind you that you don't have to use the 1st router at bridged mode, when you want to add a 2nd router to extend your network, so I think you don't have to purchase a range extender.
I have set my 1st modem/router at PPPoA 8/35 VC/MUX. It's IP (I changed the default) is 192.168.1.222, DHCP (also custom) 192.168.1.21 to 192.168.1.221. So I leave the ...1 to ...20 IPs range for static IPs. I left the default 192.168.1.1 IP at the LEDE (2nd) router and did the changes I mentioned above: about only DHCP and custom DNS.
I set the same SSID and WPA2 key at both routers, the only difference is the different channel (5 or more channels higher each other, 1 and 6 or 3 and 8 or 3 and 11 etc).
All the above are for ADSL2+, I don't know about cable ISPs and how bridged setup works there.

@jwoods @vasilis74

I absolutely did the same. Setting the same SSID and key so my devices think that there's just one WiFi network.
I'm just wondering why the wifi speed over the Netgear router is so slow, because setting up the same with another router, which runs with original firmware, in my network provides the full bandwith over WiFi.

So the setting is:

Cable router with integrated modem provides Wi-Fi and LAN network

-> Netgear router with LEDE connected via LAN to the cable router provides Wi-Fi network with same SSID and key at 20 MBit/s

-> other router connected via LAN to the cable router provides Wi-Fi network with same SSID and key at full bandwith

The other router is in LAN bridge mode.

Following the manual would set the Netgear router up as Wi-Fi bridge, but I want it via LAN so relayd shouldn't be necessary (correct me if I'm wrong).

So just setting up the same SSID and key, the right IPv4 address, gateway and DNS server in the LAN interface (like in posts #1 and #2) to work with the LAN network provided by the cable router, disable its DHCP and enable the Bridge interfaces (creates a bridge over specified interface(s)) option with ticked with Switch VLAN: "eth0.1" and Wireless network, should be the right way to expand the WiFi network, shouldn't it?

Same settings on my LEDE Netgear DGN3500. I forgot to say that at the WAN and WAN6 Interfaces, at the Advanced Settings I unticked the Bring up on boot boxes and disabled them.

But about the speed...

I did some more speed tests and the results are different than with the previous Android-app I used.
Next screenshot is the previous app, Speedcheck Pro. 2.32Mbps was my 1st (original firmware) router, 2.46Mbps was the 2nd (LEDE) router. The speed test server is probably at the other side of the Atlantic ocean, so the results were inaccurate.
speed

The newer speed tests are with a server at my town, the results are closer to the speed that my 1st router says that is synchronized, which is:
DSL
Line rate - upstream: 1020 Kbps
Line rate - downstream: 14567 Kbps

Results of the 1st (original firmware) router:
Screenshot_20171228-031333

Results of the 2nd (LEDE) router:
Screenshot_20171228-032321

And these are 2 just WiFi speed tests with FRITZ!App-WLAN between routers and Android phone, not with an Internet server out of my LAN.

Results of the 1st (original firmware) router:
Screenshot_20171228-044912

Results of the 2nd (LEDE) router:
speed

Therefore testing inside the WLAN the LEDE router is faster, testing with an Internet server through WiFi the LEDE router is slower, probably because LEDE is 2nd and there is inserted the 1st router... on not for that, because:

I don' t know why and I have not tested yet WiFi speed with another original firmware router I have connected in my LAN, I will do it.
I was wrong at the 4th post saying that I had not lower speed with LEDE's WiFi.
I have not yet tested LEDE (Netgear DGN3500) as modem/router, as 1st router, maybe the next days I will and send the results.

This is a WiFi speed test with an Internet server in my town, using as 2nd a router with its original firmware, connected to the same 1st modem/router.
Screenshot_20171228-175723

This is a WiFi speed test between the 2nd original firmware router and my Android phone, without an Internet server.
Screenshot_20171228-185801

So the the fact that this is also connected as 2nd router gives a lower speed, although the clean WiFi speed is high. This makes me think that every router is 2nd gives lower WiFi speed.

Te next screenshot is a speed test with an Internet server in my town, using my Android prone and the LEDE Netgear DGN3500 annexA, connected as modem/router without any other modem.
Screenshot_20171229-042353
The speed is even better than the 1st original firmware modem/router, so for once again the reason for low speeds seems to be the connection of routers as 2nd.

I am not an expert or professional, therefore there could be factors I cannot think about, giving inaccurate results.