NetGear D7800 WAN Config for AUS TELSRA NBN

I'm on 100Mbps FTTN with the VDSL connection and can't get the D7800 to get any internet traffic. I'm using the Telstra supplied modem with DHCP turned off, wireless off, firewall off, and bridged mode on. I connected the LAN 1 port from the modem to the Internet port of the D7800 and the link connection light is on. I tried different WLAN settings such as DHCP and unmanaged, and tried accepting everything in the firewall settings for WLAN. No errors display in the log, it just said link established and that's it. I can see TX packets but RX packets remain at 0. LAN traffic is fine. I can't connect to the modem at all once it's bridged though I don't know if that Telstra modem will tell me too much anyway. I did find an older thread somewhere where a person got it working with a switch sitting in between though I didn't see any resolution for getting it working directly from the modem to the D7800.

I've since restored the D7800 back to stock FW and using it as the modem/router until I can gain a more solid direction to take on the next attempt.

You need to investigate which settings you require for your ISP, most importantly VLAN tagging, PPPoE access credentials, etc.

(keep in mind that OpenWrt doesn't support the internal xDSL modem of the D7800, the other question would be if the external modem really behaves in bridge mode - especially considering the additional complexities of phone/ VoIP/ SIP)

Most routers for the NBN need a VLAN tag on the WAN etherframes ( EDIT: HFC ) .... it's an easy fix..... once you figure out the correct method........ and TAG. @slh makes a good point though..... often any additional services that come down the pipe are split off so you may lose them......

usually VLAN2 ( whirlpool forum should have some decent info about your ISP and what is required )


So you question may morph into: "How do I set WAN vlan tagging on openwrt"

The required settings should be documented somewhere (small- and medium businesses often require better VPN routers and face the same questions), usually rather hidden or requiring third party information, but it should be available.

No worries, thanks for the info and advice, I was suspecting tagging as it was mentioned somewhere in my research, though that's beyond my knowledge at the moment. I might ask over on Whirlpool, someone will know the config for sure. I don't care if I lose VOIP, I never connected a phone to it, all I ever got on my home phone was scam callers and marketers, they don't seem to bother me on my mobile. I'll keep an eye on this thread. The Telstra modem is a F@st 5355.

OK so I just took a quick look for you and I might have given you the wrong information.....

It seems like VLAN2 is for HFC connections only.... if that is the case..... you might need a crossover cable...... or switch in between like you mention......

The info I saw was that NON-HFC is presented as IPOE ( ethernet dhcp ).... aka NORMAL.

If you connect a laptop instead of the router.... you can verify that it works like that....... and a laptop probably would not need the crossover due to better MDI-MDI-X whatever handling ( auto-crossover function )

Digging Deeper .....

OK, finally got it working. The key was to enable MPoA and bridged mode (the checkbox at bottom-left). Then – and this is where my lack of networking understanding really threw me – I should *not* be expecting the modem to obtain an IP. Instead, my router needed to

Based on your symptoms ^ one of those seems likely....

You lucky.... i've had the same mobile number for 15+years..... scammers non-stop!

If you find that the modem MTU is set at 1492.... you might improve overall performance by setting the WAN interface to the same MTU......

The other thing to keep in mind is that if you don't clone the previous WANMAC..... you'd be best to wait 10 minutes before powering up ( connecting to the connection )...... This trips up alot of people with WAN device changes not working.....

Thank you, that's a place to start at least. I'm going to slightly re-think my strategy and look at replacing the modem, everything I'm reading is that the F@st 5355 is complete garbage. My experience of it has been too, it drops out frequently and takes an age to get back online. There should be something pre-loved out there going on ebay or gumtree that'll do the trick, I have the Whirlpool list to work from:

I just lashed out and bought an ebay special TP-Link TD-W9970, it's recommended on Whirlpool as a good bridging modem, hopefully I'll be able to resume attempting the setup next weekend.

Hai there.

i‘ve got a problem with my d7800 when i connect my 100mbit modem to the wan port. see D7800 wan not working with 100Mbit

Yeah, this is the thread I referred to earlier. Once I get the new modem I can test things next weekend to give some more feedback though little insight to the issue if it happens with me.