Netgear D7800 not flashing after tftp transfer


I'm getting an issue when trying to flash my netgear d7800 (currently running the lastest netgear r7800 firmware I followed the instructions given here :

I can get the recovery mode with power led flashing white, I can ping, I can transfer the firmware (19.07.2 factory), but once it is transferred nothing happens. The led continues to flash white, even 2 hours after transferring. If I restart the router, it will boot with the official firmware...

I don't know if I'm doing something wrong or if I have something to do to trigger the flashing process after the firmware transfer?

If you use the Netgear's built-in TFTP recovery flash mode, it starts flashing the image right after receiving it.

How do you transfer the firmware? Using some GUI tool, so that you can see the progress and completion of the transfer? Or are you trying to use some cmdline command?

(I use tftpd64 from jounin, and it works just nicely with R7800)

I have tried several command line tool under linux such as atftp or tftp-hpa, it seems to transfer correctly:

put openwrt-19.07.2-ipq806x-generic-netgear_d7800-squashfs-factory.img
putting openwrt-19.07.2-ipq806x-generic-netgear_d7800-squashfs-factory.img to [octet]
Sent 8388737 bytes in 0.9 seconds [74103806 bit/s]

The only strange thing being that the transfer is very fast, it lasts about 1 second (I see the LAN port led blinking during transfer), and the tftp client does not always report a relevant time for the transfer.

I'm just thinking that I have an old laptop with windows XP, I'll give a try to see what happens if I try to flash from it. I'm just not totally confident in using that laptop to do that since sometimes the screen stops working.

I've just tried with tftpd32 from a windows XP laptop and nothing more. The firmware is transferred in 2 seconds and the power led continues to flash white...

Can you flash there a normal D7800 OEM firmware via TFTP?
(Right now you apparently have a R7800 firmware in D7800, right?)

You might flash the D7800 firmware just to test that you can flash via TFTP.

Actually the netgear interface proposed firmware as the latest one (which seems to be the latest R7800). The latest version proposed for D7800 on their website is

I have just tried to flash through TFTP and same conclusions, it transfers (a little bit more than 6 seconds since this one if bigger than openwrt install) and then nothing, the power led continues to flash white and that's all.

So... that was a really stupid problem, the router is a R7800 and not a D7800 as I've been told when I got it from the woman who sold it to me...

TFTP flash works like a charm as soon as you use the right firmware...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.