Netgear D7800 - No internet

I got a second hand Netgear D7800 yesterday. It worked fine on stock firmware. I flashed OpenWrt stable via TFTP and it runs fine, apart from it having no internet access.

I have a vague recollection of reading something about ports being swapped, but I can't find the reference now. Anyway, I've tried connecting the internet cable into the WAN port, as well as various LAN ports. I've tried changing the interface of WAN under physical settings for WAN.

I'm using a PPPoE FTTC connection. ie. there's a locked down box that typically connects to the WAN port on routers, and that's all the configuration that's needed (apart from entering the username and password for my provider).

It might help to know your ISP, as it may have specific settings for their flavor of PPPoE if you’re connecting directly to the drop. If it’s Ethernet between the ISP box and your router, check to see if the WAN interface is getting an IP address.


Just to clarify here, I read this as you using VDSL with a(n external) VDSL modem - if so, most ISPs require a specific VLAN tag (specific to the ISP in question) to be used on WAN.

1 Like

Have you checked MTU as well?


Leaptel. I'm in Australia, so you wouldn't have heard of them. I know that the PPPoE doesn't require VLAN tagging in my case. I've used dd-wrt on a R7000 without any issues.

Yes, it's ethernet between the ISP box and WAN. It just reports that connection failed.

The fibre comes to the curb and then uses the copper up the driveway to the ISP box. The ISP box has a built in modem of sorts, so I'm using the D7800 as a router only. I'm not sure if I need to adjust any settings in OpenWrt as a result of this.

Use the Network->Switch page in Luci to identify diagnose the ports


I've got the ethernet cable in LAN port 1 and the ethernet cable to the ISP box in the WAN port. Here's a screenshot of the switch page.

In interface > wan > advanced
Change MTU to 1452
If it works bump it up to 1480

nb: as mentioned... vlan 100 comes up alot with these connections... i don't know if the OEM auto detects MTU/VLANID.....

Use a PC direct.

Verify the WAN mac address is the same for OEM firmware on the WAN port.... most NTD don't like seeing different MAC addresses. Or you could just power down the VDSL modem for 10 mins....

Rarely a call to your ISP is required to "fix" "stuck" MAC associations.... But setting it to the old one is and easy way to test.

Network > interfaces > advanced > mac

Change your WAN to DHCP ( not pppoe and see what happens ) ... set it back if no change ... you could also try PPPoATM

As for swapping the ports, in the page above swap setting between CPU0 and CPU1 if you want to test that... swap it back if no change... you may need to connect your PC to the WAN port to do that.


This didn't work.

What do you mean exactly? Enter my PPPoE details into the computer?

I've had this problem before with another ISP, but they used DHCP. I've happily switched between routers without even ending the connection with other routers with this provider.

I swapped this and played around a little. No difference.

1 Like

Try this it seems working pretty well.

Try what exactly?

see anything in

> logread

or graphically .... there is a logpage somewhere...

does your ONT have multiple ports?.... your 100% certain it's the same port / cable combination as was working with OEM firmware?

-have you tried powering down both devices ( mostly the VDSL box ) for 12mins?
-did you try tagging 100?

can you paste output from this in code tags

cat /etc/config/network

remove user/pass if it's in there
use putty.exe to login to router ip.

and yes.... a ppp direct from a laptop > NTE/VDSL-modem would rule in / out a few things....

1 Like

It just adds this to the system log over and over.

Thu Jan 31 00:03:52 2019 daemon.notice netifd: Interface 'wan' is now down
Thu Jan 31 00:03:52 2019 daemon.notice netifd: Interface 'wan' is setting up now
Thu Jan 31 00:03:52 2019 daemon.err insmod: module is already loaded - slhc
Thu Jan 31 00:03:52 2019 daemon.err insmod: module is already loaded - ppp_generic
Thu Jan 31 00:03:52 2019 daemon.err insmod: module is already loaded - pppox
Thu Jan 31 00:03:52 2019 daemon.err insmod: module is already loaded - pppoe
Thu Jan 31 00:03:52 2019 pppd[1950]: Plugin loaded.
Thu Jan 31 00:03:52 2019 pppd[1950]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Thu Jan 31 00:03:52 2019 daemon.notice pppd[1950]: pppd 2.4.7 started by root, uid 0
Thu Jan 31 00:04:08 2019 daemon.warn pppd[1950]: Timeout waiting for PADO packets
Thu Jan 31 00:04:08 2019 daemon.err pppd[1950]: Unable to complete PPPoE Discovery
Thu Jan 31 00:04:08 2019 pppd[1950]: Exit.

No, it doesn't. Yes, I'm 100% sure I'm using the same ports and cables. It's a pretty straight forward setup.

I restarted it, but didn't leave it off for 12 minutes. It's hard even switching between routers, as my family get annoyed when the internet is down.

Where exactly do I add this? The only place that I can find is on the switching page, but I'm not exactly sure how to do it.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''
config globals 'globals'
        option ula_prefix 'fd93:c13b:4349::/48'
config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'
config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 'auto'
config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
config switch
option name 'switch0'
        option reset '1'
        option enable_vlan '1'
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'
1 Like

Sweet as.

Do in the best quiet time that suits your world. Not so helpful on Easter weekend!

For vlan tag.... I believe..... You would;

interfaces > wan > edit
[tab] > physical
interface + [dropdown] > custom interface
[enter] eth0.100
[ save apply blah blah ]

Switch to TAG on that port
network > switch > add
eth0+tagged ( internal )
eth1+off ( default )

I'm not the best with this stuff... so best to wait for more input....

Simple to change back tho....

1 Like

Thanks for that. I'll give it a try.
However, it's probably worth me noting that I bought (and I'm returning to Amazon) a GL.Net B1300 earlier in the week and it didn't require any tweaking to connect to the same provider, either with its customised version of OpenWrt or with the vanilla OpenWrt that I flashed. This leaves me wondering whether the D7800 might end up on eBay and me replacing it with an EA6350v3 or an RT-AC58U. I'm not sure that many people on here are using the D7800.

I tried adding the VLAN tag and it made no difference. The WAN interface definitely is eth0 in the physical settings, right?

I came across D7800 wan not working with 100Mbit, and I'm wondering if sticking a switch between the D7800 and NTD is the next step. If only my wife wasn't up and whinging about her wifi not working, I could do the 3 minute test now. :wink:

Putting a switch between router and modem is definately worth a test. As would doing a factory reset (firstboot) on the d7800 and start over from scratch (as the switch config should be o.k. as is, with your previous tests maybe skewing the results).

1 Like

I just tried it and it didn't work.

I did that yesterday after changing various settings.

Maybe it simply doesn't work and everyone is using the R7800, so no-one (but me) is reporting issues!

Why is there 2 WAN interfaces? One with VLAN ID 2 untagged, and one tagged 100?

Looking at this youtube video on setting up VLANS there is only one.

1 Like