Netgear D7800 - Memory mod - DTS adjustment

Hi all,

I have been trying to follow the info in this post on the forum.

In the past few years, I have never had the full memory show when using Openwrt. I even flashed it back to standard firmware to check, incase I was going crazy, and it showed the full size as specified in the link above.

I have downloaded the image builder, and am aware of how it works etc. However, I am rather stuck on how to access the area on how to adjust the memory size. I look into the image builder files and the directory " /target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8064-d7800.dts" (as linked in a few different threads online) does not exist, otherwise it would be a simple case of editing the file.

Please could you help me? Thank you!

You have to compile the whole image by yourself. Imagebuilder won‘t help you here.

On compiling the source you can edit the file.

1 Like

Ah I see - that seems rather more complicated than I thought.

I'm still at a loss on how to do that tbh. Is there anywhere I can learn?

Also, why does the system not see the correct amount of ram in the first place?

EDIT: this video is awesome: https://www.youtube.com/watch?v=m9uWM6QUnpM - it's compiling at the moment, will report back!

Also, I realised a potential reason for why the correct amount of ram isn't shown; is it because the image is built for Netgear D7800 X4, and not Netgear D7800 X4S?

It worked! Full ram showing :grinning:

If anyone would like the build, comment on here and i'll send it over.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.