Netgear Centria WNDR4700/WNDR4720 Build issues

Hi!!...

First of all, thank you very much for all the support to all the people involved in this project, It's a wonderful thing to have options beyond the view of manufacturers.

I'm writing this topic, since I couldn't find any regarding this particular model, maybe it's my router that has issues or it's the build itself. What i had was: 5GHz didn't work, it took a very long time to renew (like 3 minutes), the WAN IP address and a couple of other things that I can't remember at this very moment. It was like 2 weeks ago that i tried.

I wonder, Has anybody had issues like this? I remember trying first the Developers build and I had a lot of issues, then reverted to Release build, which I used like 3 or 4 days, then back to stock. This last part was very funny, actually. When I tried to revert to stock, It didn't let me via LuCI firmware upgrade, so i had to crash it and upload the stock firmware via TFTP. After it booted, all my old settings were there! It was very scary for me to wait for this to work, since I didn't know that it had a TFTP Server working which I found out when changing from dev to release

I know this post needs editing but I'm writing as soon as it comes to my mind. I'll fix this later

Thanks for your attention, I'm waiting for your comments!

Hello!

no update?

As for the

"5GHz didn't work, "

There are a few things that could be the cause. But without logs, I have to guess what's going on. So, please keep in mind that these are just suggestions.

Both wifis are disabled in the default configuration and need to be enabled manually. Either by editing the /etc/config/wireless file manually (remove the disabled options)
or via uci or in the LuCI-webinterface interface.

Also, on certain 5GHz channels, he hardware has perform a "Channel Availability Check" (listens for 60 seconds) before it can operate on the channel (i.e. start up the AP). So the AP will not come up immediately, especially if you set the channel to auto.

it took a very long time to renew (like 3 minutes), the WAN IP address

Might be because the WAN port status is not monitored directly for link up/down changes. the WAN port is managed by the AR8327 switch (together with the other LAN-Ports). So the daemon/service that is responsible for WAN IP changes has to
have a method to detect them by itself. (So, I guess that's where the delay is coming from?). It's possible to mitigate this with software atleast a bit for WANs that are managed by dhcp:

https://github.com/chunkeey/apm82181-lede/commit/31c8424b3d431692d12fe1ea59a7fce8bdb46bb3

(Or once DSA for the AR8327 switches finally rolls around)

yeah, this is true and very unfortunate.

https://github.com/openwrt/openwrt/commit/c555b524c7e55f54aea69d11113bc36326aabafe

This situation was sadly caused by a the switch to GCC 7.3 and the ever increasing kernel binary size. So in order to keep support for the device in the upcoming 18.06 and the future, the WNDR4700's flash had to be re-partitioned and this is not possible to do that with sysupgrade. The WNDR4700 wasn't the only device which had this issue due to the kernel size though. The newer IPQ806x-based Netgear routers (R7800, D7800, R7500, ...) suffered from this too: :frowning: https://lists.openwrt.org/pipermail/openwrt-devel/2018-May/012344.html

WARNING: This breaks sysupgrade! Flashing a firmware containing this
changed partitioning from an older image with 2 MB reserved for the
kernel partion requires the tftp recovery procedure, thereby losing
all settings.

Chunkeey!! I'm pleasantly surprised to see your reply. I thought that this particular model was almost dead and I wrote this thread for myself, almost. I haven't updated this since this WNDR4700 is my only working router, I have an E1200, an E900 and a WRT54GSv7 waiting for JTAG, all bricked on upgrade, so I'm kinda scared of flashing it again.

Regarding 5GHz, I was pretty sure that I enabled it via LuCI, since is the AP that i use the most on my phone, no big deal on it if it does not work.
Regarding WAN Port: This could be a life saver! I tried to write a little script that if interface IP addrs = 0.0.0.0 then renew the interface but didn't work. If this util works, i can change back to LED right way! this is my main issue with stock firmware; when my ISP dies (doesn't happen a lot but it does) it can be like 15 minutes or more after the ADSL modem reconnects to have a working internet. I have to manually renew the interface like 8 to 15 times in order to get it working again.
Regarding repartition: I read about it but I didn't know how to perform it and, with my previous experience with DD-WRT, I wasn't exactly thrilled to do it. I thought that if I do this, I won't be able to go back to stock, if the need arises.

So, Do you recommend for me to flash release or dev?

Cheers!!

Well, I've installed openwrt-apm821xx-nand-netgear_wndr4700-squashfs-factory.img, from date 20180616 and It works a lot better that the last dev image I used last time (20180602). It's running right now and it has the same issue in 5GHz than the others builds, showing the interface as up but with 0%.
Regarding the "Patches" that chunkeey mentioned, I didn't know how to install them, I looked into the pages that were mentioned but I can't figure how to go from there.
I have the logs, but this doesn't let me upload them. They are here, in a RAR5 file:
Exar_Kun Logs

I hope that you can see what's going on, i'm reverting to stock at this very moment, 'cause internet stays on like 10 minutes and I have to restart the modem in order to have it back.

Ok after a LONG time and a lot of sweating and swallowing hard, I managed to go back to stock firmware.

It took me this long 'cause I didn't remember how I crashed the existing LEDE the last time, It was accomplished perfoming a *sysupgrade -r -f WNDR4700-V1.0.0.56.img which softbricked the router. I tried inmediately to flash via TFTP using TFTPD64 and failed every single time, Itried no less than 30 minutes to flash it, rebooting router, changing cables, changing software (Windows TFTP client, TFTP and another from WinAgents all of them failing to sedn the file. Since this is my only working router, I had to resort to use my cell phone to look for answers . The only piece of advise that I found was to use a switch between the pc and the router, since the latter is rebooting constantly, the wired interface goes down every time and could cause the software to fail. To my dismay, it didn't help either. I thought it was another expensive paperweight and What did I do different that the last time? could it be that this LEDE version does not include a TFTP Server in bootrom? I do not why but my brain didn't stop thinking what has happened and it came to the simpliest solution:
DO A 30-30-30!!
That worked!!! That was the missing step! Altough I don't recall doing it the last time, nevermind that ...

So, lesson learned. ALWAYS do a 30-30-30 after softbricking, it may save your "Life"

The reason that i went back to stock is that for no apparent reason, the WAN interface stops working/. ifconfig down/up didn't seem to do anything (no renewing IP Address), the only way to have internet back was either to turn off the modem or (which I found out later on) unplug the ethernet cable. Sometimes it worked 20 minutes, others just 2. I don't know if this is modem-related, since this is a repaired modem and it's the only one I have at hand

Hope this helps anyone else (or myself) in the future...

Cheers

If your problem is solved, please consider marking this topic as [Solved].

Well, actually, the problem is NOT solved. I just simply went back to stock because of intermittency in the WAN port, which makes it almost unusable, at least for me. Since I don't know if there are other users that have this particular router, I wrote this to see if it can help them